Error "ldconfig: /usr/lib/libxml2.so is not an ELF file"

This forum is for all other ARMv5 devices

Error "ldconfig: /usr/lib/libxml2.so is not an ELF file"

Postby hp79 » Sun Mar 04, 2012 1:41 am

Hi, I have a B01 pink pogoplug, and have samba, minidlna, and httpd setup.
I was following https://wiki.archlinux.org/index.php/LAMP#PHP LAMP setup instructions, and I'm stuck on setting up php part.

Whenever I try to install php by doing:
pacman -S php php-apache mysql


I get an error message at the end saying:
ldconfig: /usr/lib/libxml2.so is not an ELF file - it has the wrong magic bytes at the start.
ldconfig: /usr/lib/libxml2.so.2.7.8 is not an ELF file - it has the wrong magic bytes at the start.
ldconfig: /usr/lib/libxml2.so.2 is not an ELF file - it has the wrong magic bytes at the start.


I also get this message when I remove these packages using:
pacman -R php php-apache mysql


Because of this, I can't get finish setting up the php and mysql part. Apache http web server works fine.


Ignoring all this, when I try to proceed with the instruction, I get stopped where I restart the httpd service:
rc.d restart httpd

Then it gives me:
:: Restarting Apache Web Server [BUSY]
httpd: Syntax error on line 117 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp5.so into server: /usr/lib/libxml2.so.2: invalid ELF header
[FAIL]


I installed Archlinux using the script that was provided for the Onyx pogoplug, and did all updates.
What could be wrong?

I also tried to reinstall glibc, and this is the message I get.

[root@pogoplug var]# pacman -S glibc
warning: glibc-2.15-5 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Targets (1): glibc-2.15-5

Total Download Size: 7.49 MiB
Total Installed Size: 32.96 MiB
Net Upgrade Size: 0.00 MiB

Proceed with installation? [Y/n] y
:: Retrieving packages from core...
glibc-2.15-5-arm 7.5 MiB 319K/s 00:24 [############################] 100%
(1/1) checking package integrity [############################] 100%
(1/1) loading package files [############################] 100%
(1/1) checking for file conflicts [############################] 100%
(1/1) upgrading glibc [############################] 100%
sbin/ldconfig: /usr/lib/libxml2.so is not an ELF file - it has the wrong magic bytes at the start.

sbin/ldconfig: /usr/lib/libxml2.so.2.7.8 is not an ELF file - it has the wrong magic bytes at the start.

sbin/ldconfig: /usr/lib/libxml2.so.2 is not an ELF file - it has the wrong magic bytes at the start.

Generating locales...
en_US.ISO-8859-1... done
de_DE.ISO-8859-1... done
de_DE.ISO-8859-15@euro... done
en_US.UTF-8... done
Generation complete.
ldconfig: /usr/lib/libxml2.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libxml2.so.2.7.8 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libxml2.so.2 is not an ELF file - it has the wrong magic bytes at the start.


I see that in http://www.archlinux.org/news/minimum-kernel-requirement-2632/, there's a post about glibc 2.15-5 requires kernel 2.6.32, and my kernel is 2.6.31.6_SMP_820. Does this mean this is the root of all the problem?
If so, which version should I install, and how can I install the older version of glibc?


Thanks for reading my long post!
hp79
 
Posts: 9
Joined: Fri Feb 24, 2012 6:46 am

Re: Error "ldconfig: /usr/lib/libxml2.so is not an ELF file"

Postby kmihelich » Sun Mar 04, 2012 2:47 am

Do pacman -Syu, then install again.
Arch Linux ARM exists and continues to grow through community support, please donate today!
kmihelich
Developer
 
Posts: 997
Joined: Tue Jul 20, 2010 6:55 am
Location: aka leming #archlinux-arm

Re: Error "ldconfig: /usr/lib/libxml2.so is not an ELF file"

Postby hp79 » Sun Mar 04, 2012 6:35 pm

kmihelich wrote:Do pacman -Syu, then install again.

I already did all that.. It seems there's nothing else to update.

[root@pogoplug ~]# pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
aur is up to date
:: Starting full system upgrade...
warning: initscripts: ignoring package upgrade (2011.07.3-1 => 2012.01.3-1)
there is nothing to do
[root@pogoplug ~]#



EDIT on 3/15/2012:
I reinstalled ArchLinuxARM-oxnas-latest.tar.gz to a clean usb flash drive, and re-did everything. Now there are no errors such as any of the above. Then I copied the whole partition to my usb hdd's first partition which is also 16GB using gparted live cd image inside VMWare. Everything is working fine now.
hp79
 
Posts: 9
Joined: Fri Feb 24, 2012 6:46 am


Return to Community Supported

Who is online

Users browsing this forum: No registered users and 2 guests