Can't compile edimax ew-7811un driver

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

Can't compile edimax ew-7811un driver

Postby oedzoerd » Tue Jun 18, 2013 7:11 pm

Hey everyone,

I've recently got the Edimax ew-7811un usb-wifi adapter for my RPI. But now I'm running into the problem that I cannot compile the driver for this device. I've searched the internet for answers and tried them, but nothing seems te work.
Arch-version: 3.6.11-12-ARCH+
USB-wifi adapter : Edimax EW-7811un
Adapter Chipset: Realtek RTL8188CUS
Downloaded driver: RTL8192xC_USB_linux_v3.4.4_4749.20121105.zip from http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true under RTL8188CUS -> Linux

When running the install.sh script after unpacking I get the error:
Code: Select all
Makefile:564: /usr/src/linux-3.6.11-12-ARCH+/arch/armv6l/Makefile: No such file or directory


I've checked the directory, and there is no armv6l directory in /usr/src/linux-3.6.11-12-ARCH+/arch/, only a directory called arm.

Has anyone have an idea on how to fix this? I tried things like adapting the Makefile, but can't get it working (as I don't really know what to adapt...). I'm pretty new to Arch linux (and to Linux overall), but I'm starting to find my way around.

Any help is greatly appreciated.

Thanks!
oedzoerd
 
Posts: 2
Joined: Tue Jun 18, 2013 6:53 pm

Re: Can't compile edimax ew-7811un driver

Postby moonman » Tue Jun 18, 2013 7:26 pm

You driver is in the repo? try it
Code: Select all
pacman -Sy dkms-8192cu
PogoPlug v2 Pink | Seagate GoFlex Home | Raspberry Pi B 512
----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] How to reinstall ALARM from scratch | [armv5] How to install my.pogoplug.com service
moonman
Developer
 
Posts: 2190
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Can't compile edimax ew-7811un driver

Postby crashmaster » Tue Jun 18, 2013 8:41 pm

I have the same stick. it runs with "8192cu" module (included in the standard kernel package) which you should have.
Is it loaded (modprobe 8192cu) ?
crashmaster
 
Posts: 86
Joined: Wed Mar 13, 2013 1:00 am

Re: Can't compile edimax ew-7811un driver

Postby oedzoerd » Wed Jun 19, 2013 5:52 pm

Thanks! I've got it working. Should've checked wether it was already there before jumping to conclusions...
Thanks, both of you!
oedzoerd
 
Posts: 2
Joined: Tue Jun 18, 2013 6:53 pm

Re: Can't compile edimax ew-7811un driver

Postby pepedog » Wed Jun 19, 2013 6:13 pm

Nice and easy to get working too
Image
pepedog
Developer
 
Posts: 2171
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 2 guests