GoFlex Net Pogoplug installation problems

This forum is for Marvell Kirkwood devices such as the GoFlex Home/Net, PogoPlug v1/v2, SheevaPlug, and ZyXEL devices.

GoFlex Net Pogoplug installation problems

Postby rogerdygas » Mon Oct 22, 2012 8:54 am

I have used "How to install Pogoplug software on ANY armv5 with ALARM" I have done all the steps, but when I start pogoplug it shows on the web interface as no drive attached, when I go to check my hbplug.conf file (/usr/local also /usr/local/cloudengines/bin/) for any mistakes the conf file shows as nothing in it, if i add the info again and save I get [error writing ./usr/local/hbplug.conf: No such file or directory ].

Please could somebody help?
rogerdygas
 
Posts: 33
Joined: Mon Oct 08, 2012 4:29 pm

Re: GoFlex Net Pogoplug installation problems

Postby moonman » Mon Oct 22, 2012 9:00 am

What are you using to edit the file and what OS? I hope it's not windows.
PogoPlug v2 Pink | Seagate GoFlex Home | Raspberry Pi B 512
----------------------------------------------------------------------------------------------------------------------
[armv5] How to update U-Boot for kernel v3.2 and newer | [armv5] How to reinstall ALARM from scratch | [armv5] How to install my.pogoplug.com service
moonman
Developer
 
Posts: 2024
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: GoFlex Net Pogoplug installation problems

Postby rogerdygas » Mon Oct 22, 2012 6:32 pm

Im using the nano comand in putty for windows.
rogerdygas
 
Posts: 33
Joined: Mon Oct 08, 2012 4:29 pm

Re: GoFlex Net Pogoplug installation problems

Postby moonman » Mon Oct 22, 2012 7:45 pm

you should be able to:
Code: Select all
/etc/rc.d/pogoplug stop
rm /usr/local/hbplug.conf
nano /usr/local/hbplug.conf


Add the config

Then CTRL+X in nano and answer yes to save file.

Run /etc/rc.d/pogoplug start.

Also before doing this check your filesystem for errors on another computer. Make sure you copy the created svcid= line to /usr/local/hbplug.conf
PogoPlug v2 Pink | Seagate GoFlex Home | Raspberry Pi B 512
----------------------------------------------------------------------------------------------------------------------
[armv5] How to update U-Boot for kernel v3.2 and newer | [armv5] How to reinstall ALARM from scratch | [armv5] How to install my.pogoplug.com service
moonman
Developer
 
Posts: 2024
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: GoFlex Net Pogoplug installation problems

Postby rogerdygas » Tue Oct 23, 2012 7:06 pm

I have got that part sorted thans moonman

I have one problem left now, when I go to access my sata drive from my.pogoplug.com I get "This drive is not available.
You have attached a hard drive that your Pogoplug device does not recognize. Please click here to contact customer support." I presume its because I have not got the right file system on the drive.

Please could you instruct me on how to format this drive in ssh and what format will pogoplug support?
rogerdygas
 
Posts: 33
Joined: Mon Oct 08, 2012 4:29 pm

Re: GoFlex Net Pogoplug installation problems

Postby moonman » Tue Oct 23, 2012 8:21 pm

run hbplug from /usr/local/cloudengines and show me the log. You probably don't have the certificates set. Check the troubleshooting section viewtopic.php?f=18&t=3343#p19389
PogoPlug v2 Pink | Seagate GoFlex Home | Raspberry Pi B 512
----------------------------------------------------------------------------------------------------------------------
[armv5] How to update U-Boot for kernel v3.2 and newer | [armv5] How to reinstall ALARM from scratch | [armv5] How to install my.pogoplug.com service
moonman
Developer
 
Posts: 2024
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: GoFlex Net Pogoplug installation problems

Postby rogerdygas » Wed Oct 24, 2012 11:47 am

Below is the requested log

LIMITS: Successfully set fd limit to 4096
Updated OOM_ADJ for our selvs...
PROP-BL: Failed to open: /dev/xce: 2 No such file or directory
[064514.602][MAIN ][HBPLUG][08] **********************************************
[064514.603][MAIN ][HBPLUG][08] **********************************************
[064514.603][MAIN ][HBPLUG][08] **********************************************
[064514.604][MAIN ][HBPLUG][08] Application Started [VERSION 'LINUX POGOPLUG - 3.2.6' 'POGOPLUG - 0.80']
[064514.604][MAIN ][HBPLUG][08] - PID: 529 PGRP: 529 SID: 394
[064514.605][MAIN ][HBPLUG][08] - Running as UID: 0 EUID: 0
[064514.605][MAIN ][HBPLUG][08] User Agent ' POGOPLUG/3.2.6 PP_GTI:2.0'
[064514.606][MAIN ][HBPLUG][02] No certificates directory found: '../etc/certs'
[064514.605][EVT ][HBEVT ][08] >>> Entering thread
[064514.627][MAIN ][HBPLUG][02] VERSION: -- NO BOOTLOADER PROPERTY ceboardver! Guessing 'PP_GTI:2.0'
[064514.628][MAIN ][HBPLUG][08] SVCID [PROPFILE]: ---removed----
[064514.631][MAIN ][HBPLUG][08] SKU ID: POGOPLUG
[064514.631][MAIN ][HBPLUG][08] SKU Name: POGO-E01
[064514.632][MAIN ][HBPLUG][08] SKU Friendly Name: Pogoplug
[064514.632][MAIN ][HBPLUG][08] CRYPTO KEY: VALID
[064514.633][MAIN ][BREVEN][08] Using Low Handler 'epoll'
[064514.634][SVC ][BREVEN][08] Using Low Handler 'epoll'
[064514.635][MAIN ][TIMER ][08] Chose random NTP peer 'time.pogoplug.com'
[064514.686][MAIN ][SSL ][08] Reading certificate chain: /usr/local/cloudengines/etc/hbplug.cert
[064514.688][MAIN ][HTTP ][08] Handler Registered: '/sqdiag/' @ 0x334e84
[064514.689][MAIN ][HTTP ][08] Handler Registered: '/sqdiag/' @ 0x334e84
[064514.690][MAIN ][HTTP ][08] Default Handler Registered @ 0x37c430
[064514.690][MAIN ][EVTSRV][08] HBRPCEventServer client event sink timeout set to 900000
[064514.691][MAIN ][HTTP ][08] Handler Registered: '/svc/evt' @ 0x37c450
[064514.691][MAIN ][HBPLUG][08] Bound TCP socket on 0.0.0.0:3333
[064514.692][MAIN ][HBPLUG][08] Bound TCP socket on 0.0.0.0:80
[064514.693][MAIN ][HBPLUG][08] Bound TCP socket on 0.0.0.0:443
[064514.693][MAIN ][HBPLUG][08] Bound NAMED PIPE on 'xcehbplug'
[064514.694][MAIN ][SVCND ][08] Using 'http://service.pogoplug.com/svc/xconnect' for service URL.
[064514.695][MAIN ][SVCND ][08] -- SVCID [B32] '--removed--'
[064514.695][MAIN ][SVCND ][08] -- SVCID [UUID] '1a85cd0ac95a2f33433a5b0e98e8370c'
[064514.699][MAIN ][IPTLIN][08] Trying '/sbin/ifconfig xce0 10.67.101.1'...
[064514.740][MAIN ][IPTLIN][08] Trying '/sbin/ifconfig xce0 mtu 1350'...
[064514.771][MAIN ][IPTLIN][08] Trying '/sbin/route add -net 10.67.101.0 netmask 255.255.255.0 dev xce0'...
[064514.802][MAIN ][IPTLIN][08] Tunnel initialized!
[064514.802][MAIN ][HBPLUG][08] Bound UDP socket on 0.0.0.0:46465
[064514.802][MAIN ][HBPLUG][08] Device ID: --removed--
[064514.802][MAIN ][HTTP ][08] Handler Registered: '/svc/xpl/' @ 0x37e600
[064514.803][MAIN ][HTTP ][08] Handler Registered: '/svc/api' @ 0x37e648
[064514.803][MAIN ][HTTP ][08] Handler Registered: '/svc/files' @ 0x37e648
[064514.804][MAIN ][HBPMGR][08] NETLINK SOCKET -- INIT
[064514.804][MAIN ][EVTSRV][08] POST-EVENT [hbplug.status.change][--removed--][(null)] -> [(nil)]
[064514.805][MAIN ][HTTP ][08] Handler Registered: '/svc/hbpctrl' @ 0x37f090
[064514.806][MAIN ][SHMON ][08] Instantiating new Share Monitor!
[064514.806][MAIN ][HBPLUG][08] Starting main event loop
[064514.807][BGQ ][BGQ ][08] >>> Entering thread
[064514.808][BGQ ][BGQ ][08] Waiting for something to happen!
[064514.861][MAIN ][NTP ][08] NTP Server to local clock delta: 2 seconds
[064515.805][MTP05 ][SVCND ][08] + SVC RPC (checkin : 0x2)
[064515.806][MTP05 ][SVCND ][08] -- Including 314 bytes of ping data:
[064516.217][MTP05 ][SVCND ][08] + Service gave us new UDP node 'eu-pm2.pogoplug.com:4365'
[064519.811][MAIN ][NTFYUI][01] Failed to open /dev/xce errno=2
^CSIGNAL - 2
[064753.230][MAIN ][HBPLUG][08] Waiting for SVC thread to shut down...
[064753.231][MAIN ][HBPLUG][08] Application Shutting down on signal [2]...
[064753.253][MAIN ][IPTLIN][08] Tunnel closed
[064753.253][MAIN ][SNMP ][08] Shutting down SNMP - closing sockets!
[064753.253][MAIN ][EVTSRV][08] POST-EVENT [hbplug.status.change][(null)][(null)] -> [(nil)]
[064753.253][MAIN ][HBPMGR][08] NETLINK SOCKET -- CLOSE
[064753.254][MAIN ][BGQ ][08] Shutting down...
[064753.254][BGQ ][BGQ ][08] +++ Received Task: 0
[064753.254][BGQ ][BGQ ][08] <<< Exiting thread
[064753.255][MAIN ][BGQ ][08] Shutdown complete
[064753.255][MAIN ][BGQ ][08] ---- BACKGROUND QUEUE STATUS ----
[064753.256][MAIN ][BGQ ][08] Num Tasks Completed: 0
[064753.256][MAIN ][BGQ ][08] Max Queue Depth: 1
[064753.257][MAIN ][BGQ ][08] Num Pending Tasks: 0
[064753.260][MAIN ][HBPLUG][08] Application Gracefully exiting (0)...
[064753.261][MAIN ][HBPLUG][08] **********************************************
[064753.261][MAIN ][HBPLUG][08] **********************************************
[064753.262][MAIN ][HBPLUG][08]
[064753.262][MAIN ][HBPLUG][08]



Also is my hbplug.conf file correct? I have one hard drive with one primary parititon the drive is shown as sdb
vfsdir0=plugdata,/dev/sdb
installdir=/usr/local/cloudengines
datadir=/dev/sdb
#example below: vfsdir<number>=<name>,<path>
datadir=vfsdir0=plugdata,/dev/sdb
nohotplug=1
svcid=--removed--

rogerdygas
 
Posts: 33
Joined: Mon Oct 08, 2012 4:29 pm

Re: GoFlex Net Pogoplug installation problems

Postby moonman » Wed Oct 24, 2012 5:58 pm

Your hbplug.conf is wrong. You cannot access harddrives directly through /dev, thats why they get mounted. Run "mount" command to see the mount point of sdb1. If it isn't mounted, then add it to /etc/fstab/. After you find mount point, add it to the config.

Copy-paste this and only change the part in bold. That's your mountpoint.
installdir=/usr/local/cloudengines
vfsdir0=plugdata,/media/2TBDrive/Downloads
#datadir=.
datadir=.
nohotplug=1
svcid=--removed--
PogoPlug v2 Pink | Seagate GoFlex Home | Raspberry Pi B 512
----------------------------------------------------------------------------------------------------------------------
[armv5] How to update U-Boot for kernel v3.2 and newer | [armv5] How to reinstall ALARM from scratch | [armv5] How to install my.pogoplug.com service
moonman
Developer
 
Posts: 2024
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: GoFlex Net Pogoplug installation problems

Postby rogerdygas » Sat Oct 27, 2012 7:49 am

Thanks moonman once again.

This forum wouldn't be the same without you.
rogerdygas
 
Posts: 33
Joined: Mon Oct 08, 2012 4:29 pm


Return to Marvell Kirkwood

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests