Flexget broken again

Ask questions about Arch Linux ARM. Please search before making a new topic.

Re: Flexget broken again

Postby z3ppelin » Fri Dec 21, 2012 9:37 am

try this:
Code: Select all
easy_install requests==0.14
it should install version of requests python package that you need
z3ppelin
 
Posts: 3
Joined: Fri Dec 21, 2012 9:33 am

Re: Flexget broken again

Postby kakar0t » Fri Dec 21, 2012 1:12 pm

I get this

Code: Select all
[root@alarm ~]# easy_install requests==0.14
-bash: easy_install: command not found


Is easy install included in the python package or it has to be installed separately?

Code: Select all
[root@alarm ~]# which easy_install
which: no easy_install in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/bin/core_perl)
kakar0t
 
Posts: 6
Joined: Sun Jun 03, 2012 3:01 am

Re: Flexget broken again

Postby pepedog » Fri Dec 21, 2012 1:45 pm

Code: Select all
pacman -Sy python2-distribute python2-requests
pepedog
Developer
 
Posts: 2202
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

Re: Flexget broken again

Postby kakar0t » Fri Dec 21, 2012 4:35 pm

Code: Select all
[root@alarm ~]# pacman -Sy python2-distribute python2-requests
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 alarm is up to date
 aur is up to date
warning: python2-distribute-0.6.32-1 is up to date -- reinstalling
warning: python2-requests-1.0.3-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Targets (2): python2-distribute-0.6.32-1  python2-requests-1.0.3-1

Total Installed Size:   4.23 MiB
Net Upgrade Size:       0.00 MiB

Proceed with installation? [Y/n] y
(2/2) checking package integrity                   [######################] 100%
(2/2) loading package files                        [######################] 100%
(2/2) checking for file conflicts                  [######################] 100%
(2/2) checking available disk space                [######################] 100%
(1/2) upgrading python2-distribute                 [######################] 100%
(2/2) upgrading python2-requests                   [######################] 100%
[root@alarm ~]# flexget --check
Traceback (most recent call last):
  File "/usr/bin/flexget", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2811, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: requests>=0.14,<0.15


would reinstalling python/flexget help?
kakar0t
 
Posts: 6
Joined: Sun Jun 03, 2012 3:01 am

Re: Flexget broken again

Postby z3ppelin » Sat Dec 22, 2012 4:54 pm

If you have "python2-distribute 0.6.32-1" this should work:
Code: Select all
/usr/bin/easy_install-2.7 requests==0.14
z3ppelin
 
Posts: 3
Joined: Fri Dec 21, 2012 9:33 am

Re: Flexget broken again

Postby kakar0t » Sat Dec 22, 2012 5:16 pm

Code: Select all
[root@alarm ~]# /usr/bin/easy_install-2.7 requests==0.14
Searching for requests==0.14
Reading http://pypi.python.org/simple/requests/
Reading http://python-requests.org
Reading https://github.com/kennethreitz/requests
Best match: requests 0.14.0
Downloading http://pypi.python.org/packages/source/r/requests/requests-0.14.0.tar.gz#md5=a809c747e4f09b92147721ebc3e23dd6
Processing requests-0.14.0.tar.gz
Writing /tmp/easy_install-MHu4lv/requests-0.14.0/setup.cfg
Running requests-0.14.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-MHu4lv/requests-0.14.0/egg-dist-tmp-K5kSIx
warning: no files found matching 'tests/*.'
zip_safe flag not set; analyzing archive contents...
requests._oauth: module references __file__
requests.certs: module references __file__
Adding requests 0.14.0 to easy-install.pth file

Installed /usr/lib/python2.7/site-packages/requests-0.14.0-py2.7.egg
Processing dependencies for requests==0.14
Finished processing dependencies for requests==0.14


That worked. Thanks a ton z3ppelin. you have been a lifesaver. Would it safe to run pacman -Syu now? or would it overwrite this module?
kakar0t
 
Posts: 6
Joined: Sun Jun 03, 2012 3:01 am

Re: Flexget broken again

Postby z3ppelin » Sun Dec 23, 2012 3:08 pm

No problem :) Pacman should not overwrite this file, so it's safe to -Syu!
z3ppelin
 
Posts: 3
Joined: Fri Dec 21, 2012 9:33 am

Re: Flexget broken again

Postby hendrix123 » Sat Dec 29, 2012 12:15 pm

I've got the exact same problem getting this error when trying to makepkg flexget:

Code: Select all
[ove@arch flexget]$ makepkg -s
==> Making package: flexget 1.0r3214-2 (Sat Dec 29 14:10:32 CET 2012)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: python2-requests-0.14
==> ERROR: 'pacman' failed to install missing dependencies.

Code: Select all
[ove@arch flexget]$ sudo /usr/bin/easy_install-2.7 requests==0.14
Searching for requests==0.14
Best match: requests 0.14.0
Processing requests-0.14.0-py2.7.egg
requests 0.14.0 is already the active version in easy-install.pth

Using /usr/lib/python2.7/site-packages/requests-0.14.0-py2.7.egg
Processing dependencies for requests==0.14
Finished processing dependencies for requests==0.14


I'm not using Arch Linux ARM but the regular Arch Linux 12.01, but I hope you guys can help me anyway :)
hendrix123
 
Posts: 1
Joined: Sat Dec 29, 2012 12:04 pm

Re: Flexget broken again

Postby moonman » Sat Mar 30, 2013 9:37 pm

FYI: flexget is broken again because python sqlalchemy got updated to 0.8

Fix with:
Code: Select all
easy_install-2.7 sqlalchemy==0.7
PogoPlug v2 Pink | Seagate GoFlex Home | Raspberry Pi B 512
----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] How to reinstall ALARM from scratch | [armv5] How to install my.pogoplug.com service
moonman
Developer
 
Posts: 2211
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Flexget broken again

Postby pepedog » Sat Mar 30, 2013 10:06 pm

I dipped into my pkgs cache
Code: Select all
pacman -U /var/cache/pacman/pkg/python2-sqlalchemy-0.7.9-1-arm.pkg.tar.xz
pepedog
Developer
 
Posts: 2202
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

PreviousNext

Return to User Questions

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests