[nextcloud] 12.0.4

Problems with packages? Post here, using [tags] of the package name.

[nextcloud] 12.0.4

Postby jfuhrmie » Wed Dec 06, 2017 11:11 am

The PKGBUILD file contains the line
depends=('php<7.2' 'php-gd<7.2')
where pacman is unable to find the packages titled

as scene here:
$ sudo pacman -S nextcloud
resolving dependencies...
warning: cannot resolve "php<7.2", a dependency of "nextcloud"
warning: cannot resolve "php-gd<7.2", a dependency of "nextcloud"
:: The following package cannot be upgraded due to unresolvable dependencies:

Arch Linux issue:
Nextcloud is not compatible with PHP 7.2.

What is the best way to upgrade to nextcloud 12.0.4 but not break pacman?

I am running this on a Rasberry Pi 3B, running archlinuxARM armv7l
Posts: 1
Joined: Wed Dec 06, 2017 10:59 am

Re: [nextcloud] 12.0.4

Postby tomracing79 » Wed Dec 27, 2017 8:42 pm

Agreed, on XU4 I also had this come up
When adding php and php-gd to IgnorePkg list in pacman.conf update of nextcloud to 12.0.4 was fine.

php and php-gd are being updated only to 7.2.0-2 I see no reason why this should be held back?
edit: never mind the above the reason this is being held back is because of nextcloud requirements from their wiki:
PHP 7.0, 7.1 (PHP 7.2 not supported)

So for now the solution remains to add the php and php-gd to the IgnorePkg list in /etc/pacman.conf until further notice of nextcloud.
Posts: 1
Joined: Sun Feb 22, 2015 10:40 pm

Return to Packages

Who is online

Users browsing this forum: No registered users and 3 guests