[Solved] spyder 5.0.0-1 and 'parso==0.7.0'

Problems with packages? Post here, using [tags] of the package name.

[Solved] spyder 5.0.0-1 and 'parso==0.7.0'

Postby alexela » Wed Apr 07, 2021 3:45 pm

It seems theres a bug with latest python updates… I have reinstall the spyder package, but here is my issue :

The 'parso==0.7.0' distribution was not found and is required by spyder

I guess there are some different versions of this parso…

The jupyter kernel provided by the elpy emacs package still works if it helps…
Last edited by alexela on Sat Apr 10, 2021 4:10 pm, edited 1 time in total.
alexela
 
Posts: 4
Joined: Thu Aug 27, 2020 8:42 am

Re: spyder 5.0.0-1 and 'parso==0.7.0'

Postby alexela » Sat Apr 10, 2021 4:09 pm

I have been lucky enough to get in touch with the archlinux package maintainer who gave me the solution :

edit the /usr/lib/python3.9/site-packages/spyder-5.0.0-py3.9.egg-info/requires.txt file and modify the == in the line with paro and jedi in >=. The package should be fixed soon.

alexela
alexela
 
Posts: 4
Joined: Thu Aug 27, 2020 8:42 am


Return to Packages

Who is online

Users browsing this forum: No registered users and 4 guests