kodi-rpi depends on python 3.9

Problems with packages? Post here, using [tags] of the package name.

Re: kodi-rpi depends on python 3.9

Postby doragasu1 » Tue Jan 18, 2022 7:37 am

Unless you have deleted them, you should have a copy of the older packages under /var/cache/pacman/pkg. Locate the packages and versions you want to downgrade to, and then

Code: Select all
# pacman -U [package_list]


With package_list being the path to the packages you want to downgrade.
doragasu1
 
Posts: 97
Joined: Sun Jun 03, 2012 3:52 pm

Re: kodi-rpi depends on python 3.9

Postby grandcanyon » Tue Jan 18, 2022 4:20 pm

I am running a new install. This is the first time I have used Arch.
grandcanyon
 
Posts: 20
Joined: Tue Jan 18, 2022 1:46 am

Re: kodi-rpi depends on python 3.9

Postby moonman » Wed Jan 19, 2022 12:33 am

There are community provided archives of older packages for cases like this
viewtopic.php?f=8&t=15698
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3367
Joined: Sat Jan 15, 2011 3:36 am

Re: kodi-rpi depends on python 3.9

Postby grandcanyon » Wed Jan 19, 2022 12:45 am

There are community provided archives of older packages for cases like this
viewtopic.php?f=8&t=15698

Thank you! I would have never found that.
grandcanyon
 
Posts: 20
Joined: Tue Jan 18, 2022 1:46 am

Re: kodi-rpi depends on python 3.9

Postby grandcanyon » Wed Jan 19, 2022 11:04 pm

I downgraded to python 3.9 but when trying to start kodi I got libpython3.10 are missing from kodi.bin. Not sure if the libs are hardcoded into kodi or I can set a path or I am missing a package or I just symbolic link to libpython3.9.

I just installed the python3.9 package.
grandcanyon
 
Posts: 20
Joined: Tue Jan 18, 2022 1:46 am

Re: kodi-rpi depends on python 3.9

Postby doragasu1 » Thu Jan 20, 2022 7:19 am

You have to downgrade Kodi to 19.3-2 or earlier.
doragasu1
 
Posts: 97
Joined: Sun Jun 03, 2012 3:52 pm

Previous

Return to Packages

Who is online

Users browsing this forum: Google [Bot] and 2 guests