kodi-c2 17.4-2 hw accelaration + framebuffer + permissions

Problems with packages? Post here, using [tags] of the package name.

kodi-c2 17.4-2 hw accelaration + framebuffer + permissions

Postby mvrk » Sun Sep 24, 2017 1:50 pm

Hi,

On my odroid-c2 i have the framebuffer driver (odroid-c2-libgl-fb) and kodi-c2 17.4-2 (https://archlinuxarm.org/packages/aarch64/kodi-c2) installed, but i can't get hw acceleration.

First time i execute kodi-standalone and try to play a video, the video doesn't play, the video window doesn't show up, kodi continues on the list of videos, though the video name has the "play" icon before the name.

On kodi log i see this:

13:25:20.677 T:548068164736 NOTICE: VideoPlayer: Opening: /mnt/Movies/test.mkv
13:25:20.677 T:548068164736 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13:25:20.680 T:546870128832 NOTICE: Creating InputStream
13:25:20.696 T:546870128832 NOTICE: Creating Demuxer
13:25:20.983 T:546870128832 NOTICE: Opening stream: 0 source: 256
13:25:20.984 T:546870128832 NOTICE: Creating video codec with codec id: 28
13:25:20.986 T:546870128832 ERROR: Unable to load libamplayer.so, reason: libamplayer.so: cannot open shared object file: No such file or directory
13:25:20.986 T:546870128832 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead
13:25:20.992 T:546870128832 NOTICE: Creating video thread
13:25:20.992 T:546870128832 NOTICE: Opening stream: 1 source: 256
13:25:20.992 T:546870128832 NOTICE: Finding audio codec for: 86020
13:25:20.992 T:546459087040 NOTICE: running thread: video_thread
13:25:20.993 T:546870128832 NOTICE: Creating audio thread
13:25:20.993 T:546408755392 NOTICE: running thread: CVideoPlayerAudio::Process()
13:25:20.993 T:546870128832 NOTICE: Opening stream: 0 source: 1024
13:25:21.116 T:546408755392 NOTICE: Creating audio stream (codec id: 86020, channels: 6, sample rate: 48000, pass-through)
13:25:22.183 T:546870128832 WARNING: VideoPlayer::Sync - stream player video does not start, flushing buffers

At this point i try to exit Kodi, but it just gets stuck, so i hit ctrl+c on the terminal.

Then i try to run kodi again, now the videos play but with software decoding, i can't get hw acceleration, i see this permissions error on kodi log:

12:57:30.991 T:547847332992 ERROR: AML: no rw on /dev/amstream*
...
13:04:52.546 T:546232594624 ERROR: AML: no proper permission, please contact the device vendor. Skipping codec...

but the permissions are all 666:

[root@odroid ~]# ll /dev/am*
crw-rw-rw- 1 root video 266, 10 Sep 24 12:41 /dev/amaudio0
crw-rw-rw- 1 root video 266, 0 Sep 24 12:41 /dev/amaudio_ctl
crw-rw-rw- 1 root video 266, 1 Sep 24 12:41 /dev/amaudio_utils
crw-rw-rw- 1 root video 253, 0 Sep 24 12:41 /dev/amhdmitx0
crw-rw-rw- 1 root video 255, 1 Sep 24 12:41 /dev/amstream_abuf
crw-rw-rw- 1 root video 255, 8 Sep 24 12:41 /dev/amstream_hevc
crw-rw-rw- 1 root video 255, 3 Sep 24 12:41 /dev/amstream_mpps
crw-rw-rw- 1 root video 255, 2 Sep 24 12:41 /dev/amstream_mpts
crw-rw-rw- 1 root video 255, 4 Sep 24 12:41 /dev/amstream_rm
crw-rw-rw- 1 root video 255, 5 Sep 24 12:41 /dev/amstream_sub
crw-rw-rw- 1 root video 255, 6 Sep 24 12:41 /dev/amstream_sub_read
crw-rw-rw- 1 root video 255, 7 Sep 24 12:41 /dev/amstream_userdata
crw-rw-rw- 1 root video 255, 0 Sep 24 12:41 /dev/amstream_vbuf
crw-rw-rw- 1 root video 237, 0 Sep 24 12:41 /dev/amsubtitle
crw-rw-rw- 1 root video 233, 0 Sep 24 12:41 /dev/amvecm
crw-rw-rw- 1 root video 240, 0 Sep 24 12:41 /dev/amvenc_avc
crw-rw-rw- 1 root video 264, 0 Sep 24 12:41 /dev/amvideo


It seems the first run that gets stuck locks the devices...

Anyone as any idea?
mvrk
 
Posts: 2
Joined: Sun Sep 24, 2017 1:44 pm

Re: kodi-c2 17.4-2 hw accelaration + framebuffer + permissio

Postby Evils » Sun Sep 24, 2017 7:42 pm

I have similar issues on my rpi3 with HW acceleration.

My error log shows:
Code: Select all
CMMALVideo::Open Failed to create pool for decoder input port (status=0 SUCCESS)


I have the feeling it's either a dependency that changed or the Kodi package is broken.

First I thought it might have been the pi that kicked the bucket, but after exchanging that and even with a brand new installation, I don't feel that's the case anymore.
Evils
 
Posts: 20
Joined: Fri May 01, 2015 2:36 am

Re: kodi-c2 17.4-2 hw accelaration + framebuffer + permissio

Postby Evils » Sun Sep 24, 2017 7:44 pm

Evils
 
Posts: 20
Joined: Fri May 01, 2015 2:36 am

Re: kodi-c2 17.4-2 hw accelaration + framebuffer + permissio

Postby jsntyyl » Fri Oct 06, 2017 2:28 pm

By reading this page(viewtopic.php?f=15&t=11777), you can fix the issue by downgrading the package linux-odroid-c2 from current version to 3.14.79-24.

I have another issue which is I cant hide the console text(login prompt) entirely, when I start playing, fast forward/backword / stop playing a video file, I can see the console login prompt flash, you can see it from the gif that I upload(which is I'm stopping a video).
ezgif.com-optimize.gif
stopping a video
ezgif.com-optimize.gif (245.72 KiB) Viewed 268 times
jsntyyl
 
Posts: 6
Joined: Tue Jan 28, 2014 6:01 am

Re: kodi-c2 17.4-2 hw accelaration + framebuffer + permissio

Postby setti » Thu Nov 09, 2017 8:01 pm

same problem with the flashing console screen after rebuilding kernel with gcc6. Did you solve your flashing console problem somehow? Adding consoleblank=0 to boot.ini is not enough.
setti
 
Posts: 26
Joined: Tue Sep 04, 2012 9:49 pm


Return to Packages

Who is online

Users browsing this forum: No registered users and 1 guest