[dotnet-runtime] "cannot resolve {libcurl,so, libuiid.so}.."

Problems with packages? Post here, using [tags] of the package name.

[dotnet-runtime] "cannot resolve {libcurl,so, libuiid.so}.."

Postby vindicator » Wed Nov 08, 2017 3:12 pm

Code: Select all
warning: cannot resolve "libcurl.so=4-64", a dependency of "dotnet-runtime"
warning: cannot resolve "libuuid.so=1-64", a dependency of "dotnet-runtime"
:: The following package cannot be upgraded due to unresolvable dependencies:
      dotnet-runtime

Code: Select all
Name            : curl
Version         : 7.56.1-1
...
Provides        : libcurl.so=4-32

< 4-64

Code: Select all
Name            : libutil-linux
Version         : 2.31-1
...
Provides        : libblkid.so=1-32  libfdisk.so=1-32  libmount.so=1-32  libsmartcols.so=1-32  libuuid.so=1-32

< 1-64
vindicator
 
Posts: 9
Joined: Sat Jan 21, 2017 5:31 am

Re: [dotnet-runtime] "cannot resolve {libcurl,so, libuiid.so

Postby WarheadsSE » Wed Nov 08, 2017 4:40 pm

Have you confirmed your repository information is up to date with an `pacman -Syy` ?
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm

Re: [dotnet-runtime] "cannot resolve {libcurl,so, libuiid.so

Postby vindicator » Wed Nov 08, 2017 4:43 pm

Yes. I tried it just now with the same result.
vindicator
 
Posts: 9
Joined: Sat Jan 21, 2017 5:31 am

Re: [dotnet-runtime] "cannot resolve {libcurl,so, libuiid.so

Postby vindicator » Thu Nov 09, 2017 10:48 am

Uhhh, now dotnet-runtime no longer is listed.

I think the issue was not so much about dotnet being incompatible with the package dependency versions, but rather why the dependency packages provided older library versions (ARM curl 7.56.1-1 = libcurl.so = 4-32, vs x86_64 curl also 7.56.1-1 but libcurl.so = 4-64).
vindicator
 
Posts: 9
Joined: Sat Jan 21, 2017 5:31 am


Return to Packages

Who is online

Users browsing this forum: Bing [Bot] and 2 guests