upgrading libva to 2.0.0-2 breaks kodi-c2

Problems with packages? Post here, using [tags] of the package name.

upgrading libva to 2.0.0-2 breaks kodi-c2

Postby stast » Sat Nov 11, 2017 4:03 pm

kodi-c2 failed to start because of unsatisfied shared object dependency:
Code: Select all
/usr/lib/kodi/kodi.bin: error while loading shared libraries: libva.so.1: cannot open shared object file: No such file or directory

My guess is that kodi-c2 version should be incremented to force rebuild against a newer version of libva.

Workaround to let kodi start again:
Code: Select all
sudo ln -s /usr/lib/libva.so.{2,1}
sudo ln -s /usr/lib/libva-drm.so.{2,1}
sudo ln -s /usr/lib/libva-x11.so.{2,1}


EDIT:
Is it also an idea to change kodi.service to fix console flashing reported here: https://archlinuxarm.org/forum/viewtopic.php?f=15&t=12064#p57151?
An example:
Code: Select all
$ diff /usr/lib/systemd/system/kodi.service /etc/systemd/system/kodi.service
8a9,12
> PermissionsStartOnly = true
> ExecStartPre = /bin/sh -c 'echo 0 > /sys/class/vtconsole/vtcon1/bind'
> ExecStartPre = /bin/sh -c "echo 0 > /sys/class/graphics/fbcon/cursor_blink"
> ExecStartPre = /bin/sh -c "dmesg -D"
9a14,16
> ExecStopPost = /bin/sh -c "dmesg -E"
> ExecStopPost = /bin/sh -c "echo 1 > /sys/class/graphics/fbcon/cursor_blink"
> ExecStopPost = /bin/sh -c 'echo 1 > /sys/class/vtconsole/vtcon1/bind'
stast
 
Posts: 14
Joined: Thu May 04, 2017 2:45 pm

Re: upgrading libva to 2.0.0-2 breaks kodi-c2

Postby stast » Sat Nov 11, 2017 4:44 pm

Just checked Owersun git repo - there were many changes made recently: https://github.com/Owersun/xbmc/commits/Krypton.
Also stable Kodi version is now 17.5.
stast
 
Posts: 14
Joined: Thu May 04, 2017 2:45 pm

Re: upgrading libva to 2.0.0-2 breaks kodi-c2

Postby stast » Sat Nov 11, 2017 9:14 pm

stast
 
Posts: 14
Joined: Thu May 04, 2017 2:45 pm

Re: upgrading libva to 2.0.0-2 breaks kodi-c2

Postby stast » Sun Nov 12, 2017 9:39 am

After upgrading kodi to 17.5-1 from the package repo I see this: before the service starts normally it segfaults few times and restarts:
Code: Select all
systemd-coredump[1849]: Process 1813 (kodi.bin) of user 995 dumped core.
                                             
                                              Stack trace of thread 1813:
                                              #0  0x00000055802f6c78 ff_h263_rfc2190_dynamic_handler (kodi.bin)
                                              #1  0x000000557f9d8010 av_frame_copy_props (kodi.bin)
                                              #2  0x000000557e856a8c _ZN16CGUIAudioManager9LoadSoundERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE (kodi.bin)
                                              #3  0x000000557eb06128 _ZN12CApplication8LoadSkinERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE (kodi.bin)
                                              #4  0x000000557eb07870 _ZN12CApplication10InitializeEv (kodi.bin)
                                              #5  0x000000557e7d7594 XBMC_Run (kodi.bin)
                                              #6  0x000000557e213264 main (kodi.bin)
                                              #7  0x0000007fa33ebbb4 __libc_start_main (libc.so.6)
                                              #8  0x0000007fa33ebbb4 __libc_start_main (libc.so.6)
                                              #9  0x000000557e296818 _start (kodi.bin)

Interesting thing: kodi 17.5 I've built myself yesterday doesn't have this problem.

EDIT: May it be related to the recent upgrade of mesa and libvdpau?
stast
 
Posts: 14
Joined: Thu May 04, 2017 2:45 pm


Return to Packages

Who is online

Users browsing this forum: No registered users and 2 guests