[libtool] local is newer than core

Problems with packages? Post here, using [tags] of the package name.

[libtool] local is newer than core

Postby davep » Thu May 06, 2021 10:39 am

Running 'pacman -Syu' on a RPi2 produces this information message: "local (2.4.6+44+gb9b44533-14) is newer than core (2.4.6+42+gb88cebd5-15)"

Looking in the package repo the most recent version is indeed libtool 2.4.6+42+gb88cebd5-15, however the PKGBUILD file is for 2.4.6+44+gb9b44533-15. The PKGBUILD has the 'noautobuild' flag set which is perhaps why there is a version discrepancy.
davep
 
Posts: 4
Joined: Tue Jun 25, 2019 12:24 pm

Re: [libtool] local is newer than core

Postby karog » Thu May 06, 2021 1:34 pm

It is not just RPi's. It happened this morning for me on my pogo e02, odroid xu4 and n2 as well as my RPi ZW's.
karog
 
Posts: 239
Joined: Thu Jan 05, 2012 7:55 pm

Re: [libtool] local is newer than core

Postby bulletmark » Wed May 19, 2021 11:53 pm

Over 2 weeks now and this bug is still there .... :(
bulletmark
 
Posts: 63
Joined: Tue Oct 13, 2015 10:17 pm

Re: [libtool] local is newer than core

Postby graysky » Thu May 20, 2021 10:10 am

Just run pacman -Suu
graysky
 
Posts: 980
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: [libtool] local is newer than core

Postby bulletmark » Thu May 20, 2021 11:56 am

@graysky, sorry but is that an official instruction on how to address this bug? Has that been posted on these forums, or anywhere else? How did this issue occur and are there any side-effects of the problem, or that solution?
bulletmark
 
Posts: 63
Joined: Tue Oct 13, 2015 10:17 pm

Re: [libtool] local is newer than core

Postby karog » Thu May 20, 2021 2:14 pm

graysky wrote:Just run pacman -Suu

This seems rather odd. It is quite the regression. This downgraded version is

Code: Select all
libtool-2.4.6+42+gb88cebd5-15-arm.pkg.tar.xz


On one of my machines not yet downgraded in my pacman cache I have

Code: Select all
-rw-r--r-- 1 root root 399K Jan  8  2019 libtool-2.4.6+42+gb88cebd5-2-armv7h.pkg.tar.xz
-rw-r--r-- 1 root root 399K Jun  9  2019 libtool-2.4.6+44+gb9b44533-1-armv7h.pkg.tar.xz
-rw-r--r-- 1 root root 398K Dec 20  2019 libtool-2.4.6+44+gb9b44533-8-armv7h.pkg.tar.xz
-rw-r--r-- 1 root root 398K Apr 26  2020 libtool-2.4.6+44+gb9b44533-11-armv7h.pkg.tar.xz
-rw-r--r-- 1 root root 398K Aug 23  2020 libtool-2.4.6+44+gb9b44533-14-armv7h.pkg.tar.xz


This downgraded version has the same version as from Jan 8 2019 except for the -2 to -15 at the end of the version number (I don't understand the structure of these version numbers here) and further has older copyright dates inside.

Can you explain what is going on here?
karog
 
Posts: 239
Joined: Thu Jan 05, 2012 7:55 pm

Re: [libtool] local is newer than core

Postby bulletmark » Thu May 20, 2021 10:58 pm

@karog, your post prompted me to compare to mainline Arch:

Code: Select all
# libtool package updates on Arch ARM Linux:
2017-06-09 11:00:00 libtool 2.4.6-7 -> 2.4.6-8
2017-09-13 09:28:00 libtool 2.4.6-8 -> 2.4.6+40+g6ca5e224-1
2017-12-25 09:32:00 libtool 2.4.6+40+g6ca5e224-1 -> 2.4.6+40+g6ca5e224-2
2018-04-05 16:25:00 libtool 2.4.6+40+g6ca5e224-2 -> 2.4.6+40+g6ca5e224-5
2018-05-12 07:15:00 libtool 2.4.6+40+g6ca5e224-5 -> 2.4.6+40+g6ca5e224-6
2018-08-12 17:02:00 libtool 2.4.6+40+g6ca5e224-6 -> 2.4.6+42+gb88cebd5-1
2019-01-27 14:41:00 libtool 2.4.6+42+gb88cebd5-1 -> 2.4.6+42+gb88cebd5-2
2019-07-05 15:54:00 libtool 2.4.6+42+gb88cebd5-2 -> 2.4.6+44+gb9b44533-1
2020-01-06 08:04:50 libtool 2.4.6+44+gb9b44533-1 -> 2.4.6+44+gb9b44533-8
2020-04-29 07:23:04 libtool 2.4.6+44+gb9b44533-8 -> 2.4.6+44+gb9b44533-11
2020-08-25 07:34:45 libtool 2.4.6+44+gb9b44533-11 -> 2.4.6+44+gb9b44533-14

# libtool package updates on mainline Arch Linux:
2017-05-30 06:34:00 libtool 2.4.6-7 -> 2.4.6-8
2017-09-10 07:48:00 libtool 2.4.6-8 -> 2.4.6+40+g6ca5e224-1
2017-12-08 09:11:00 libtool 2.4.6+40+g6ca5e224-1 -> 2.4.6+40+g6ca5e224-2
2018-02-03 07:29:00 libtool 2.4.6+40+g6ca5e224-2 -> 2.4.6+40+g6ca5e224-4
2018-03-21 06:45:00 libtool 2.4.6+40+g6ca5e224-4 -> 2.4.6+40+g6ca5e224-5
2018-05-08 07:24:00 libtool 2.4.6+40+g6ca5e224-5 -> 2.4.6+40+g6ca5e224-6
2018-06-07 06:51:00 libtool 2.4.6+40+g6ca5e224-6 -> 2.4.6+40+g6ca5e224-7
2018-08-07 06:53:00 libtool 2.4.6+40+g6ca5e224-7 -> 2.4.6+42+gb88cebd5-1
2018-09-13 07:12:00 libtool 2.4.6+42+gb88cebd5-1 -> 2.4.6+42+gb88cebd5-2
2019-04-21 07:52:00 libtool 2.4.6+42+gb88cebd5-2 -> 2.4.6+42+gb88cebd5-3
2019-06-18 21:00:00 libtool 2.4.6+42+gb88cebd5-3 -> 2.4.6+42+gb88cebd5-4
2019-07-24 07:35:00 libtool 2.4.6+42+gb88cebd5-4 -> 2.4.6+42+gb88cebd5-5
2019-10-07 07:29:00 libtool 2.4.6+42+gb88cebd5-5 -> 2.4.6+42+gb88cebd5-6
2019-11-19 07:25:18 libtool 2.4.6+42+gb88cebd5-6 -> 2.4.6+42+gb88cebd5-7
2019-11-22 06:55:11 libtool 2.4.6+42+gb88cebd5-7 -> 2.4.6+42+gb88cebd5-8
2020-02-12 07:04:54 libtool 2.4.6+42+gb88cebd5-8 -> 2.4.6+42+gb88cebd5-10
2020-03-15 07:23:52 libtool 2.4.6+42+gb88cebd5-10 -> 2.4.6+42+gb88cebd5-11
2020-05-04 07:28:37 libtool 2.4.6+42+gb88cebd5-11 -> 2.4.6+42+gb88cebd5-12
2020-05-15 07:08:41 libtool 2.4.6+42+gb88cebd5-12 -> 2.4.6+42+gb88cebd5-13
2020-08-22 07:26:34 libtool 2.4.6+42+gb88cebd5-13 -> 2.4.6+42+gb88cebd5-14
2021-05-06 07:07:42 libtool 2.4.6+42+gb88cebd5-14 -> 2.4.6+42+gb88cebd5-15
2021-05-17 15:30:54 libtool 2.4.6+42+gb88cebd5-15 -> 2.4.6+42+gb88cebd5-16

$ pi2:~ sudo pacman -Suu
:: Starting full system upgrade...
warning: libtool: downgrading from version 2.4.6+44+gb9b44533-14 to version 2.4.6+42+gb88cebd5-15


So it appears that Arch ARM introduced a custom branch libtool (i.e. departed from mainline Arch) on 05-Jul-2019 and now are switching back to mainline with 2.4.6+42+gb88cebd5-15.

Arch ARM needs a news feed (like Arch, Arch 32, etc) where uses can be informed about odd update situations like this.
bulletmark
 
Posts: 63
Joined: Tue Oct 13, 2015 10:17 pm


Return to Packages

Who is online

Users browsing this forum: No registered users and 2 guests