mongodb

Problems with packages? Post here, using [tags] of the package name.

mongodb

Postby windexh8er » Mon Oct 12, 2015 1:33 pm

Anyone else having segfault problems with mongodb-3.0.6-2-armv7h? The mongodb-3.0.4-1-armv7h works fine, but I get segfaults with 6-2.

Downgraded and works as expected. This is on a RPi2.

TIA!
windexh8er
 
Posts: 7
Joined: Wed Jul 22, 2015 2:04 pm

Re: mongodb

Postby a0js » Sun Oct 18, 2015 7:42 am

I'm also having segfault issues, though with armv6 (mongodb-3.0.7-1-armv6h). Unfortunately, I just started the project today and don't have the older 3.0.4-1 available for downgrading. Is there an archive for packages on Arch Linux ARM like the Arch Linux Archive?

Running on RPi B+.

Code: Select all
2015-10-18T06:48:14.043+0000 F -        Invalid access at address: 0
2015-10-18T06:48:14.063+0000 F -        Got signal: 11 (Segmentation fault).

 0xba4a84 0xba4128 0xba4558 0xb6361e40
----- BEGIN BACKTRACE -----
{"backtrace":[{"b":"10000","o":"B94A84"},{"b":"10000","o":"B94128"},{"b":"10000","o":"B94558"},{"b":"B6335000","o":"2CE40"}]}
 mongod(_ZN5mongo15printStackTraceERSo+0x20) [0xba4a84]
 mongod(+0xB94128) [0xba4128]
 mongod(+0xB94558) [0xba4558]
 libc.so.6(__default_rt_sa_restorer+0x0) [0xb6361e40]
-----  END BACKTRACE  -----
a0js
 
Posts: 1
Joined: Sun Oct 18, 2015 7:30 am

Re: mongodb

Postby TPXP » Sun Oct 18, 2015 12:06 pm

Same problem here, I also tried to build the package myself, without success. See the related issue on github.
TPXP
 
Posts: 9
Joined: Sun Oct 18, 2015 8:56 am

Re: mongodb

Postby WarheadsSE » Sun Oct 18, 2015 3:02 pm

Your compilation problem ticket was invalid.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6807
Joined: Mon Oct 18, 2010 2:12 pm

Re: mongodb

Postby TPXP » Sun Oct 18, 2015 3:42 pm

That's true, my bad.
Still, MongoDB doesn't start. :/
TPXP
 
Posts: 9
Joined: Sun Oct 18, 2015 8:56 am

Re: mongodb

Postby TPXP » Wed Oct 21, 2015 10:37 am

I recompiled MongoDB 3.0.4-1 for armv7h. The compilation succeeded without any major issue, except a few failed test (mongo hanged for ages when asked to drop a collection if I remember well). I guess I was close to running out of memory, but still it worked. ^^

You can grab my compiled version here : [Link removed, not anymore useful].

Hope this helps until our beloved developers hopefully find a fix!
Last edited by TPXP on Sun Feb 07, 2016 5:19 pm, edited 1 time in total.
TPXP
 
Posts: 9
Joined: Sun Oct 18, 2015 8:56 am

Re: mongodb

Postby marbi » Sat Oct 24, 2015 7:07 am

Same problem here on a RPi, after upgrading to mongodb-3.0.7-1-armv6h I started getting those errors on mongodb start.

Downgraded from pacman cache to mongodb-3.0.4-1-armv6h. I also needed to downgrade boost-libs to boost-libs-1.58.0-3-armv6h

If anybody needs these files, take them from my dropbox:

https://www.dropbox.com/s/uzr460r95k6g3 ... ar.xz?dl=0
https://www.dropbox.com/s/zo3wcly86i7sw ... ar.xz?dl=0
marbi
 
Posts: 12
Joined: Tue Feb 17, 2015 9:58 pm

Re: mongodb

Postby TPXP » Wed Oct 28, 2015 2:58 pm

This problem still happens with the new version mongodb 3.0.7-2.
Here is an example startup dump :
Code: Select all
2015-10-28T15:57:42.362+0100 F -        Invalid access at address: 0
2015-10-28T15:57:42.367+0100 F -        Got signal: 11 (Segmentation fault).

 0xb89558 0xb88c18 0xb8902c 0xb62e8a30
----- BEGIN BACKTRACE -----
{"backtrace":[{"b":"10000","o":"B79558"},{"b":"10000","o":"B78C18"},{"b":"10000","o":"B7902C"},{"b":"B62BC000","o":"2CA30"}]}
 mongod(_ZN5mongo15printStackTraceERSo+0x2C) [0xb89558]
 mongod(+0xB78C18) [0xb88c18]
 mongod(+0xB7902C) [0xb8902c]
 libc.so.6(__default_rt_sa_restorer+0x0) [0xb62e8a30]
-----  END BACKTRACE  -----
TPXP
 
Posts: 9
Joined: Sun Oct 18, 2015 8:56 am

Re: mongodb

Postby mserrano » Sun Nov 29, 2015 10:25 am

@marbi,

Thanks a lot for the packages. I am in the same situation.

I also need boost-1.58.0-3-armv6h. Does anyone have it?

It seems the problem with new versions still remains...

Thanks
mserrano
 
Posts: 2
Joined: Sun Nov 29, 2015 10:21 am

Re: mongodb

Postby mserrano » Sat Dec 05, 2015 6:18 pm

Ok,

I have finally been able to make my system work again, thanks to the packages provided by marbi.

I was trying to move to odroid C1.. but the problem is also there... and I do not have packages for odroid.

It seems that mongodb is not so well maintained in arch arm... Has anyone experience with nosql databases working fine on arm?
mserrano
 
Posts: 2
Joined: Sun Nov 29, 2015 10:21 am

Next

Return to Packages

Who is online

Users browsing this forum: No registered users and 1 guest