[RESOLVED] GoFlex net boot only in ubit-0.6

This forum is for Marvell Kirkwood devices such as the GoFlex Home/Net, PogoPlug v1/v2, SheevaPlug, and ZyXEL devices.

[RESOLVED] GoFlex net boot only in ubit-0.6

Postby chris614 » Wed Mar 16, 2011 10:13 am

hi,

i'm a little confuse to ask your help but my knowledge about plug-compter is limited.

When i buy my goflex net, i immediatly install debian on usb stick with jeff's script ( http://jeff.doozan.com/debian/ ) and all was good.
debian is in sda1
swap is in sda2
One week ago i buy a 2.5" sata hard drive and plug into it, but as you know it didn't work.
So after reading this post ( http://Arch Linux ARM.com/forum/viewtopic.php?f=18&t=494&start=60#p4741 ) i try.
When i run uboot_uptodate after ubit_start (from my debian environnement), i 've got a message that say something like "can't get version of uboot, so upgrade was not done."
when i run chain_install goflexnet no problem, so i exit.

for the second part, i want to keep my debian configuration so i only do :
Code: Select all
mv /boot /boot_OLD
wget http://jeff.doozan.com/debian/goflex/v0.6/v2.6.37/boot.tar.gz
wget http://jeff.doozan.com/debian/goflex/v0.6/v2.6.37/modules.tar.gz
mkdir -p /boot
tar -C /boot -xvzf boot.tar.gz
tar -C / -xvzf modules.tar.gz
wget http://jeff.doozan.com/debian/goflex/v0.6/uInitrd -O /boot/uInitrd


After reboot, my goflex take a new IP and i can ssh it.
When i connect to this new IP with ssh (and password 'root' for root user), i'm not in my debian but i'm in ubit-0.6 OS .

How can i boot into debian ?

thanks

ps : Sorry for my bad english
chris614
 
Posts: 2
Joined: Wed Mar 16, 2011 9:38 am

Re: GoFlex net boot only in ubit-0.6

Postby pegi » Wed Mar 16, 2011 11:54 am

Hi.
I did the same mistake and found out that after removing /boot/uInitrd, which contain the UBIT ramdisk env, I could again boot into the debian fs
pegi
 
Posts: 2
Joined: Fri Mar 11, 2011 8:29 am

Re: GoFlex net boot only in ubit-0.6

Postby peaslaker » Wed Mar 16, 2011 4:25 pm

If you have replaced the U-Boot with a non-machine specific U-Boot from Jeff, UBIT doesn't know what to install.

The correct command instead of 'uboot_uptodate' is:
Code: Select all
uboot_install goflexnet


As of now, you do not have any UBIT components installed. 'chain_install' puts a reserve copy of the OE Pogoplug U-Boot into an unused part of NAND memory, so doesn't affect booting. When it is time to revert the machine to operating as a Pogoplug, you just need to enter the UBIT command:
Code: Select all
chain_revert


All other parts of the Pogoplug system remain unmolested in a UBIT install. This is not the case if you have run the install script for Jeff's U-Boot or have otherwise altered the contents of NAND memory.

While pegi's instruction may get you up and running without UBIT, UBIT is a better environment for recovery.

All you need to do is set up the UBIT ramdisk as before and get to a position where you can run the 'uboot_install goflexnet' command.
peaslaker
 
Posts: 101
Joined: Tue Sep 07, 2010 10:40 pm

Re: GoFlex net boot only in ubit-0.6

Postby chris614 » Wed Mar 16, 2011 7:41 pm

Hi peaslaker,

i follow your instructions and now everythings is OK.
My GoFlex Net is now a good and cheap low-powered NAS.

Thank you so much.

Chris
chris614
 
Posts: 2
Joined: Wed Mar 16, 2011 9:38 am


Return to Marvell Kirkwood

Who is online

Users browsing this forum: No registered users and 2 guests