Odroid C1 - mainline kernel status

Discussion about U-Boot and the kernel.

Odroid C1 - mainline kernel status

Postby Sagittarius » Wed Dec 08, 2021 9:03 am

The subject viewtopic.php?f=23&t=15041 is locked, so I was wondering which is now the status of the mainline kernel on Odroid C1 regarding the Matrix support table on linux-meson: https://linux-meson.com/hardware.html

eMMC status seems right now, is it ?
what about USB,or even HDMI ?

Dockstar / GoFlexNet booting on NFS / Odroid C1+ / Odroid C2
Posts: 60
Joined: Mon Nov 14, 2011 9:21 pm
Location: France

Re: Odroid C1 - mainline kernel status

Postby renegat » Sat Jan 15, 2022 3:22 am

I tried yesterday to run Odroid C1+ using alarms mainline kernel with no avail.

Odroid boots from eMMC but USB, HDMI and ethernet not working.
Still a paperweight with kernel provided by alarm.

ArchLinuxArm is stuck with 5.11 here too while linux-meson is already at 5.16.
Seems like archlinuxarm kernel development for armv7 has completely stopped a year ago.

The only architecture which still seems to get kernel updates is AArch64.
This is sad. Seems like we have to look for another distribution for our armv7 devices. :(
Odroid U3+ / U3 / U2 / C1+ / XU4
RPi 1B / 1B+ / 2B / 3B / Zero WH
Posts: 23
Joined: Sat Oct 12, 2013 1:56 pm

Re: Odroid C1 - mainline kernel status

Postby moonman » Sat Jan 15, 2022 9:10 am

No idea what the status is for C1 to be honest as I haven't tried it in a while and the 3.10 seems to be doing the job for now, but I have compiled the 5.15.14 for my other devices if you'd like to try
Code: Select all

Note: I've taken out beagle* patches and cubietruck led patch from this package if somebody else stumbles upon this thread with these devices. Confirmed working with Odroid XU4, U2; SolidRun Clearfog, Cubox i

armv7 will eventually get updated. Kevin just hasn't got around to it yet.
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
[armv5] Updated U-Boot | [armv5] NAND Rescue System
Posts: 3367
Joined: Sat Jan 15, 2011 3:36 am

Re: Odroid C1 - mainline kernel status

Postby windozupdat3 » Sun Jan 16, 2022 6:09 pm

Thanks moonman, seems to be working perfectly on C1!
Posts: 31
Joined: Tue Aug 29, 2017 9:07 am

Re: Odroid C1 - mainline kernel status

Postby renegat » Sun Jan 23, 2022 9:50 am

I noticed alarm-kernel 5.16.2-2 was released for odroid-c1 just yesterday. :D

Was able to boot it with two simple modifications to boot.ini:

setenv condev "console=ttyAML0,115200n8"
ext4load mmc 0:1 0x21800000 /boot/dtbs/meson8b-odroidc1.dtb

- still no HDMI output (like expected)
- USB hotplug not working really reliable: Only, if there was some usb-device attached during boot which will be recognised by the Odroid (usb memory-stick e.g.) you can use the other usb ports.

- rngd blocks the whole device for about 1min with all cores at 100% workload. This makes ssh login painfully slow.
- reboot mostly does not work, you have to power-cycle in most cases.

So no real advance to kernel 5.11 :cry:

Will try now if eMMC is really supported with new kernel...


Yes, the odroid c1 seems to boot from eMMC (blue light blinking) - but still with no network and no usb working. :(
So it still stays unusable with eMMC.

With the same eMMC attached to the sd-card adapter in the sd-card slot of the odroid it will boot with network.

Any ideas how to fix this?
Odroid U3+ / U3 / U2 / C1+ / XU4
RPi 1B / 1B+ / 2B / 3B / Zero WH
Posts: 23
Joined: Sat Oct 12, 2013 1:56 pm

Return to U-Boot/Kernel

Who is online

Users browsing this forum: No registered users and 2 guests