Missing U-Boot Special Commands!

Discussion about U-Boot and the kernel.

Missing U-Boot Special Commands!

Postby Yong0320 » Mon Oct 03, 2016 2:24 am

Hi guys,

Recently, I'm learning how to troubleshoot U-boot-based CPU, while the OS for the CPU is Win CE 6.0. I found out that the special commands for U-boot is missing due to the U-boot processor I have here is being customized. Is that possible that I can re-install or re-configure the U-boot's missing commands into the U-boot?

Regards and Thanks,
Yong0320
Yong0320
 
Posts: 2
Joined: Mon Oct 03, 2016 2:10 am

Re: Missing U-Boot Special Commands!

Postby summers » Mon Oct 03, 2016 10:26 am

Well as you are Win CE based, that isn't something this forum deals with. So rewriting uboot env variables from Win CE is off topic.

However if you have access to the boot, e.g. via a uart plugged onto the board. You can interrupt the uboot, then rewrite env variables, then saveenv. Commands can be found on the uboot site, its quite simple.

http://www.denx.de/wiki/view/DULG/UBootCommandLineInterface
summers
 
Posts: 176
Joined: Sat Sep 06, 2014 12:56 pm

Re: Missing U-Boot Special Commands!

Postby Yong0320 » Tue Oct 04, 2016 12:42 am

Hi summers,
Sorry for asking the wrong question in this forum.
Thanks for your help.
Yong0320
 
Posts: 2
Joined: Mon Oct 03, 2016 2:10 am

Re: Missing U-Boot Special Commands!

Postby WarheadsSE » Tue Oct 04, 2016 1:05 pm

special commands for U-boot is missing

Can you actually describe what commands are missing? We don't know what board you have, what SoC it is based on, or how the u-boot is stored on that device. All of these things are needed information
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6730
Joined: Mon Oct 18, 2010 2:12 pm


Return to U-Boot/Kernel

Who is online

Users browsing this forum: No registered users and 1 guest