armsoc woes on HP Chromebook 11"

Install Arch Linux ARM on other devices.

armsoc woes on HP Chromebook 11"

Postby jman6495 » Sun Sep 14, 2014 2:33 pm

Hey,

I recently got hold of one of the ARM HP Chromebook 11's, It has similar specs to the Samsung ARM Chromebook : Exynos 5250, Mali-T604 MP4.

I've been running ALARM on fbdev for a couple of days now, and i'm pretty pleased with it, But I would really like to run gnome shell (without using llvmpipe), for this I know i need acceleration. So I followed the instructions given here : http://archlinuxarm.org/forum/viewtopic.php?f=47&t=7469&start=10

I installed xf86-video-armsoc-odroid and copied the MALI libgl libs over the originals. But X won't start.

Since then i've tried many other things :
all the availible xf86-video-armsoc providers (chromium & git). However I can never get X to start when using armsoc as the driver.

I either get :
Code: Select all
[292108.356] (--) Depth 24 pixmap format is 32 bpp
[292108.356] (EE) _CREATE_GEM({height: 768, width: 1366, bpp: 32 buf_type: 0x0}) failed. errno: 22 - Invalid argument
[292108.356] (EE) ARMSOC(0): ERROR: Cannot allocate scanout buffer

[292108.356] (EE)
Fatal server error:
[292108.356] (EE) AddScreen/ScreenInit failed for driver 0
[292108.356] (EE)


or

Code: Select all
RROR: Can't set the DRM interface version.
ERROR: Can't open a connection with the DRM - Permission denied


my XORG config for the card looks like this :

Code: Select all
Section "Device"
        Identifier      "Mali FBDEV"
        Driver          "armsoc"
        Option          "fbdev"                 "/dev/fb0"
        Option          "Fimg2DExa"             "false"
        Option          "DRI2"                  "true"
        Option          "DRI2_PAGE_FLIP"        "false"
        Option          "DRI2_WAIT_VSYNC"       "true"
#       Option          "Fimg2DExaSolid"        "false"
#       Option          "Fimg2DExaCopy"         "false"
#       Option          "Fimg2DExaComposite"    "false"
        Option          "SWcursorLCD"           "false"
EndSection

Section "Screen"
        Identifier      "DefaultScreen"
        Device          "Mali FBDEV"
        DefaultDepth    24
EndSection


I'm pretty much at a loss for what to do, any help is really appreciated.

-jman6495
jman6495
 
Posts: 4
Joined: Mon Jun 18, 2012 3:13 pm

Return to [Please read announcement] Community-Supported Devices

Who is online

Users browsing this forum: Bing [Bot] and 1 guest