ALARM on Sharp Zaurus C3x00

Install Arch Linux ARM on other devices.

Re: ALARM on Sharp Zaurus C3x00

Postby pcxfm » Thu Apr 14, 2016 4:28 am

Hi, everyone!

Excellent work on ALARM! Very nice progress.

I am attempting to reformat my C3100 but so far getting no luck. An HDD not initialized error appears.

Someone provided a workaround for this particular error on OESF however it appears OESF is no longer accessible.

Is OESF offline for anyone else?

Thanks in advance!
Posts: 1
Joined: Thu Apr 14, 2016 4:12 am

Re: ALARM on Sharp Zaurus C3x00

Postby greguu » Fri Apr 15, 2016 8:52 am

Hi pcxfm,

yes, OESF is down since a few days. Hope it will get back up on its feet as it contained heaps of information.
You can join #alarmz on freenode, there is a couple of us who can maybe help you out. Also at #kexecboot some Zaurus veterans hang around. You can also run it of the SD card. See previous post for links to GitHub.

Posts: 11
Joined: Tue Jul 17, 2012 8:42 pm

Re: ALARM on Sharp Zaurus C3x00

Postby Varthall » Fri Apr 15, 2016 9:20 am

Hi pcxfm,

I'm trying (with the help from greguu) to get in touch with some people which are/might be admin on to try to find out what's happening on that forum, I'll let you know.

I have an SL-C1000 and I'm looking forward to try to see it Arch works there as well. I have tried to install kexecboot on it but it fails to boot - as expected, since it's a 3x00 specific binary; I'm going to try with an other kexecboot, specific for the SL-C1000.

Posts: 2
Joined: Fri Apr 15, 2016 9:06 am

Re: ALARM on Sharp Zaurus C3x00

Postby NORI » Tue May 24, 2016 1:15 am

Dear Greguu

I tried your kernel and rootfs on my SL-C1000.

I used a SD card holding rootfs extracted from tar.gz, and a CF card to write boot-loader to the flush memory.
It won't boot.

I also own SL-C3000 , and confirmed this works.

Possible reason is that at the writing stage of flush memory, the HDD existence check occurred and failed to write boot-loader.

Thanks for your great effort to port ArchLinux ARM to Zaurus.
Posts: 1
Joined: Sat May 21, 2016 9:34 am

Re: ALARM on Sharp Zaurus C3x00

Postby greguu » Tue May 31, 2016 1:36 am


thanks for testing on the C1000.

I believe the C1000 has a different NAND layout and the kexecboot kernel fails. Possibly the same for the main kernel.
Since I do not have a C1000 this is difficult to troubleshoot but you can test the kernels on this link below for C1000 (akita) kernels from a different project. If you get these to boot they should run ALARM too. Have a look here and try the kexecboot kernel first.


Posts: 11
Joined: Tue Jul 17, 2012 8:42 pm


Return to [Please read announcement] Community-Supported Devices

Who is online

Users browsing this forum: No registered users and 1 guest