Support for OLinuXino available

Arch Linux ARM announcements, news, and other important things are posted here.

Support for OLinuXino available

Postby kmihelich » Sat Jul 21, 2012 10:20 pm

We've added new installation instructions, a root filesystem, and packages to bring support to Olimex's OLinuXino board. This device is based on the Freescale i.MX233 SoC at 454MHz with 64MB RAM, 10/100mbit ethernet, audio in/out, and NTSC or PAL composite video out. It also provides a wealth of connectivity easily accessible over standard connectors which should inspire those looking for a device to run home automation or robotics to name a couple applications. The device is fully open source hardware under a Creative Commons license, with all of the CAD and schematics available with no restrictions on personal or commercial usage.

We also want to personally thank Olimex Ltd. for sending us a board so that we could make this official support possible!

Arch Linux ARM exists and continues to grow through community support, please donate today!
kmihelich
Developer
 
Posts: 1124
Joined: Tue Jul 20, 2010 6:55 am
Location: aka leming #archlinux-arm

Re: Support for OLinuXino available

Postby crisman » Thu Jul 26, 2012 3:21 pm

could you add spi modules in the kernel please?
crisman
 
Posts: 1
Joined: Thu Jul 26, 2012 3:16 pm

Re: Support for OLinuXino available

Postby WarheadsSE » Thu Jul 26, 2012 5:02 pm

GitHub issue please :)
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6730
Joined: Mon Oct 18, 2010 2:12 pm

Re: Support for OLinuXino available

Postby tERBO » Fri Jul 27, 2012 5:58 am

I think it is good idea to add a new forum category under the Devices
tERBO
 
Posts: 3
Joined: Mon Jul 23, 2012 7:19 pm

Re: Support for OLinuXino available

Postby WarheadsSE » Fri Jul 27, 2012 11:42 am

If so, probably an i.MX Family
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6730
Joined: Mon Oct 18, 2010 2:12 pm

Re: Support for OLinuXino available

Postby redfox74 » Sat Aug 25, 2012 9:05 pm

Dear Friend,
i try to execute ArchLinux on Olinuxino , but it don't start :
this is the screen message :

:: Configuring Virtual Consoles [s[71G [BUSY] [71G [FAIL]
:: Bringing up loopback interface [s[71G [BUSY] [71G [DONE]
:: Unlocking encrypted volumes [s[71G [BUSY] [71G [DONE]
:: Checking Filesystems [s[71G [BUSY] /etc/rc.sysinit: line 100: /dev/stdout: Read-only file system
[71G [DONE]
:: Remounting Root and API filesystems [s[71G [BUSY] EXT2-fs (mmcblk0p2): warning: mounting unchecked fs, running e2fsck is recommended

[71G [DONE]
:: Mounting Local Filesystems [s[71G [BUSY] [71G [DONE]
:: Activating Swap [s[71G [BUSY] [71G [DONE]
:: Configuring Time Zone [s[71G [BUSY] [71G [DONE]
:: Initializing Random Seed [s[71G [BUSY] [71G [FAIL]
:: Removing Leftover Files [s[71G [BUSY] [71G [DONE]
:: Setting Hostname: alarm [s[71G [BUSY] [71G [DONE]
:: Saving dmesg Log [s[71G [BUSY] install: cannot stat /dev/fd/63: No such file or directory
[71G [FAIL]

INIT: Entering runlevel: 3 mount: mount point /proc/sys/fs/binfmt_misc does not exist
:: Setting MAC address to 16:54:0b:2e:16:c7 [s[71G [BUSY] [71G [DONE]
:: Starting Syslog-NG [s[71G [BUSY] [71G [DONE]
usb0: link up, 100Mbps, full-duplex, lpa 0x45E1

:: Starting Network [s[71G [BUSY] [71G [DONE]
:: Mounting Network Filesystems [s[71G [BUSY] [71G [DONE]
:: Starting crond daemon [s[71G [BUSY] [71G [DONE]
:: Starting Secure Shell Daemon [s[71G [BUSY] PRNG is not seeded PRNG is not seeded [71G [FAIL]

INIT: Id "s0" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel
INIT: Id "s0" respawning too fast: disabled for 5 minutes
INIT: Id "s0" respawning too fast: disabled for 5 minutes

Someone can help me :)

You are doing a great work with this arm distribution it's wonderfull :)
redfox74
 
Posts: 3
Joined: Sat Aug 25, 2012 6:58 pm

Re: Support for OLinuXino available

Postby redfox74 » Sat Aug 25, 2012 9:16 pm

This is the problem that i have on Olinuxino Micro.
I don't see the login at the end of process i don't understand where is the problem.
Best
Roberto


No device for DAI mxs adc/dac

asoc: mxs adc/dac <-> mxs adc/dac mapping ok

ALSA device list:

#0: MXS EVK (mxs adc/dac)

TCP cubic registered

NET: Registered protocol family 17

mxs-rtc mxs-rtc.0: setting system clock to 1970-01-01 00:00:10 UTC (10)

Waiting for root device /dev/mmcblk0p2...

mmc0: new high speed SDHC card at address e624

mmcblk0: mmc0:e624 SU04G 3.69 GiB

mmcblk0: p1 p2

EXT2-fs (mmcblk0p2): warning: mounting unchecked fs, running e2fsck is recommended

VFS: Mounted root (ext2 filesystem) on device 179:2.

Freeing init memory: 120K


INIT: version 2.88 booting
> Arch Linux ARM

> http://www.archlinuxarm.org

------------------------------
mount: unknown filesystem type 'devtmpfs'
:: Mounting Root Read-Only [s[71G [BUSY] [71G [DONE]
:: Adjusting system time and setting kernel timezone [s[71G [BUSY] [71G [DONE]
:: Starting UDev Daemon [s[71G [BUSY] [71G [DONE]
:: Triggering UDev uevents [s[71G [BUSY] [71G [DONE]
:: Loading User-specified Modules [s[71G [BUSY] [71G [DONE]
:: Waiting for UDev uevents to be processed [s[71G [BUSY] [71G [DONE]
:: Configuring Virtual Consoles [s[71G [BUSY] [71G [FAIL]
:: Bringing up loopback interface [s[71G [BUSY] [71G [DONE]
:: Unlocking encrypted volumes [s[71G [BUSY] [71G [DONE]
:: Checking Filesystems [s[71G [BUSY] /etc/rc.sysinit: line 100: /dev/stdout: Read-only file system
[71G [DONE]
:: Remounting Root and API filesystems [s[71G [BUSY] EXT2-fs (mmcblk0p2): warning: mounting unchecked fs, running e2fsck is recommended

[71G [DONE]
:: Mounting Local Filesystems [s[71G [BUSY] [71G [DONE]
:: Activating Swap [s[71G [BUSY] [71G [DONE]
:: Configuring Time Zone [s[71G [BUSY] [71G [DONE]
:: Initializing Random Seed [s[71G [BUSY] [71G [FAIL]
:: Removing Leftover Files [s[71G [BUSY] [71G [DONE]
:: Setting Hostname: alarm [s[71G [BUSY] [71G [DONE]
:: Saving dmesg Log [s[71G [BUSY] install: cannot stat /dev/fd/63: No such file or directory
[71G [FAIL]
EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291


INIT: Entering runlevel: 3 mount: mount point /proc/sys/fs/binfmt_misc does not exist
:: Setting MAC address to 16:54:0b:2e:16:c7 [s[71G [BUSY] usb0: ERROR while getting interface flags: No such device
SIOCSIFHWADDR: No such device
usb0: ERROR while getting interface flags: No such device
[71G [FAIL]
usb0: ERROR while getting interface flags: No such device
:: Starting Syslog-NG [s[71G [BUSY] EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37300

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

Error binding socket; addr='AF_UNIX(/dev/log)', error='Input/output error (5)'
Error initializing source driver; source='src', id='src#0'
Error initializing message pipeline;
[71G [FAIL]
:: Starting Network [s[71G [BUSY]
Error: unknown interface in /etc/rc.conf: `usb0'
[71G [DONE]
:: Mounting Network Filesystems [s[71G [BUSY] [71G [DONE]
:: Starting crond daemon [s[71G [BUSY] [71G [DONE]
EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

:: Starting Secure Shell Daemon [s[71G [BUSY] PRNG is not seeded PRNG is not seeded [71G [FAIL]
EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291

EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291


INIT: Id "s0" respawning too fast: disabled for 5 minutes EXT2-fs (mmcblk0p2): error: ext2_lookup: deleted inode referenced: 37291


INIT: no more processes left in this runlevel
redfox74
 
Posts: 3
Joined: Sat Aug 25, 2012 6:58 pm

Re: Support for OLinuXino available

Postby redfox74 » Sun Aug 26, 2012 7:55 am

Today i test with debian and it work fine . The network is up and apt-get work fine ... some idea about my problem on ArchLinux ?
Best
Roberto
redfox74
 
Posts: 3
Joined: Sat Aug 25, 2012 6:58 pm


Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest