PlugUI is out for testing!

Arch Linux ARM announcements, news, and other important things are posted here.

PlugUI is out for testing!

Postby kmihelich » Sat Mar 19, 2011 6:20 pm

Our python programmer extraordinaire mrsteveman1 has finished up with enough of Arch Linux ARM's new web administration interface to get it released for alpha testing in the wild! File browsing, share setup, configuration for some applications, software updating, file streaming, and LED control are some of the features available right now.

To install:
Code: Select all
pacman -Sy plugui


After it installs, start it up with:
Code: Select all
/etc/rc.d/plugui start


PlugUI runs on port 80, so if you're running your own web server you'll need to change the port on the web server or PlugUI. For your web server, see the appropriate manual pages. For PlugUI, edit /etc/rc.d/plugui and change the 'port' value in the CPSERVER_OPTIONS block at the top.

After starting it up, just point your browser to your plug's IP address (including any port change). You'll be prompted to create a login for the web interface, then you can login and explore!
You can also visit http://plugfinder.appspot.com/ to find your plug and give you a local address link.

To ensure PlugUI starts up at boot, add 'plugui' to end of the DAEMONS list at the end of /etc/rc.conf.

Issues? Bugs? Feature requests? Create an issue on the GitHub tracker.
Arch Linux ARM exists and continues to grow through community support, please donate today!
kmihelich
Developer
 
Posts: 1118
Joined: Tue Jul 20, 2010 6:55 am
Location: aka leming #archlinux-arm

Re: PlugUI is out for testing!

Postby Parsa » Sat Mar 19, 2011 9:46 pm

Woo! it installed fine here and it's very sweet. Loaded fine. The only 'bug' I think is that it didn't load all my users when I clicked on users, just root. Though this might be a feature :)
PogoPlug v2 Pink
Parsa
 
Posts: 16
Joined: Tue Mar 15, 2011 8:38 am
Location: London, UK

Re: PlugUI is out for testing!

Postby kmihelich » Sat Mar 19, 2011 9:55 pm

Users in PlugUI are just for the interface, no correlation to standard authentication. It's more for security overall.
Arch Linux ARM exists and continues to grow through community support, please donate today!
kmihelich
Developer
 
Posts: 1118
Joined: Tue Jul 20, 2010 6:55 am
Location: aka leming #archlinux-arm

Re: PlugUI is out for testing!

Postby Parsa » Sat Mar 19, 2011 10:05 pm

oh my bad :oops: it's been a long day :lol:
PogoPlug v2 Pink
Parsa
 
Posts: 16
Joined: Tue Mar 15, 2011 8:38 am
Location: London, UK

Re: PlugUI is out for testing!

Postby hojnikb » Sun Mar 20, 2011 3:50 pm

I was wating for this for a while ;)

Well i cant replace it for webmin for now, but it defenetly looks better than webmin.

For me it would be great if all the info about plug would be gathered on home page (like uptime, storage space etc...) and maybe if there would be a page for custom commands, like in webmin.
Also in the future if possible it would be awsome to have a feature similar to pogoplug ui, which converts video files using ffmpeg.I know it can be done already with console, but it way more nice to have a web ui for converting stuff...
Well maybe its just me :P

I really like the System Maintenance and update feature; keeps me away from console ;)


Anyway keep up the good work ;)
+°´°+,¸¸,+°´°~ +°´°+,¸¸,+°´°~I ♥ my DockStar :oops:~°´°+,¸¸,+°´°++°´°+,¸¸,+°´°~
Linux = Be root
Windows = reboot

+°´°+,¸¸,+°´°~DockStar, Marvell CPU @ 1.2Ghz, 128MB RAM, 4GB rootfs + 160GB°´°+,¸¸,+°´°+
hojnikb
 
Posts: 104
Joined: Thu Jul 08, 2010 11:57 am

Re: PlugUI is out for testing!

Postby hojnikb » Sun Mar 20, 2011 4:01 pm

Well i forget; it would also be awsome to have somekind of http download feature and a page with all the running processeses.


Now i really have to stop giving suggestions :lol: :lol: :lol:
+°´°+,¸¸,+°´°~ +°´°+,¸¸,+°´°~I ♥ my DockStar :oops:~°´°+,¸¸,+°´°++°´°+,¸¸,+°´°~
Linux = Be root
Windows = reboot

+°´°+,¸¸,+°´°~DockStar, Marvell CPU @ 1.2Ghz, 128MB RAM, 4GB rootfs + 160GB°´°+,¸¸,+°´°+
hojnikb
 
Posts: 104
Joined: Thu Jul 08, 2010 11:57 am

Re: PlugUI is out for testing!

Postby ygator » Sun Mar 20, 2011 4:36 pm

Here are some issues I have found:
1. There is an error in the file /opt/PlugUI/views/files/browse.html in the window.open command. It is not enclosed in single quotes. It shows in git being highlighted red.
2. System Maintenance last run time is reported in UTC and not the local time.
3. Share a file, but the local link was http://files/download/ZmI1YzNmMj
it did not include the host name or ip in the url.

Here are some issues I have found relating to trying to run this with IE
1. Clicking browse shows nothing (after correcting issue 1 above)
2. Click "Run Now" for System Maintenance never returns just see running and graphic spinning.

Looking good so far.
ygator
 
Posts: 94
Joined: Tue Aug 10, 2010 9:37 pm

Re: PlugUI is out for testing!

Postby crimsonredmk » Sun Mar 20, 2011 7:21 pm

Any issues should be posted on https://github.com/Arch Linux ARM/PlugUI/issues - thanks for finding some. ;)
Remember, Arch Linux ARM is completely donation-supported, and is totally awesome.
crimsonredmk
Site Admin
 
Posts: 433
Joined: Wed Dec 30, 2009 5:17 pm
Location: #archlinux-arm on irc.freenode.net

Re: PlugUI is out for testing!

Postby BinaryJay » Mon Mar 21, 2011 3:30 pm

I appreciate the work, but at the moment I'm a bit puzzled at it since it provides few plug specific features and seems to be an overlap of what Webmin has already been doing better for quite some time already.

The public sharing feature looks good (trying to get back a taste of the cloudengines software... come on cloudengines, work with this guys so I can use your service since I bought your device even if I don't want to use your OS) but I was unable to get it to create shares reliably, for folders at all, and the ones I did create didn't work. I have not posted any issue on git about it because I didn't try very hard to figure out if it was stupid human error or not.
BinaryJay
 
Posts: 87
Joined: Mon Dec 06, 2010 10:27 pm

Re: PlugUI is out for testing!

Postby slycat » Tue Mar 22, 2011 12:35 am

Just tried this on a Pro using Warheads' fixes.
Runs as it should, browser finds link properly. Editing some configuration files from the UI (for, lets say, minidlna) returns a string of errors, but I fear that is because I have the OS mounted directly on the harddrive so the PlugUI can't reach those files (for example, in Storage, only folders in /media/ show up, no parent directory like root).

But this is proof that it still works even when using the old libs. I think that if Pro users boot from usb and mount their storage separately, things should go smoothly.
Pogoplug Pro w/ Wireless User -> decomm.
Cubox-i4pro User
4TB eSATA HDD (8g/3700+ Sw/Storage)
Kodi / Transmission / Minidlna / Samba / Batch-audio-conversions / Lighttpd
slycat
 
Posts: 165
Joined: Wed Feb 09, 2011 3:07 am
Location: Miami, FL

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest