[RPi 2] Getting HDMI to work

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

[RPi 2] Getting HDMI to work

Postby JoJoModding » Sun Jun 13, 2021 12:08 pm

Hello,

I have an old RPi 2 I want to use to play videos or sound on my TV. I managed to get raspotify installed, and it works over the AUX port.

However, I am having issues with HDMI audio and video. When I plug my Pi (which so far was only used as a headless server) into the TV, I can see the usual console. However, I can get neither sound not video to work there. Neither raspotify not speaker-test produce audio output. omxplayer just refuses to do anything. kodi crashes immediately after startup.

config.txt:
Code: Select all
# See /boot/overlays/README for all available options

dtoverlay=vc4-kms-v3d
initramfs initramfs-linux.img followkernel
gpu_mem=256m
include kodi.config.txt
## the kodi.config.txt
dtoverlay=vc4-kms-v3d,cma-512
dtoverlay=rpivid-v4l2
disable_overscan=1
disable_fw_kms_setup=1

### uncomment for RPi4B playback of 4k x265 content @60 fps (UNDER DEVELOPMENT)
#hdmi_enable_4kp60=1

### uncomment to use the analog audio jack
### the 2nd option prevents crackling audio when HW accel decoding is active
#dtparam=audio=on
#audio_pwm_mode=1
hdmi_drive=2


kodi journalctl
Code: Select all
Jun 13 14:01:29 raspberrypi systemd[1]: Started Kodi standalone (GBM).
Jun 13 14:01:29 raspberrypi systemd[332]: pam_systemd_home(login:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Jun 13 14:01:29 raspberrypi systemd[332]: pam_unix(login:session): session opened for user kodi(uid=967) by (uid=0)
Jun 13 14:01:30 raspberrypi systemd[332]: pam_env(login:session): deprecated reading of user environment enabled
Jun 13 14:01:39 raspberrypi kodi-standalone[375]: /usr/bin/kodi: line 181:   380 Illegal instruction     (core dumped) ${KODI_BINARY} $SAVED_ARGS
Jun 13 14:01:39 raspberrypi kodi-standalone[375]: Crash report available at /var/lib/kodi/kodi_crashlog-20210613_140139.log
Jun 13 14:01:42 raspberrypi kodi-standalone[406]: /usr/bin/kodi: line 181:   411 Illegal instruction     (core dumped) ${KODI_BINARY} $SAVED_ARGS
Jun 13 14:01:42 raspberrypi kodi-standalone[406]: Crash report available at /var/lib/kodi/kodi_crashlog-20210613_140141.log
Jun 13 14:01:42 raspberrypi kodi-standalone[332]: /usr/bin/kodi --standalone  has exited in an unclean state 3 times in the last 12 seconds.
Jun 13 14:01:42 raspberrypi kodi-standalone[332]: Something is probably wrong
Jun 13 14:01:42 raspberrypi killall[434]: kodi.bin: no process found
Jun 13 14:01:42 raspberrypi systemd[434]: pam_systemd_home(login:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Jun 13 14:01:42 raspberrypi systemd[434]: pam_unix(login:session): session opened for user kodi(uid=967) by (uid=0)
Jun 13 14:01:42 raspberrypi systemd[434]: pam_env(login:session): deprecated reading of user environment enabled
Jun 13 14:01:42 raspberrypi systemd[1]: kodi.service: Control process exited, code=exited, status=1/FAILURE
Jun 13 14:01:42 raspberrypi systemd[1]: kodi.service: Failed with result 'exit-code'.


kodi log (referenced above)
Code: Select all
############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
 Date: Sun Jun 13 02:01:39 PM CEST 2021
 Kodi Options:
 Arch: armv7l
 Kernel: Linux 5.10.42-1-ARCH #1 SMP Tue Jun 8 14:18:46 UTC 2021
 Release: Arch Linux ARM
############## END SYSTEM INFO ##############

############### STACK TRACE #################
############# END STACK TRACE ###############

################# LOG FILE ##################

Logfile not found in the usual place.
Please attach it separately.
Use pastebin.com or similar for forums or IRC.

############### END LOG FILE ################

############ END Kodi CRASH LOG #############


Do you know what might cause this? Is the hardware to blame? I would not be surprised if the GPU is damaged, since the PI has continously been running for the last few years (without issues, tho, but as mentioned it did not use the GPU).
JoJoModding
 
Posts: 2
Joined: Sat Dec 09, 2017 4:57 pm

Re: [RPi 2] Getting HDMI to work

Postby graysky » Sun Jun 13, 2021 1:15 pm

Your config.txt is not the recommended one. Which kodi package are you using? RPi2 needs kodi-rpi-legacy. Based on the amount of memory you're trying to allocate, you're using the package intended for later model Pis.

It should simply be:
Code: Select all
# See /boot/overlays/README for all available options

initramfs initramfs-linux.img followkernel

[all]
include kodi.config.txt
graysky
 
Posts: 1000
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests