piTFT 2.8 Capacitive TS on Arch Linux & Raspberry PI 2

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

piTFT 2.8 Capacitive TS on Arch Linux & Raspberry PI 2

Postby knocklee » Wed Mar 23, 2016 7:23 pm

Hi all,

My Raspberry PI is 2 is running Arch Linux with notro firmware.

I was using a resistive TFT touchscreen and it was working fine. I thought that by changing the overlay and replacing stmpe-ts by ft6x06_ts in my configs the capacitive touchscreen would work too. Nevertheless, it didn't.

By doing some research I figured out that only adafruit guys had been supporting it, but by late October 2015 it was supported everywhere (https://github.com/raspberrypi/linux/issues/1050)) starting from linux kernel 4.1 and notro included it in his firmware.

I upgraded using rpi-update to 4.1.20-v7+ (20 of march 2016) and it does have updated overlays and modules. However instead of ft6x06_ts (FT6206) it has FT6236.

The FT6236 didn't work well as xinput says unable to find device ft6236 and the TS didn't work at all. I tried then to compile ft6x06_ts and insert it (even if notro overlays use ft6236) but in vain because I couldn't find the right headers for ARCH-4.1.20-v7+. Using this ones (ARCH-4.1.20) I got insertion errors; I tried also to use the right ones from debian repository but couldn't succeed to extract them correctly (I got compilation errors).

Am I doing something wrong ? this is supposed to work out of the box !
knocklee
 
Posts: 1
Joined: Wed Mar 23, 2016 7:19 pm

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 2 guests