Original RPi hangs on minimal fresh install

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

Original RPi hangs on minimal fresh install

Postby stasiana » Wed Apr 26, 2017 4:09 am

I have two Raspberry Pis, two Raspberry Pi 2s and two Raspberry Pi 3s.

The RPi2s and RPi3s seem to behave fine with Arch Linux. However, my original RPis have this problem where, upon a fresh install (only the instructions as described at https://archlinuxarm.org/platforms/armv6/raspberry-pi) and boot, the board will run for about 2-3 minutes, then start to freeze. It will freeze for just a second. Then 10 seconds later, it will freeze for 2, then 20 seconds later, it will freeze for 5 seconds, etc.. a few times, each long freezing longer, and then it will hang altogether and not be responsive anymore.

Raspbian has no problems on these boards.

Each time it freezes, pings don't work, shell doesn't respond, console doesn't respond, etc.

BUT, if I had a running task generating output periodically, each time it unfreezes, that output that should've been generated during the freeze all gets sent out at the same time.

For example, if I run the following:

Code: Select all
while true ; do date ; sleep 1 ; done


it will run, then freeze for 5 seconds, and then the output during those five seconds is shown. I have tried this on two RPis and I have tried this on two different SD cards.

A ping session is here illustrating how it goes up and down: https://gist.github.com/anonymous/36fe6 ... e457e5bd4e


Very confused. Anyone else had the original RPi freeze like this?
stasiana
 
Posts: 5
Joined: Wed Apr 26, 2017 3:58 am

Re: Original RPi hangs on minimal fresh install

Postby crashmaster » Fri Apr 28, 2017 10:59 pm

Same problem if booting on RPi2/3 using the same SDcard ?
Does it also happen without the connection to any external equipment, f.e. lan, hdd, etc. ?
crashmaster
 
Posts: 119
Joined: Wed Mar 13, 2013 1:00 am

Re: Original RPi hangs on minimal fresh install

Postby stasiana » Sat Apr 29, 2017 10:04 pm

No, no problems on the 2 and 3. Just this particular combination. Very strange.
stasiana
 
Posts: 5
Joined: Wed Apr 26, 2017 3:58 am

Re: Original RPi hangs on minimal fresh install

Postby andre » Thu May 04, 2017 5:38 pm

Anything in the dmesg?
andre
 
Posts: 40
Joined: Wed Jan 25, 2012 1:39 pm
Location: Eindhoven


Return to Raspberry Pi

Who is online

Users browsing this forum: Bing [Bot] and 3 guests