[SOLVED] Last update breaks Nextcloud.

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

[SOLVED] Last update breaks Nextcloud.

Postby netlak » Wed Jan 10, 2018 10:42 pm

Hello to all,

Today I run a full system update and pacman was not complaining anymore with nextcloud not being compatible with php 7.2 (php71) so I thought that the compatibility issue had been solved and so I decided to continue with the update. Guess again..... It was not solved at all!!!

Now nextcloud complains that it won't work with php 7.2 (php71 package). Trying to downgrade php php-gd php-intl php-apache doesn't work because nextcloud 12.0.4 wants php71.

Then I downgraded php php-gd php-intl php-apache and nextcloud (12.0.3) from the cache directory. After this, httpd exits with an error claiming that Cannot load modules/libphp7.so into server. I could trace down this file to the package icu. Downgrading this package did not solve the issue either.

I have also tryied installing nextcloud-testing-13.0 from the archlinux AUR. When I do that I don't see any errors when starting httpd but when I go to the nexcloud web page I only see a blank page.

Is anyone else having the same problem?
Why in the first place nextcloud 12.0.4 wants php71??
Any idea on how can i solve this?

Best regards, jose.
Last edited by netlak on Thu Jan 11, 2018 11:04 am, edited 2 times in total.
netlak
 
Posts: 3
Joined: Wed Jan 10, 2018 10:23 pm

Re: Update of Nextcloud 12.0.4 needs php71. Not working

Postby netlak » Thu Jan 11, 2018 8:56 am

Yesterday I precipitated on the causes of nextcloud not working. After the full system update nextcloud does not work claiming that it does not support php 7.2. I assumed that it was the package php71. Well it is not. The package is the correct version.

After the full system update the web server works according to "systemctl status httpd". The problem is that nextcloud doen't work because of php 7.2. Then I downgraded php-apache and php-intl to the 7.1.9 version. After this downgrade the web server doesn't work any more with this output:

Code: Select all
● httpd.service - Apache Web Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2018-01-11 09:40:54 CET; 1s ago
  Process: 492 ExecStop=/usr/bin/httpd -k graceful-stop (code=exited, status=1/FAILURE)
  Process: 525 ExecStart=/usr/bin/httpd -k start -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 525 (code=exited, status=1/FAILURE)

Jan 11 09:40:54 alarmpi systemd[1]: Started Apache Web Server.
Jan 11 09:40:54 alarmpi httpd[525]: httpd: Syntax error on line 186 of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server: libicui18n.so.59: cannot open shared obje
Jan 11 09:40:54 alarmpi systemd[1]: httpd.service: Main process exited, code=exited, status=1/FAILURE
Jan 11 09:40:54 alarmpi systemd[1]: httpd.service: Failed with result 'exit-code'.


Downgrading icu to version 59.1-2 didn't help because then httpd claims that is missing libicuuc.so.60

I'm guessing that downgrading php-apache and/or php-intl breaks the web server.

Is anyone else having this issue?
Any hint on the solution?
netlak
 
Posts: 3
Joined: Wed Jan 10, 2018 10:23 pm

Re: [SOLVED] Last update breaks Nextcloud.

Postby netlak » Thu Jan 11, 2018 11:06 am

This was an interesting talk with myself in the end.

Just to finish with the solution. It ends up that I had to manually change the php-* packages to the php71-* packages.

Now my apache web and nextcloud are up again!!!

José.
netlak
 
Posts: 3
Joined: Wed Jan 10, 2018 10:23 pm

Re: [SOLVED] Last update breaks Nextcloud.

Postby acidicX » Thu Jan 11, 2018 9:01 pm

seems to be broken with php-apcu though:

Code: Select all
PHP Warning:  PHP Startup: apcu: Unable to initialize module
Module compiled with module API=20170718
PHP    compiled with module API=20160303
These options need to match
 in Unknown on line 0


I had to disable the following line in my nextcloud config:
Code: Select all
  //'memcache.local' => '\OC\Memcache\APCu',


Now it's running really slow though :/
acidicX
 
Posts: 6
Joined: Sun Mar 20, 2016 11:32 am


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests