Compute Module fails to boot current image

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

Compute Module fails to boot current image

Postby shaman2014 » Fri Feb 02, 2018 11:26 pm

I have been using ArchLinux ARM for 3 years now. I am now looking to update the distribution but I am encountering a problem.

I am unable to boot the latest ArchLinuxARM-rpi-latest.tar.gz image on a RaspberryPi Compute Module. I have tried on multiple modules and they all hang sometime after bootcode.bin is loaded (or colored screen is displayed). I have tried the latest Rasbian as a sanity check and it works great.

Any suggestions?
Posts: 3
Joined: Tue Aug 26, 2014 4:54 am

Re: Compute Module fails to boot current image

Postby leragequit » Fri Feb 16, 2018 9:17 am

I am currently facing the same issue.
Image works fine on the Raspberry Pi 3 Model B 1.2 but fails to boot on the CM3.

Were you able to resolve the issue?

Posts: 1
Joined: Fri Feb 16, 2018 9:10 am

Re: Compute Module fails to boot current image

Postby naums » Fri Feb 16, 2018 10:32 pm

Are you using the eMMC-flash or an external SD? Are you using the rpi2-builds? CM3 is an Raspberry Pi 3 afterall.

If so: Are you sure, the GPU even boots from the boot-medium? I.e. are you sure the system sees the boot-medium at all?

If so: Are you sure the kernel mounts the correct partitions on bootup? Are there any debug-outputs over the UART-interface of the GPIO-interface? (I don't have the fogiest how one would connect the UART-pins on the Compute Module to an adapter though...)
Posts: 27
Joined: Sun Dec 31, 2017 11:11 am

Re: Compute Module fails to boot current image (Followup)

Postby shaman2014 » Mon Feb 19, 2018 6:37 pm

I have been able to detemine some additional information:

First note:
1. The problem is due to the fact that Newark was forced to change the RAM and
Flash chips (end of lifed) and the new chips require some changes in the
firmware to support them (which they have provided). But it also appears
that the kernel must be changed to support the new chips.
2. I am using a CM not a CM3 (cannot upgrade due to power constraints).
3. The modules in question start with the serial number ND****.
4. I am using the rpi image (not the rpi2 or rpi3 images).
5. I am using onboard eMMC.
6. I get the multi-colored screen and nothing else. If I understand correctly
that means that the bootcode.bin and the start.elf have loaded but it hangs
when the kernel loads (the color screen does not go away)
7. I have also tried to do a full system upgrade from our current image to the
latest stuff available in the ArchLinux ARM repositories and it is even worse.
In this case I do not even get the colored screen.
8. The latest Rasbian image boots fine but none of the ArchLinux ARM images
from November to current work, they all hang in the same place.

I have a PI3 board that I started testing last Friday:
1. The rpi3 images boots but is VERY unstable.
2. The rpi2 images seems to work fine.
3. This shows the possiblity that a CM3 might work but that does not help
due to the fact that I have 1000+ CM modules that I CAN NOT use.

The problem is that Newark has not been very open about the changes nor have
they been helpful in providing information about the actually changes needed.
It almost appears that they have tried to conceal the change and to slip the
changes in quietly.

At this point the odds are pretty good that we will be shipping 1000+ CM modules
back to Newark expecting a FULL refund. And we will be forced to find a different
solution, one that does not use a Raspberry PI.
Posts: 3
Joined: Tue Aug 26, 2014 4:54 am

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 2 guests