Starting X - no screens found

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

Starting X - no screens found

Postby shaurz » Fri May 04, 2012 11:40 am

When I try to start X it says that no screens are found. Do I have to manually set up xorg.conf?
shaurz
 
Posts: 15
Joined: Fri May 04, 2012 11:38 am

Re: Starting X - no screens found

Postby pepedog » Fri May 04, 2012 12:00 pm

Can you try this first?
xinit /usr/bin/lxsession
pepedog
Developer
 
Posts: 2431
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

Re: Starting X - no screens found

Postby shaurz » Fri May 04, 2012 12:05 pm

pepedog wrote:Can you try this first?
xinit /usr/bin/lxsession


I get the same error.
shaurz
 
Posts: 15
Joined: Fri May 04, 2012 11:38 am

Re: Starting X - no screens found

Postby pepedog » Fri May 04, 2012 12:13 pm

Did you update and install these packages?
Code: Select all
pacman -Syu
pacman -S xf86-video-fbdev lxde xorg-xinit dbus

Also I think you can edit .xinitrc in your home directory
Code: Select all
nano .xinitrc

The command you should put in your .xinitrc to start LXDE is:
Code: Select all
exec startlxde

Then startx should start it (just tested that)
pepedog
Developer
 
Posts: 2431
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

Re: Starting X - no screens found

Postby shaurz » Fri May 04, 2012 12:46 pm

Aha, it seems I did not have xf86-video-fbdev. I wasn't sure what driver it would need for X.

Is the Raspberry Pi capable of generating 1280x1024 resolution? Currently it seems to start up in 800x480.
shaurz
 
Posts: 15
Joined: Fri May 04, 2012 11:38 am

Re: Starting X - no screens found

Postby pepedog » Fri May 04, 2012 12:51 pm

I think it's actually 720p
Comment out hdmi line in /boot/config.txt
Then reboot
pepedog
Developer
 
Posts: 2431
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

Re: Starting X - no screens found

Postby shaurz » Fri May 04, 2012 1:20 pm

xdpyinfo says it's 800x480.

There is no config.txt. Hmm...
shaurz
 
Posts: 15
Joined: Fri May 04, 2012 11:38 am

Re: Starting X - no screens found

Postby shaurz » Fri May 04, 2012 1:29 pm

I found a fix for the resolution problem here: http://elinux.org/R-Pi_Troubleshooting
shaurz
 
Posts: 15
Joined: Fri May 04, 2012 11:38 am

Re: Starting X - no screens found

Postby pepedog » Fri May 04, 2012 1:32 pm

Code: Select all
http://downloads.raspberrypi.org/images/archlinuxarm/archlinuxarm-29-04-2012/archlinuxarm-29-04-2012.zip
http://downloads.raspberrypi.org/images/archlinuxarm/archlinuxarm-29-04-2012/archlinuxarm-29-04-2012.zip.sha1

Pi people haven't updated download page
Latest firmware upgrade will wipe out txt files on earlier images, a thing that will never happen from latest image ever again, plus lots of kernel bugs ironed out
pepedog
Developer
 
Posts: 2431
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

Re: Starting X - no screens found

Postby shaurz » Fri May 04, 2012 3:43 pm

Could you paste the contents of the txt files here so I don't have to reinstall the new image? Are they not included as part of a package?
shaurz
 
Posts: 15
Joined: Fri May 04, 2012 11:38 am

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest