[SOLVED] "glibc: /lib exists in filesystem" on RPi

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

[SOLVED] "glibc: /lib exists in filesystem" on RPi

Postby xenoxaos » Sun Sep 16, 2012 1:43 pm

If you're receiving the following error while updating with pacman (even on a fresh install), the following instructions should be of help!

error: failed to commit transaction (conflicting files)
glibc: /lib exists in filesystem
Errors occurred, no packages were upgraded.

It's typically a bad idea to force an install(unless it's required) or delete a directory with required files in it...So I'm updating the instructions of the original poster. I confirmed that these worked on a fresh install from the arclinuxarm-13-06-2012 image. If you come across any issues with this on an older install, please don't force an install or go deleting random files...hop on over to IRC and ask for some help and be patient.

First off, we'll need to go clean up some stuff that may have hung around when it doesn't need to be there. You should be on a fairly recent kernel by now.
Currently, there are some remnants of an old kernel in /lib.
Make sure that there is just one subdirectory called '3.1.9-10+' in /lib/modules/
Code: Select all
ls /lib/modules/

if there's only that one, then remove it with
Code: Select all
rm -rf /lib/modules

There's an old pcmciautils package that is no longer in the repos and really isn't needed. (Last I checked, the RPi doesn't have a PCMCIA slot.)
Code: Select all
pacman -R pcmciautils
mv /etc/profile.d/locale.sh /etc/profile.d/locale.sh.pacnew
pacman -Syu --ignore glibc

Say 'N' to updating pacman
Say 'Y' to any replacements and say 'Y' when it asks if you want to skip the above packages
After it installs all of those
Code: Select all
pacman -Su

And once again, say 'N' to pacman and 'Y' to any other packages
Arch Linux ARM exists and continues to grow through community support, please donate today!
Posts: 323
Joined: Thu Jan 06, 2011 1:45 am

Re: [SOLVED] "glibc: /lib exists in filesystem" on RPi

Postby slayer88 » Tue Sep 18, 2012 4:09 pm

After following these steps. Can i use arch linux normally as before?
Posts: 1
Joined: Wed Aug 29, 2012 12:59 pm

Re: [SOLVED] "glibc: /lib exists in filesystem" on RPi

Postby Ahemagain » Tue Sep 18, 2012 9:29 pm

Im sure this will be extremely obvious, but in my case /lib/modules also contains the following:

3.1.9-20-ARCH+ extramodules-3.1.9--raspberrypi

How will this affect the above procedure, is it still safe to remove the whole directory, alternatively can i just remove the 3.1.9-10+ entry, or something else entirely?
Posts: 1
Joined: Tue Sep 18, 2012 9:22 pm

Re: [SOLVED] "glibc: /lib exists in filesystem" on RPi

Postby pepedog » Tue Sep 18, 2012 9:54 pm

Update the kernel, it will move the to /usr/lib/modules
You can delete /lib/modules if it isn't empty
pacman -Sy linux-raspberrypi
Posts: 2431
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK

Re: [SOLVED] "glibc: /lib exists in filesystem" on RPi

Postby pushpop » Mon Oct 08, 2012 3:06 am

THANK YOU! Took me way too long to find a proper way to fix this issue. Something happened and I lost all my modules too. :shock: Now they are back, and everything is updated. :D
Posts: 4
Joined: Thu Sep 06, 2012 2:22 am

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest