Terratec USB audio: no sound

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

Terratec USB audio: no sound

Postby crom » Fri Nov 08, 2013 8:07 pm

Hi, I'm trying to get the following soundcard to work:
0ccd:0077 TerraTec Electronic GmbH Aureon Dual USB

I can adjust the volume in alsamixer but neither aplay nor mplayer will create something audible. At least aplay gives a hint:
Code: Select all
aplay: set_params:1239: Channels count non available


Any hints on this?
crom
 
Posts: 14
Joined: Thu Apr 12, 2012 7:05 pm

Re: Terratec USB audio: no sound

Postby sdjf » Fri Nov 08, 2013 11:25 pm

You need an .asoundrc file in home directory, do you have one?

Mine has in it right now, for Logitech USB speakers:

defaults.ctl.card 1
defaults.pcm.card 1
defaults.pcm.device 0

Don't know if that will fix your problem, but might.

I generally adjust volume on raw command line rather than with alsamixer as then I can set it in scripts that play sound for me.

Both aplay and mplayer use .asoundrc to know where to direct output, chances are your sound is going to the built in sound jack otherwise.
sdjf
 
Posts: 178
Joined: Wed May 08, 2013 1:55 pm

Re: Terratec USB audio: no sound

Postby crom » Sat Nov 09, 2013 9:16 am

Wow, I was just incredibly dumb. :oops:
Plugging the jack into the output plug (although it is glowing) suddenly leads to playback, the other one is the microphone input.

Anyways, adding

options snd slots=snd_usb_audio
to
/etc/modprobe.d/alsa.conf

makes the USB card card0, this minimizes further configuration. But thanks for your effort. :)
crom
 
Posts: 14
Joined: Thu Apr 12, 2012 7:05 pm


Return to Raspberry Pi

Who is online

Users browsing this forum: Google [Bot] and 2 guests