Can't bring UP wi-fi interface with systemd-networkd

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

Can't bring UP wi-fi interface with systemd-networkd

Postby anisotropo » Sat Jun 13, 2015 8:35 pm

Hello,

I've been trying to configure the network settings of a Raspberry Pi 2 with the systemd-networkd daemon but I can't bring UP my wireless card.

$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: en0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether aa:bb:cc:dd:ee:ff brd ff:ff:ff:ff:ff:ff
3: wl0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
link/ether ff:ee:dd:cc:bb:aa brd ff:ff:ff:ff:ff:ff

I've done other settings before with NetworkManager and everything went OK.

I don't know if this problem is due to something I did wrong in this process or just because of my wireless network card: TP-LINK TL-WN725N (is a USB NIC). The output of lsusb is:

# lsusb
Bus 001 Device 005: ID 04f3:0103 Elan Microelectronics Corp. ActiveJet K-2024 Multimedia Keyboard
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The settings I made are: first, I changed the network device names by creating /etc/udev/rules.d/10-network.rules. I put inside this file:

SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="aa:bb:cc:dd:ee:ff", NAME="en0"
SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="ff:ee:dd:cc:bb:aa", NAME="wl0"

Then I stopped the systemd-networkd daemon:

# systemctl stop systemd-networkd.service
and created in /etc/systemd/network/ the files: en0.link, en0.network, wl0.link and wl0.network. These files are:

en0.link
----------------------------------------
[Match]
MACAddress=aa:bb:cc:dd:ee:ff
Type=ethernet
Virtualization=no
Host=rAsp-backups
[Link]
Name=en0
MTUBytes=1450
MACAddress=aa:bb:cc:dd:ee:ff


en0.network
--------------------------------------------------
[Match]
Name=en0
[Network]
DNS=192.168.1.1
[Address]
Address=192.168.1.35/24
[Route]
Gateway=192.168.1.1


wl0.link
----------------------------------------------------------
[Match]
MACAddress=ff:ee:dd:cc:bb:aa
Type=wlan
Virtualization=no
Host=rAsp-backups
[Link]
Name=wl0
MTUBytes=1450
MACAddress=ff:ee:dd:cc:bb:aa


wl0.network
--------------------------------------------------------------
[Match]
Name=wl0
[Network]
DNS=192.168.1.1
[Address]
Address=192.168.1.47/24
[Route]
Gateway=192.168.1.1
And finally, I started the systemd-networkd daemon:
# systemctl start systemd-networkd.service

Thanks.
anisotropo
 
Posts: 5
Joined: Sat Jun 13, 2015 8:30 pm

Re: Can't bring UP wi-fi interface with systemd-networkd

Postby WarheadsSE » Sun Jun 14, 2015 2:15 pm

You'll want to also do the association with the network via wpa_supplicant services.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6804
Joined: Mon Oct 18, 2010 2:12 pm


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 4 guests