Kodi 15.1 crash at startup if remote library

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

Kodi 15.1 crash at startup if remote library

Postby pums974 » Mon Aug 24, 2015 10:02 am

Since the upgrade to kodi 15.1-1 it cannot start when I use a remote mysql library.
My system is totally up to date.

I tried with a clean install with no extensions and no configuration what so ever.
It crash without any error message (that I can find), even in debug mode.

You'll find log and coredump here : https://www.dropbox.com/sh/iu2kggrvkc63 ... seqBa?dl=0
kodi.log : first and normal run
kodi_crashlog : second run that crashed
systemd.log : relevent part of my journalctl with a first run without remote library, and a second one with remote library and crash.

With all prior version i can remember, including 15.0-2, everything was working fine
Last edited by pums974 on Mon Aug 24, 2015 7:23 pm, edited 1 time in total.
pums974
 
Posts: 5
Joined: Sun May 25, 2014 9:09 pm

Re: Kodi 15.1 crash at startup if remote library

Postby pums974 » Mon Aug 24, 2015 7:22 pm

The kodi guys asked for the backtrace,here, so I added it in the dropbox in the gdb.txt file.

For now, no one now if it's a arch specific issue or a kodi bug.
pums974
 
Posts: 5
Joined: Sun May 25, 2014 9:09 pm

Re: Kodi 15.1 crash at startup if remote library

Postby moonman » Tue Aug 25, 2015 12:00 am

Same thing seems to happen for aome people on all builds of kodi including kodi-imx and raspberrypi2. It may be linked to update to gcc5.2, but so far it is unknown whether it is a bug in gcc itself or certain parts of code in kodi need to be brought up to gcc5 standards.
For now I would suggest using an older build of kodi.
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 2973
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Kodi 15.1 crash at startup if remote library

Postby pums974 » Tue Aug 25, 2015 4:35 pm

I can confirm that my problem doesn't appears with openelec.
So it's an arch-specific problem, that may indeed be caused by gcc5.
pums974
 
Posts: 5
Joined: Sun May 25, 2014 9:09 pm

Re: Kodi 15.1 crash at startup if remote library

Postby moonman » Tue Aug 25, 2015 11:08 pm

Try this build. Built with gcc5.1:
Code: Select all
https://olegtown.pw/Public/ArchLinuxArm/kodi-15.1/kodi-rbp-15.1-1-armv6h.pkg.tar.xz
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 2973
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Kodi 15.1 crash at startup if remote library

Postby odious » Wed Aug 26, 2015 9:32 am

I ran into a similar problem when updating to 15.1-1, my kodi crashed after some time running. When restarting, it immediately crashed when loading the home screen - only deleting the Database folder seemed to help. I compiled the old 15.0 release (which worked fine before) with gcc5.2 on my pi b+ and ran into the same problem, the kodi-rbp-git aur package didn't help either.

I just tried your gcc5.1 build for a few hours and until now it works fine, thanks!
odious
 
Posts: 1
Joined: Wed Aug 26, 2015 7:31 am

Re: Kodi 15.1 crash at startup if remote library

Postby halomadei » Wed Aug 26, 2015 2:46 pm

OKay at first I thought the build for armv7h did work, but apperently it still crashes when I add my advancedsettings.xml
halomadei
 
Posts: 3
Joined: Wed Aug 26, 2015 2:44 pm

Re: Kodi 15.1 crash at startup if remote library

Postby moonman » Thu Aug 27, 2015 4:47 am

halomadei wrote:OKay at first I thought the build for armv7h did work, but apperently it still crashes when I add my advancedsettings.xml

Please don't confuse people here. This is armv6h. I've rebuilt for armv7h packages with links in the appropriate thread.
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 2973
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Kodi 15.1 crash at startup if remote library

Postby kovscer » Thu Aug 27, 2015 10:34 pm

Hi mooman, I just install your package and all seems to work except CEC. Do you have a solution for that ?
kovscer
 
Posts: 2
Joined: Thu Aug 27, 2015 10:30 pm

Re: Kodi 15.1 crash at startup if remote library

Postby moonman » Fri Aug 28, 2015 1:08 am

I've got no rpi to test cec unfortunately. Try running kodi as root - if it works, then you need a udev rule
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 2973
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest