[SOLVED] Samba segmentation fault (was arm-mem-git)

This forum is for topics specific to the Raspberry Pi and Arch Linux ARM

[SOLVED] Samba segmentation fault (was arm-mem-git)

Postby kokoko3k » Thu Mar 10, 2016 8:31 pm

I just updated my system:
Code: Select all
[2016-03-10 20:16] [PACMAN] Running 'pacman -Sc'
[2016-03-10 20:16] [PACMAN] Running 'pacman -Suy'
[2016-03-10 20:16] [PACMAN] synchronizing package lists
[2016-03-10 20:16] [PACMAN] starting full system upgrade
[2016-03-10 20:17] [PACMAN] Running 'pacman --color auto -S --asdeps --needed core/pacman'
[2016-03-10 20:17] [PACMAN] Running 'pacman -R package-query yaourt'
[2016-03-10 20:17] [ALPM] transaction started
[2016-03-10 20:17] [ALPM] removed yaourt (1.5-1)
[2016-03-10 20:17] [ALPM] removed package-query (1.5-2)
[2016-03-10 20:17] [ALPM] transaction completed
[2016-03-10 20:17] [PACMAN] Running 'pacman -Su'
[2016-03-10 20:17] [PACMAN] starting full system upgrade
[2016-03-10 20:24] [ALPM] transaction started
[2016-03-10 20:24] [ALPM] upgraded linux-api-headers (4.0-1 -> 4.4.1-1)
[2016-03-10 20:24] [ALPM] upgraded tzdata (2015e-1 -> 2016a-1)
[2016-03-10 20:24] [ALPM] upgraded iana-etc (2.30-5 -> 20151016-1)
[2016-03-10 20:24] [ALPM] upgraded filesystem (2015.02-1 -> 2015.09-1)
[2016-03-10 20:24] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2016-03-10 20:24] [ALPM] upgraded glibc (2.21-4 -> 2.23-1)
[2016-03-10 20:24] [ALPM-SCRIPTLET] Generating locales...
[2016-03-10 20:24] [ALPM-SCRIPTLET]   it_IT.UTF-8... done
[2016-03-10 20:24] [ALPM-SCRIPTLET]   it_IT.ISO-8859-1... done
[2016-03-10 20:24] [ALPM-SCRIPTLET]   it_IT.ISO-8859-15@euro... done
[2016-03-10 20:24] [ALPM-SCRIPTLET] Generation complete.
[2016-03-10 20:25] [ALPM] upgraded alsa-lib (1.0.29-1 -> 1.1.0-1)
[2016-03-10 20:25] [ALPM] upgraded gcc-libs (5.1.0-4 -> 5.3.0-5)
[2016-03-10 20:25] [ALPM] upgraded ncurses (5.9-7 -> 6.0-4)
[2016-03-10 20:25] [ALPM] upgraded bash (4.3.039-1 -> 4.3.042-4)
[2016-03-10 20:25] [ALPM-SCRIPTLET] /usr/bin/bash: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory
[2016-03-10 20:25] [ALPM] upgraded readline (6.3.008-1 -> 6.3.008-3)
[2016-03-10 20:25] [ALPM] upgraded pcre (8.37-2 -> 8.38-2)
[2016-03-10 20:25] [ALPM] upgraded glib2 (2.44.1-1 -> 2.46.2-4)
[2016-03-10 20:25] [ALPM] upgraded libcap (2.24-2 -> 2.25-1)
[2016-03-10 20:25] [ALPM] upgraded libgpg-error (1.19-1 -> 1.21-1)
[2016-03-10 20:25] [ALPM] upgraded libgcrypt (1.6.3-2 -> 1.6.5-1)
[2016-03-10 20:25] [ALPM] upgraded lz4 (130-1 -> 131-1)
[2016-03-10 20:25] [ALPM] upgraded xz (5.2.1-1 -> 5.2.2-1)
[2016-03-10 20:25] [ALPM] upgraded libsystemd (221-1 -> 229-3)
[2016-03-10 20:25] [ALPM] upgraded libdbus (1.8.18-1 -> 1.10.6-1)
[2016-03-10 20:25] [ALPM] upgraded dbus (1.8.18-1 -> 1.10.6-1)
[2016-03-10 20:25] [ALPM] upgraded avahi (0.6.31-15 -> 0.6.32-2)
[2016-03-10 20:25] [ALPM-SCRIPTLET] >>> Avahi now needs to be enabled in order to launch.
[2016-03-10 20:25] [ALPM-SCRIPTLET]     Run `systemctl enable avahi-daemon` if you wish
[2016-03-10 20:25] [ALPM-SCRIPTLET]     to make use of Avahi.
[2016-03-10 20:25] [ALPM] upgraded binutils (2.25-5.1 -> 2.26-3)
[2016-03-10 20:25] [ALPM] upgraded bwm-ng (0.6-5 -> 0.6.1-2)
[2016-03-10 20:25] [ALPM] upgraded gmp (6.0.0-2 -> 6.1.0-3)
[2016-03-10 20:25] [ALPM] upgraded db (5.3.28-2 -> 5.3.28-3)
[2016-03-10 20:26] [ALPM] upgraded perl (5.20.2-1 -> 5.22.1-2)
[2016-03-10 20:26] [ALPM] upgraded openssl (1.0.2.c-1 -> 1.0.2.g-3)
[2016-03-10 20:26] [ALPM] upgraded coreutils (8.23-2 -> 8.25-1)
[2016-03-10 20:26] [ALPM] upgraded findutils (4.4.2-6 -> 4.6.0-1)
[2016-03-10 20:26] [ALPM] upgraded less (471-1 -> 481-2)
[2016-03-10 20:26] [ALPM] upgraded texinfo (5.2-3 -> 6.1-1)
[2016-03-10 20:26] [ALPM] upgraded libtasn1 (4.5-1 -> 4.7-1)
[2016-03-10 20:26] [ALPM] upgraded p11-kit (0.23.1-2 -> 0.23.2-1)
[2016-03-10 20:26] [ALPM] upgraded ca-certificates-mozilla (3.19.1-2 -> 3.22.1-1)
[2016-03-10 20:26] [ALPM] upgraded hwids (20150129-1 -> 20160306-1)
[2016-03-10 20:26] [ALPM] upgraded kmod (20-1 -> 22-1)
[2016-03-10 20:26] [ALPM] upgraded pciutils (3.3.1-1 -> 3.4.1-1)
[2016-03-10 20:26] [ALPM] upgraded cpupower (4.0-3 -> 4.4-1)
[2016-03-10 20:26] [ALPM] upgraded libutil-linux (2.26.2-1 -> 2.27.1-1)
[2016-03-10 20:26] [ALPM] upgraded e2fsprogs (1.42.12-2 -> 1.42.13-1)
[2016-03-10 20:26] [ALPM] upgraded libldap (2.4.40-2 -> 2.4.43-3)
[2016-03-10 20:26] [ALPM] upgraded krb5 (1.13.1-1 -> 1.13.2-3)
[2016-03-10 20:26] [ALPM] upgraded libtirpc (0.3.2-2 -> 1.0.1-2)
[2016-03-10 20:26] [ALPM] upgraded pam (1.2.0-1 -> 1.2.1-3)
[2016-03-10 20:26] [ALPM] upgraded kbd (2.0.2-1 -> 2.0.3-1)
[2016-03-10 20:26] [ALPM] upgraded libidn (1.30-1 -> 1.32-1)
[2016-03-10 20:26] [ALPM] upgraded libelf (0.164-1 -> 0.165-1)
[2016-03-10 20:26] [ALPM] upgraded libseccomp (2.2.0-1 -> 2.2.3-1)
[2016-03-10 20:26] [ALPM] upgraded util-linux (2.26.2-1 -> 2.27.1-1)
[2016-03-10 20:26] [ALPM] warning: /etc/systemd/journald.conf installed as /etc/systemd/journald.conf.pacnew
[2016-03-10 20:26] [ALPM] warning: /etc/systemd/resolved.conf installed as /etc/systemd/resolved.conf.pacnew
[2016-03-10 20:27] [ALPM] upgraded systemd (221-1 -> 229-3)
[2016-03-10 20:27] [ALPM] upgraded device-mapper (2.02.120-2 -> 2.02.144-1)
[2016-03-10 20:27] [ALPM] upgraded cryptsetup (1.6.6-1 -> 1.7.1-1)
[2016-03-10 20:27] [ALPM] upgraded libssh2 (1.5.0-1 -> 1.7.0-2)
[2016-03-10 20:27] [ALPM] upgraded curl (7.43.0-1 -> 7.47.1-2)
[2016-03-10 20:27] [ALPM] upgraded dhcpcd (6.9.0-1 -> 6.10.1-1)
[2016-03-10 20:27] [ALPM] upgraded dialog (1:1.2_20150528-1 -> 1:1.3_20160209-1)
[2016-03-10 20:27] [ALPM] upgraded dosfstools (3.0.27-1 -> 3.0.28-1)
[2016-03-10 20:27] [ALPM] upgraded elfutils (0.164-1 -> 0.165-1)
[2016-03-10 20:27] [ALPM] upgraded gpm (1.20.7-4 -> 1.20.7-6)
[2016-03-10 20:27] [ALPM] upgraded lua51 (5.1.5-4 -> 5.1.5-4.1)
[2016-03-10 20:27] [ALPM] upgraded nspr (4.10.8-1 -> 4.12-1)
[2016-03-10 20:27] [ALPM] upgraded js185 (1.0.0-2.1 -> 1.0.0-3)
[2016-03-10 20:27] [ALPM] upgraded gc (7.4.2-2.1 -> 7.4.2-4)
[2016-03-10 20:27] [ALPM] upgraded tre (0.8.0-3 -> 0.8.0-4)
[2016-03-10 20:27] [ALPM] upgraded elinks (0.13-15 -> 0.13-16)
[2016-03-10 20:27] [ALPM] upgraded nettle (3.1.1-1 -> 3.2-1)
[2016-03-10 20:27] [ALPM] upgraded gnutls (3.4.2-1 -> 3.4.10-1)
[2016-03-10 20:27] [ALPM] upgraded gsm (1.0.13-8 -> 1.0.14-1)
[2016-03-10 20:27] [ALPM] upgraded libpng (1.6.16-1 -> 1.6.21-1)
[2016-03-10 20:27] [ALPM] upgraded graphite (1:1.2.4-1 -> 1:1.3.6-1)
[2016-03-10 20:27] [ALPM] upgraded harfbuzz (0.9.41-1 -> 1.2.3-1)
[2016-03-10 20:27] [ALPM] upgraded freetype2 (2.6-1 -> 2.6.3-1)
[2016-03-10 20:27] [ALPM] upgraded libass (0.13.0-1 -> 0.13.2-1)
[2016-03-10 20:27] [ALPM] upgraded libxml2 (2.9.2-2 -> 2.9.3-1)
[2016-03-10 20:27] [ALPM] upgraded libbluray (0.9.1-1 -> 0.9.2-1)
[2016-03-10 20:27] [ALPM] upgraded libmodplug (0.8.8.5-1 -> 0.8.8.5-2)
[2016-03-10 20:27] [ALPM] upgraded flac (1.3.1-1 -> 1.3.1-3)
[2016-03-10 20:27] [ALPM] upgraded libsndfile (1.0.25-2 -> 1.0.26-1)
[2016-03-10 20:27] [ALPM] upgraded xproto (7.0.27-1 -> 7.0.28-1)
[2016-03-10 20:27] [ALPM] upgraded xcb-proto (1.11-1 -> 1.11-2)
[2016-03-10 20:27] [ALPM] upgraded libxcb (1.11-1 -> 1.11.1-1)
[2016-03-10 20:27] [ALPM] upgraded libxi (1.7.5-1 -> 1.7.6-1)
[2016-03-10 20:27] [ALPM] upgraded libpulse (7.1-1 -> 8.0-3)
[2016-03-10 20:27] [ALPM] upgraded libssh (0.7.2-1 -> 0.7.3-1)
[2016-03-10 20:27] [ALPM] upgraded libdrm (2.4.65-1 -> 2.4.67-1)
[2016-03-10 20:27] [ALPM] upgraded wayland (1.9.0-1 -> 1.10.0-1)
[2016-03-10 20:27] [ALPM] upgraded libedit (20150325_3.1-1 -> 20150325_3.1-2)
[2016-03-10 20:28] [ALPM] upgraded llvm-libs (3.7.0-5 -> 3.7.1-1)
[2016-03-10 20:28] [ALPM] upgraded mesa (11.0.5-1.1 -> 11.1.2-1)
[2016-03-10 20:28] [ALPM] upgraded mesa-libgl (11.0.5-1.1 -> 11.1.2-1)
[2016-03-10 20:28] [ALPM] upgraded libva (1.6.1-1 -> 1.6.2-1)
[2016-03-10 20:28] [ALPM] upgraded libvdpau (1.1.1-1 -> 1.1.1-2)
[2016-03-10 20:28] [ALPM] upgraded libjpeg-turbo (1.4.1-1 -> 1.4.2-2)
[2016-03-10 20:28] [ALPM] upgraded libtiff (4.0.3-5 -> 4.0.6-2)
[2016-03-10 20:28] [ALPM] upgraded giflib (5.1.1-1 -> 5.1.2-1)
[2016-03-10 20:28] [ALPM] upgraded libwebp (0.4.4-1 -> 0.5.0-1)
[2016-03-10 20:28] [ALPM] upgraded opus (1.1-1.1 -> 1.1.2-1)
[2016-03-10 20:28] [ALPM] upgraded orc (0.4.24-1 -> 0.4.25-1)
[2016-03-10 20:28] [ALPM] upgraded schroedinger (1.0.11-2 -> 1.0.11-3)
[2016-03-10 20:28] [ALPM] upgraded v4l-utils (1.6.3-1 -> 1.10.0-1)
[2016-03-10 20:28] [ALPM] installed dcadec (0.2.0-1)
[2016-03-10 20:28] [ALPM] upgraded libvpx (1.5.0-2 -> 1.5.0-4)
[2016-03-10 20:28] [ALPM] upgraded libx264 (2:148.20150725-1 -> 2:148.20160103-1)
[2016-03-10 20:28] [ALPM] upgraded x265 (1.8-1 -> 1.9-1)
[2016-03-10 20:28] [ALPM] upgraded ffmpeg (1:2.8.2-1 -> 1:3.0-1)
[2016-03-10 20:28] [ALPM] upgraded file (5.23-2 -> 5.25-1)
[2016-03-10 20:28] [ALPM] upgraded fuse (2.9.4-1 -> 2.9.5-1)
[2016-03-10 20:28] [ALPM] upgraded mpfr (3.1.3-1 -> 3.1.3.p5-1)
[2016-03-10 20:29] [ALPM] upgraded gcc (5.1.0-4 -> 5.3.0-5)
[2016-03-10 20:29] [ALPM] upgraded libunistring (0.9.5-1 -> 0.9.6-1)
[2016-03-10 20:29] [ALPM] upgraded gettext (0.19.4-1 -> 0.19.7-1)
[2016-03-10 20:29] [ALPM] upgraded git (2.4.4-1 -> 2.7.2-2)
[2016-03-10 20:29] [ALPM] upgraded libassuan (2.2.0-1 -> 2.4.2-1)
[2016-03-10 20:29] [ALPM] upgraded pinentry (0.9.1-1 -> 0.9.7-1)
[2016-03-10 20:29] [ALPM] upgraded sqlite (3.8.10.2-1 -> 3.11.1-1)
[2016-03-10 20:29] [ALPM] upgraded gnupg (2.1.5-1 -> 2.1.11-1)
[2016-03-10 20:29] [ALPM] upgraded gpgme (1.5.4-1 -> 1.6.0-2)
[2016-03-10 20:29] [ALPM] upgraded grep (2.21-2 -> 2.23-1)
[2016-03-10 20:29] [ALPM] upgraded groff (1.22.3-3 -> 1.22.3-5)
[2016-03-10 20:29] [ALPM] upgraded libtool (2.4.6-2 -> 2.4.6-4)
[2016-03-10 20:29] [ALPM] upgraded guile (2.0.11-2 -> 2.0.11-3)
[2016-03-10 20:29] [ALPM] upgraded hdparm (9.45-1 -> 9.48-1)
[2016-03-10 20:29] [ALPM] upgraded hicolor-icon-theme (0.13-1 -> 0.15-1)
[2016-03-10 20:29] [ALPM] upgraded htop (1.0.3-2 -> 2.0.0-2)
[2016-03-10 20:29] [ALPM] upgraded libnl (3.2.25-1 -> 3.2.26-1)
[2016-03-10 20:29] [ALPM] upgraded libusb (1.0.19-1 -> 1.0.20-1)
[2016-03-10 20:29] [ALPM] upgraded libpcap (1.6.2-1 -> 1.7.4-1)
[2016-03-10 20:29] [ALPM] upgraded iftop (1.0pre4-1 -> 1.0pre4-2)
[2016-03-10 20:29] [ALPM] upgraded inetutils (1.9.4-1 -> 1.9.4-2.1)
[2016-03-10 20:29] [ALPM] upgraded iniparser (4.0-1 -> 4.0-2)
[2016-03-10 20:30] [ALPM] upgraded python (3.4.3-2 -> 3.5.1-2)
[2016-03-10 20:30] [ALPM] upgraded iotop (0.6-2 -> 0.6-4)
[2016-03-10 20:30] [ALPM] upgraded iperf (2.0.5-8 -> 2.0.5-9)
[2016-03-10 20:30] [ALPM] upgraded iproute2 (4.0.0-2 -> 4.1.1-1)
[2016-03-10 20:30] [ALPM] upgraded iputils (20140519.fad11dc-1 -> 20150815.1c59920-3)
[2016-03-10 20:30] [ALPM] upgraded nss (3.19.1-2 -> 3.22.1-1)
[2016-03-10 20:30] [ALPM] upgraded libcups (2.0.3-1 -> 2.1.3-1)
[2016-03-10 20:30] [ALPM] upgraded jre7-openjdk-headless (7.u79_2.5.5-1 -> 7.u95_2.6.4-1)
[2016-03-10 20:30] [ALPM] upgraded xdg-utils (1.1.0.git20150323-1 -> 1.1.1-1)
[2016-03-10 20:30] [ALPM] upgraded jre7-openjdk (7.u79_2.5.5-1 -> 7.u95_2.6.4-1)
[2016-03-10 20:30] [ALPM] upgraded talloc (2.1.2-1 -> 2.1.5-1)
[2016-03-10 20:30] [ALPM] upgraded tevent (0.9.24-1 -> 0.9.28-1)
[2016-03-10 20:30] [ALPM] upgraded tdb (1.3.4-1 -> 1.3.8-1)
[2016-03-10 20:30] [ALPM] upgraded ldb (1.1.20-1 -> 1.1.26-1)
[2016-03-10 20:31] [ALPM] upgraded ldns (1.6.17-2 -> 1.6.17-4)
[2016-03-10 20:31] [ALPM] upgraded lftp (4.6.3a-1 -> 4.6.5-1)
[2016-03-10 20:31] [ALPM] upgraded libbsd (0.7.0-1 -> 0.8.2-2)
[2016-03-10 20:31] [ALPM] upgraded libcap-ng (0.7.4-1 -> 0.7.7-1)
[2016-03-10 20:31] [ALPM] upgraded libevent (2.0.22-1 -> 2.0.22-2)
[2016-03-10 20:31] [ALPM] upgraded libmariadbclient (10.0.20-1 -> 10.1.12-3)
[2016-03-10 20:31] [ALPM] upgraded libpipeline (1.4.0-1 -> 1.4.1-1)
[2016-03-10 20:31] [ALPM] upgraded libunwind (1.1-2 -> 1.1-3)
[2016-03-10 20:31] [ALPM] upgraded libwbclient (4.2.1-1 -> 4.3.6-1)
[2016-03-10 20:31] [ALPM] upgraded libzip (1.0.1-1 -> 1.1.2-1)
[2016-03-10 20:32] [ALPM] upgraded linux-firmware (20150527.3161bfa-1 -> 20160113.40e9ae8-1)
[2016-03-10 20:32] [ALPM] upgraded linux-raspberrypi (4.0.6-1 -> 4.1.19-4)
[2016-03-10 20:32] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2016-03-10 20:32] [ALPM] upgraded logrotate (3.8.9-1 -> 3.9.1-1)
[2016-03-10 20:32] [ALPM] upgraded lsof (4.88-2 -> 4.89-1)
[2016-03-10 20:32] [ALPM] upgraded thin-provisioning-tools (0.4.1-1 -> 0.6.0-2)
[2016-03-10 20:32] [ALPM] upgraded lvm2 (2.02.120-2 -> 2.02.144-1)
[2016-03-10 20:32] [ALPM] upgraded make (4.1-1 -> 4.1-3)
[2016-03-10 20:32] [ALPM] upgraded man-db (2.7.1-1 -> 2.7.5-1)
[2016-03-10 20:32] [ALPM] upgraded man-pages (4.00-1 -> 4.04-1)
[2016-03-10 20:32] [ALPM] upgraded mdadm (3.3.2-2 -> 3.4-1)
[2016-03-10 20:32] [ALPM] warning: /etc/nanorc installed as /etc/nanorc.pacnew
[2016-03-10 20:32] [ALPM] upgraded nano (2.4.1-1 -> 2.5.3-1)
[2016-03-10 20:32] [ALPM] upgraded openresolv (3.7.0-1 -> 3.7.2-1)
[2016-03-10 20:32] [ALPM] upgraded netctl (1.10-2 -> 1.11-1)
[2016-03-10 20:32] [ALPM] installed geoip-database (20160105-1)
[2016-03-10 20:32] [ALPM] installed geoip (1.6.6-1)
[2016-03-10 20:32] [ALPM] upgraded nginx (1.8.0-1 -> 1.8.1-3)
[2016-03-10 20:32] [ALPM] warning: /etc/ssh/sshd_config installed as /etc/ssh/sshd_config.pacnew
[2016-03-10 20:32] [ALPM] upgraded openssh (6.8p1-3 -> 7.2p1-1)
[2016-03-10 20:32] [ALPM] upgraded openvpn (2.3.6-1 -> 2.3.9-2)
[2016-03-10 20:32] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2016-03-10 20:32] [ALPM] upgraded pacman-mirrorlist (20150520-1 -> 20160207-1)
[2016-03-10 20:32] [ALPM] upgraded pacman (4.2.1-1 -> 5.0.1-2)
[2016-03-10 20:32] [ALPM] warning: /etc/php/php.ini installed as /etc/php/php.ini.pacnew
[2016-03-10 20:32] [ALPM] upgraded php (5.6.10-1 -> 7.0.4-2)
[2016-03-10 20:32] [ALPM] warning: /etc/php/php-fpm.conf installed as /etc/php/php-fpm.conf.pacnew
[2016-03-10 20:32] [ALPM] upgraded php-fpm (5.6.10-1 -> 7.0.4-2)
[2016-03-10 20:32] [ALPM] warning: directory permissions differ on /etc/privoxy/
[2016-03-10 20:32] [ALPM] warning: directory permissions differ on /etc/privoxy/templates/
[2016-03-10 20:32] [ALPM] warning: /etc/privoxy/config installed as /etc/privoxy/config.pacnew
[2016-03-10 20:32] [ALPM] warning: directory permissions differ on /var/log/privoxy/
[2016-03-10 20:32] [ALPM] upgraded privoxy (3.0.23-1 -> 3.0.24-2)
[2016-03-10 20:32] [ALPM] upgraded procps-ng (3.3.10-2 -> 3.3.11-2)
[2016-03-10 20:32] [ALPM] upgraded psmisc (22.21-2 -> 22.21-3)
[2016-03-10 20:33] [ALPM] upgraded python2 (2.7.10-1 -> 2.7.11-2)
[2016-03-10 20:33] [ALPM] upgraded raspberrypi-firmware-bootloader (20150623-1 -> 20160309-1)
[2016-03-10 20:33] [ALPM] upgraded raspberrypi-firmware-bootloader-x (20150623-1 -> 20160309-1)
[2016-03-10 20:33] [ALPM] upgraded raspberrypi-firmware-tools (20150623-1 -> 20160309-1)
[2016-03-10 20:33] [ALPM] upgraded raspberrypi-firmware-examples (20150623-1 -> 20160309-1)
[2016-03-10 20:33] [ALPM] upgraded raspberrypi-firmware (20150623-1 -> 20160309-1)
[2016-03-10 20:33] [ALPM] upgraded rsync (3.1.1-4 -> 3.1.2-1)
[2016-03-10 20:33] [ALPM] upgraded rtmpdump (20140918-2 -> 1:2.4.r96.fa8646d-2)
[2016-03-10 20:33] [ALPM] upgraded s-nail (14.8.2-1 -> 14.8.6-2)
[2016-03-10 20:33] [ALPM] upgraded smbclient (4.2.1-1 -> 4.3.6-1)
[2016-03-10 20:34] [ALPM] upgraded samba (4.2.1-1 -> 4.3.6-1)
[2016-03-10 20:34] [ALPM] upgraded screen (4.3.0-3 -> 4.3.1-2)
[2016-03-10 20:34] [ALPM] upgraded smartmontools (6.4-1 -> 6.4-2)
[2016-03-10 20:34] [ALPM] upgraded socat (1.7.3.0-1 -> 1.7.3.1-2)
[2016-03-10 20:34] [ALPM] upgraded sshfs (2.5-1 -> 2.6-1)
[2016-03-10 20:34] [ALPM] upgraded strace (4.10-2 -> 4.11-1)
[2016-03-10 20:34] [ALPM] warning: /etc/sudoers installed as /etc/sudoers.pacnew
[2016-03-10 20:34] [ALPM] upgraded sudo (1.8.13-1 -> 1.8.15-1)
[2016-03-10 20:34] [ALPM] upgraded systemd-sysvcompat (221-1 -> 229-3)
[2016-03-10 20:34] [ALPM] upgraded tinc (1.0.25-2 -> 1.0.26-2)
[2016-03-10 20:34] [ALPM] upgraded tor (0.2.6.9-1 -> 0.2.7.6-3)
[2016-03-10 20:34] [ALPM] upgraded transmission-cli (2.84-1 -> 2.91-1)
[2016-03-10 20:34] [ALPM] upgraded transmission-remote-cli (1.7.0-1 -> 1.7.1-2)
[2016-03-10 20:34] [ALPM] upgraded unzip (6.0-10 -> 6.0-11)
[2016-03-10 20:34] [ALPM] upgraded vi (1:050325-4 -> 1:070224-2)
[2016-03-10 20:34] [ALPM] upgraded vsftpd (3.0.2-5 -> 3.0.3-2)
[2016-03-10 20:34] [ALPM] upgraded wget (1.16.3-1 -> 1.16.3-2)
[2016-03-10 20:34] [ALPM] upgraded xfsprogs (3.2.2-1 -> 4.3.0-1)
[2016-03-10 20:34] [ALPM] transaction completed
[2016-03-10 21:06] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/samba-4.3.6-1-armv6h.pkg.tar.xz'
[2016-03-10 21:12] [PACMAN] Running 'pacman -S samba'
[2016-03-10 21:12] [ALPM] transaction started
[2016-03-10 21:12] [ALPM] reinstalled samba (4.3.6-1)
[2016-03-10 21:12] [ALPM] transaction completed
[2016-03-10 21:15] [PACMAN] Running 'pacman -R smbclient'
[2016-03-10 21:16] [PACMAN] Running 'pacman -S smbclient'
[2016-03-10 21:16] [ALPM] transaction started
[2016-03-10 21:16] [ALPM] reinstalled smbclient (4.3.6-1)
[2016-03-10 21:16] [ALPM] transaction completed
[2016-03-10 21:20] [PACMAN] Running 'pacman -S gdb'
[2016-03-10 21:20] [ALPM] transaction started
[2016-03-10 21:20] [ALPM] installed gdb (7.11-1)
[2016-03-10 21:20] [ALPM] transaction completed


Now i have segmentation fault with samba and testparm :
Code: Select all
pi ~ # smbd
Segmentation fault
pi ~ # testparm
Segmentation fault


Tried to get a backtrace:
Code: Select all
pi ~ # gdb smbd
GNU gdb (GDB) 7.11
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "armv6l-unknown-linux-gnueabihf".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from smbd...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/smbd
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x000013e4 in ?? ()
(gdb) bt
#0  0x000013e4 in ?? ()
#1  0xb697e838 in trim_char () from /usr/lib/samba/libsamba3-util-samba4.so
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)


pi ~ # gdb testparm
GNU gdb (GDB) 7.11
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "armv6l-unknown-linux-gnueabihf".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from testparm...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/testparm
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
 
Program received signal SIGSEGV, Segmentation fault.
0x00000cec in ?? ()
(gdb) bt
#0  0x00000cec in ?? ()
#1  0xb6e8df30 in debug_parse_levels () from /usr/lib/samba/libsamba-debug-samba4.so
#2  0xb6ca82c8 in set_variable () from /usr/lib/libsamba-hostconfig.so.0
#3  0xb6ca8488 in lpcfg_do_global_parameter () from /usr/lib/libsamba-hostconfig.so.0
#4  0xb6ca8958 in lpcfg_set_cmdline () from /usr/lib/libsamba-hostconfig.so.0
#5  0xb6edcb5c in lp_set_cmdline () from /usr/lib/libsmbconf.so.0
#6  0x7f556b80 in main ()
(gdb)


-EDIT-
smbclient crashes as well, the backtrace is similar to the one from testparm:
Code: Select all
#0  0x00000cec in ?? ()
#1  0xb6867f30 in debug_parse_levels () from /usr/lib/samba/libsamba-debug-samba4.so
#2  0xb65232c8 in set_variable () from /usr/lib/libsamba-hostconfig.so.0
#3  0xb6523488 in lpcfg_do_global_parameter () from /usr/lib/libsamba-hostconfig.so.0
#4  0xb6523958 in lpcfg_set_cmdline () from /usr/lib/libsamba-hostconfig.so.0
#5  0xb6d0ab5c in lp_set_cmdline () from /usr/lib/libsmbconf.so.0
#6  0x7f55a62c in main ()


And /var/log/samba/log.smbd is empty.

I did strace -f to testparm,smbd and smbclient, they are here:
http://wpage.unina.it/aorefice/sharevari/sambacrash/

Any hint please?
Last edited by kokoko3k on Fri Mar 11, 2016 7:19 am, edited 1 time in total.
kokoko3k
 
Posts: 9
Joined: Sat Jan 03, 2015 1:27 pm

Re: Samba segmentation fault

Postby kokoko3k » Fri Mar 11, 2016 7:18 am

Ok, that was my fault.
I forgot that i've installed arm-mem-git since it wasn't present in the aur binary repo; that's why it wasn't updated.
Just updated it; and now samba works again.
kokoko3k
 
Posts: 9
Joined: Sat Jan 03, 2015 1:27 pm


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 5 guests