PcDuino 3 and Archlinux arm?

This forum is for supported devices using an ARMv7 Allwinner SoC.

PcDuino 3 and Archlinux arm?

Postby nidzo » Wed May 19, 2021 9:02 pm

Hello everyone. I have recently tried to follow the provided instructions on how to install arch linux on Pcduino 3 (provided here https://archlinuxarm.org/platforms/armv7/allwinner/pcduino3#installation but it is simply not booting after I did all the steps. Now what I have treid is used the one of the older Arch linux arm distros (few years old) with a kernel (Linux PcDuino3-alarm 3.4.79+ #12 SMP PREEMPT Mon Jul 21 13:05:42 CST 2014 armv7l GNU/Linux) but this is simply just too old. Therefore I am trying to bring it up to date, still following happens.

Code: Select all
 pacman -Syu uboot-pcduino3
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 alarm is up to date
 aur is up to date
:: Starting full system upgrade...
:: Replace ca-certificates-cacert with core/ca-certificates? [Y/n]
:: Replace libdbus with core/dbus? [Y/n]
:: Replace libsystemd with core/systemd-libs? [Y/n]
:: Replace libutil-linux with core/util-linux-libs? [Y/n]
:: Replace linux-sun7i with core/linux-armv7? [Y/n]
resolving dependencies...
looking for inter-conflicts...

Packages (157): acl-2.3.1-1  archlinuxarm-keyring-20140119-1  argon2-20190702-3  attr-2.5.1-1  audit-3.0.1-1  bash-5.1.008-1  bzip2-1.0.8-4  ca-certificates-20181109-4
                ca-certificates-cacert-20140824-1 [removal]  ca-certificates-mozilla-3.65-1  ca-certificates-utils-20181109-4  coreutils-8.32-1  cracklib-2.9.7-2  cryptsetup-2.3.5-4
                curl-7.76.1-1  db-5.3.28-5  dbus-1.12.20-1  device-mapper-2.03.12-1  dhcpcd-9.4.0-1  diffutils-3.7-3  dnssec-anchors-20190629-3  e2fsprogs-1.46.2-1  expat-2.3.0-1
                file-5.40-3  filesystem-2021.01.19-1  findutils-4.8.0-1  gawk-5.1.0-1  gcc-libs-10.2.0-1  gdbm-1.19-2  gettext-0.21-1  glib2-2.68.2-1  glibc-2.32-2  gmp-6.2.1-1
                gnupg-2.2.27-1  gnutls-3.7.1-1  gpgme-1.15.1-1  grep-3.6-1  groff-1.22.4-5  gzip-1.10-3  haveged-1.9.14-1  hwids-20201207-1  iana-etc-20210202-1  icu-69.1-1
                inetutils-1.9.4-9  iproute2-5.12.0-1  iptables-1:1.8.7-1  iputils-20210202-1  jfsutils-1.1.15-7  json-c-0.15-1  kbd-2.4.0-2  keyutils-1.6.3-1  kmod-28-1
                krb5-1.19.1-1  ldns-1.7.1-2  less-1:581.2-1  libaio-0.3.112-2  libarchive-3.5.1-1  libassuan-2.5.5-1  libcap-2.49-1  libcap-ng-0.8.2-1  libcroco-0.6.13-2
                libdbus-1.8.10-1 [removal]  libedit-20210419_3.1-1  libelf-0.184-1  libffi-3.3-4  libgcrypt-1.9.3-1  libgpg-error-1.42-1  libidn-1.37-1  libidn2-2.3.1-1  libinih-53-1
                libksba-1.4.0-2  libldap-2.4.58-2  libmnl-1.0.4-3  libnetfilter_conntrack-1.0.8-1  libnfnetlink-1.0.1-4  libnftnl-1.1.9-1  libnghttp2-1.43.0-1  libnl-3.5.0-2
                libp11-kit-0.23.22-1  libpcap-1.10.0-1  libpipeline-1.5.3-1  libpsl-0.21.1-1  libsasl-2.1.27-3  libseccomp-2.5.1-2  libsecret-0.20.4-1  libssh2-1.9.0-3
                libsystemd-217-8 [removal]  libtasn1-4.17.0-1  libtirpc-1.3.2-1  libunistring-0.9.10-3  libusb-1.0.24-2  libutil-linux-2.25.2-1 [removal]  libxcrypt-4.4.20-1
                libxml2-2.9.10-9  licenses-20200427-1  linux-api-headers-5.12.3-1  linux-armv7-5.11.2-1  linux-firmware-20210511.7685cf4-1  linux-sun7i-3.4.90-5 [removal]
                logrotate-3.18.0-1  lvm2-2.03.12-1  lz4-1:1.9.3-1  lzo-2.10-3  man-db-2.9.4-1  man-pages-5.11-1  mdadm-4.1-2  mkinitcpio-30-1  mkinitcpio-busybox-1.32.1-3
                mpfr-4.1.0-2  nano-5.7-1  ncurses-6.2-2  net-tools-2.10-1  netctl-1.24-1  nettle-3.7.2-1  npth-1.6-3  openresolv-3.12.0-1  openssh-8.6p1-1  openssl-1.1.1.k-1
                p11-kit-0.23.22-1  pacman-5.2.2-4  pacman-mirrorlist-20210307-1  pam-1.5.1-1  pambase-20200721.1-2  pciutils-3.7.0-1  pcre-8.44-1  pcre2-10.36-1  perl-5.32.1-1
                pinentry-1.1.1-1  popt-1.18-1  procps-ng-3.3.17-1  psmisc-23.4-1  pth-2.0.7-7  readline-8.1.001-1  reiserfsprogs-3.6.27-3  run-parts-4.11.2-1  s-nail-14.9.22-1
                sed-4.8-1  shadow-4.8.1-4  sqlite-3.35.5-1  sysfsutils-2.1.1-1  systemd-248.3-2  systemd-libs-248.3-2  systemd-sysvcompat-248.3-2  tar-1.34-1  texinfo-6.7-3
                thin-provisioning-tools-0.9.0-1  tzdata-2021a-1  usbutils-013-1  util-linux-2.36.2-1  util-linux-libs-2.36.2-1  vi-1:070224-5  which-2.21-5  xfsprogs-5.11.0-2
                xz-5.2.5-1  zlib-1:1.2.11-4  zstd-1.4.9-1  uboot-pcduino3-2017.01-2

Total Download Size:    0.17 MiB
Total Installed Size:   1285.83 MiB
Net Upgrade Size:       899.95 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
 uboot-pcduino3-2017.01-2-armv7h                                                     177.9 KiB  4.83M/s 00:00 [------------------------------------------------------------------] 100%
(152/152) checking keys in keyring                                                                            [------------------------------------------------------------------] 100%
^[[1~(117/152) checking package integrity                                                                          [-----------------------------------------------------co  o  o  o  ](152/152) checking package integrity                                                                          [------------------------------------------------------------------] 100%
(152/152) loading package files                                                                               [------------------------------------------------------------------] 100%
error: error while reading package /var/cache/pacman/pkg/iputils-20210202-1-armv7h.pkg.tar.xz: Ignoring malformed pax extended attribute
error: failed to commit transaction (libarchive error)
Errors occurred, no packages were upgraded.

How can I bring this system up to date? Any help would be apreciated. Thank you in advance
Posts: 6
Joined: Wed Dec 24, 2014 3:51 am

Re: PcDuino 3 and Archlinux arm?

Postby moonman » Wed May 19, 2021 10:04 pm

A few years old is too old for a rolling distro like Arch. Some executables are so out of date that they you can't use them to install/upgrade packages from repo.

I don't have pcduino, but not being able to boot following the instructions usually means you are doing something wrong, or hardware failure (which doesn't seem to be the case here).
Connect a serial or monitor and see what's wrong. If you get no output at all, then u-boot is probably not installed.

You may also want to check this out for after you get your new install working https://wiki.archlinux.org/title/Pacman/Rosetta
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
[armv5] Updated U-Boot | [armv5] NAND Rescue System
Posts: 3332
Joined: Sat Jan 15, 2011 3:36 am

Re: PcDuino 3 and Archlinux arm?

Postby graysky » Thu May 20, 2021 10:18 am

Well, linux-sun7i was replaced by linux-armv7 on Jun 13 2015 so you're in for an uphill battle. Probably better to backup the media and just reinstall. If you don't want to try moonman's suggestion, another option is to use TARDIS (http://tardis.tiny-vps.com/aarm/repos/) to step forward in several month increments, then update the box until you're current. Not fool-proof but an option.

The oldest package on TARDIS is Nov 28 2015 so:
1. Edit /etc/pacman.d/mirrorlist and comment out all servers then add this one:
Code: Select all
Server = http://tardis.tiny-vps.com/aarm/repos/2015/11/28/$arch/$repo

2. Run pacman -Syu
3. Reboot and verify everything works
4. Repeat 1 and move the date up 3 or 4 months.
Posts: 1026
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: PcDuino 3 and Archlinux arm?

Postby moonman » Fri May 21, 2021 6:53 am

graysky wrote:another option is to use TARDIS

Good call. Totally forgot about the archive
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
[armv5] Updated U-Boot | [armv5] NAND Rescue System
Posts: 3332
Joined: Sat Jan 15, 2011 3:36 am

Re: PcDuino 3 and Archlinux arm?

Postby nidzo » Sat May 22, 2021 5:52 pm

Thank you all for the reply. I have however managed to install it now. It is up and runing. I think the problem was that I was approaching it as a "normal" linux install on a PC and did partition the SD card, while the guide says to explicitly make only one partition. I have no idea what TARDIS is! :D
Posts: 6
Joined: Wed Dec 24, 2014 3:51 am

Re: PcDuino 3 and Archlinux arm?

Postby nickb333 » Fri Jul 23, 2021 5:19 pm

I've had Arch Linux Arm running happly on a PcDuino3 for a few years with continuous upgrades. I also have a SATA hard drive. The initial boot is from the SD card before transferring to the HD. I run the system headless, access either over ssh or vnc to xorg running LXDE desktop.

I found I needed to use the pcduino3-nano rather than the pcduino3 bootloader. http://dk.mirror.archlinuxarm.org/os/sunxi/boot/ shows what other versions are available.

Sorry for the late reply, only just found the thread, sounds like you are up and running! My only minor issue is that the kernel doesn't seem to have been updated for a few months, currently I have linux-armv7 5.11.2-1.
Posts: 1
Joined: Fri Jul 23, 2021 5:03 pm

Return to Allwinner

Who is online

Users browsing this forum: No registered users and 2 guests