[SOLVED] Audio with Cubieboard2 (A20)

This forum is for supported devices using an ARMv7 Allwinner SoC.

[SOLVED] Audio with Cubieboard2 (A20)

Postby uxalarm » Sat Jun 04, 2016 8:48 am

Is the audio supposed to work on the Cubieboard 2?

I'm trying to have some audio out of the jack.

First trying to figure out the available output(s), but can only see one device (not supposed to have jack and HDMI?):
Code: Select all
[ux@chiisai ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sun4icodec [sun4i-codec], device 0: CDC PCM Codec-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Trying to play something anyway:
Code: Select all
[ux@chiisai ~]$ speaker-test -c 2

speaker-test 1.1.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 131072
Period size range from 64 to 16384
Using max buffer size 131072
Periods = 4
was set period_size = 16384
was set buffer_size = 131072
 0 - Front Left
 1 - Front Right
Write error: -5,Input/output error
xrun_recovery failed: -5,Input/output error
Transfer failed: Input/output error
[ux@chiisai ~]$


I/O error (after a few secondes), but nothing interesting in dmesg AFAICT:
Code: Select all
[ux@chiisai ~]$ dmesg |grep sun
[    1.710136] sun4i-usb-phy 1c13400.phy: could not find pctldev for node /soc@01c00000/pinctrl@01c20800/usb0_id_detect_pin@0, deferring probe
[    1.716126] sun7i-a20-pinctrl 1c20800.pinctrl: initialized sunXi PIO driver
[    2.746853] sunxi-rtc 1c20d00.rtc: rtc core: registered rtc-sunxi as rtc0
[    2.753705] sunxi-rtc 1c20d00.rtc: RTC enabled
[    2.793371] sunxi-wdt 1c20c90.watchdog: Watchdog enabled (timeout=16 sec, nowayout=1)
[    2.841448] sunxi-mmc 1c0f000.mmc: Got CD GPIO
[    2.872957] sunxi-mmc 1c0f000.mmc: base:0xf08c6000 irq:26
[    3.047719] ahci-sunxi 1c18000.sata: controller can't do PMP, turning off CAP_PMP
[    3.055293] ahci-sunxi 1c18000.sata: SSS flag set, parallel bus scan disabled
[    3.062486] ahci-sunxi 1c18000.sata: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode
[    3.071461] ahci-sunxi 1c18000.sata: flags: ncq sntf stag pm led clo only pio slum part ccc
[    3.081135] scsi host0: ahci-sunxi
[    3.593915] sunxi-rtc 1c20d00.rtc: setting system clock to 1970-01-01 00:00:21 UTC (21)
[   11.269228] sun4i-ss 1c15000.crypto-engine: no reset control found
[   11.277120] sun4i-ss 1c15000.crypto-engine: Die ID 0
[   11.378273] input: sunxi-ir as /devices/platform/soc@01c00000/1c21800.ir/rc/rc0/input0
[   11.402779] rc rc0: sunxi-ir as /devices/platform/soc@01c00000/1c21800.ir/rc/rc0
[   11.445502] sunxi-ir 1c21800.ir: initialized sunXi IR driver
[   12.218109] rc rc0: lirc_dev: driver ir-lirc-codec (sunxi-ir) registered at minor = 0
[   12.668906] sun4i-codec 1c22c00.codec: Codec <-> 1c22c00.codec mapping ok
[   12.850288] sun7i-dwmac 1c50000.ethernet: no regulator found
[   12.858530] sun7i-dwmac 1c50000.ethernet: no reset control found
[   19.743050] sun7i-dwmac 1c50000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx


Oh, and I'm in the audio group and it's the same as a root user.

I'm using the mainline kernel as it's the default one with this board.
Code: Select all
[ux@chiisai ~]$ uname -a
Linux chiisai 4.6.0-3-ARCH #1 SMP Sat May 21 10:58:31 MDT 2016 armv7l GNU/Linux


Any suggestion?

EDIT: needed to unmute "Power Amplifier DAC" and "Power Amplifier Mute" in alsamixer to fix the I/O errors, and raise the "Power Amplifier" to hear something. Curious behaviour, but be it. Maybe an /etc/asound.conf should be created.
uxalarm
 
Posts: 4
Joined: Sat Jun 04, 2016 8:29 am

Return to Allwinner

Who is online

Users browsing this forum: No registered users and 2 guests