pcDuino3 Nano SD card issues

This forum is for supported devices using an ARMv7 Allwinner SoC.

pcDuino3 Nano SD card issues

Postby alphaniner » Mon Jun 27, 2016 7:40 pm

Using an x86 system and a SDHC to USB adapter, I configured a 4GB Class4 SDHC card for a pcDuino3 Nano. When powered on the system didn't initialize beyond the point with the blinking cursor just below two penguins. I reconnected the card to the x86 system and found the filesystem was corrupt. I repeated the process from the beginning and the same thing occurred.

Then I booted the pcd3n to the built-in system and tried to prepare ALARM from there. Certain types of I/O to the SD card succeeded (wipefs,dd,fdisk) but when I tried to format the process hung indefinitely, and dmesg showed some kind of trace related to the format. The problem did not occur with a different SD card (also 4GB Class4) and I was able to get ALARM up and running on it, so at that point I assumed there was probably something wrong with the first one that didn't get exposed when using a USB adapter.

But a few things have occurred since to make me wonder if there may actually be a problem with the pcd3n. One, the 'bad' SD card tested fine in two other ARM systems (Beaglebone Black, RasPi 3). Two, while the ALARM system on the pcd3 is stable, reading and writing from/to the SD card (mostly just editing config files) often hangs for a second on file open or write. Navigating and working on system just generally feels sluggish compared to the BeagleBone which was configured for the same purpose (rtorrent+rutorrent). OTOH, everything related to rutorrent and rtorrent - which resides on a SATA attached HDD - is as responsive as I would expect.

Ultimately, I'm wondering if these things could indicate a problem with the pcd3n since I still have the opportunity to return it.

Thanks for reading.
Posts: 1
Joined: Mon Jun 27, 2016 3:22 pm

Return to Allwinner

Who is online

Users browsing this forum: No registered users and 1 guest