No tty with latest build on CT Plus

This forum is for supported devices using an ARMv7 Allwinner SoC.

No tty with latest build on CT Plus

Postby DocBoolean » Fri Jul 06, 2018 10:14 am

Hi,

I'm running one of the latest ALARM builds with kernel 4.17.2 on my Cubietruck Plus (ArchLinuxARM-armv7-latest), but I don't get any tty via HDMI, I have to work via serial console (ttyS0).

How can I activate HDMI output / ttys ?

My Kernel command line:
Code: Select all
console=ttyS0,115200 console1=tty0 earlyprintk root=/dev/mmcblk0p2 rootwait panic=5


and in boot.cmd:
Code: Select all
setenv bootargs console=ttyS0,115200 console1=tty0 earlyprintk root=/dev/mmcblk0p2 rootwait panic=5 ${extra}



Please help :)
DocBoolean
 
Posts: 7
Joined: Tue Jul 03, 2018 8:12 am

Re: No tty with latest build on CT Plus

Postby summers » Fri Jul 06, 2018 11:49 am

Good that you have got it to boot. Is the ethernet working, if so it should bring up the network, and it may be easier to log in across the network.

Anyway no hdmi, I run most of my boxes headless, so am not the best person to answer. me though I'd look in "dmesg" and see if the display was detected. Hopefully you managed to boot using the CT Plus device tree, as that usually describes what the display hardware is like - so if that wrong it won't work.

Then its a case of making sure you have the right drivers for your hardware, be that mali or whatever ...

Good though that you have made progress.
summers
 
Posts: 926
Joined: Sat Sep 06, 2014 12:56 pm

Re: No tty with latest build on CT Plus

Postby DocBoolean » Fri Jul 06, 2018 12:34 pm

Hi,

after doing further research I found out that the CT Plus has a PowerVR SGX544 GPU, but I can't find an option for that in the graphics section of the current kernel, not even in sunxi-next.

All I could find is in
Code: Select all
 Device Drivers → Graphics support → Display Interface Bridges →Toshiba TC358767 eDP bridge (NEW)

I will try with that enabled, but the sunxi-page states that the CT Plus has a Toshiba TC358777XBG MIPI DSI - DP bridge.

All dmesg gives me regarding display/GPU is
Code: Select all
vdd-gpu: disabling


Do you know anything about this device ?


P.S.: Ethernet is working perfectly, I can SSH to it, but that doesn't solve my HDMI problem. :)
DocBoolean
 
Posts: 7
Joined: Tue Jul 03, 2018 8:12 am

Re: No tty with latest build on CT Plus

Postby summers » Fri Jul 06, 2018 1:05 pm

PowerVR have never been that well supported with linux, think its becuase the specs aren't open. IIRC it means there is no accelerated graphics, but I though they could usually bring up the screen accelerated. I think one of my boxes at home (maybe the BBB) is PowerVR so I could check that. This said though it currently has HDMI disabled (some else here asked about that).
summers
 
Posts: 926
Joined: Sat Sep 06, 2014 12:56 pm

Re: No tty with latest build on CT Plus

Postby DocBoolean » Fri Jul 06, 2018 1:58 pm

Sorry,

I couldn't get the sunxi-4.17.4 sources, now sunxi-next is on 4.18.0-rc1 which crashes on boot (...rc1 :) )

I will try to compile mainline 4.17.4, but just for testing, because with mainline I only get one core, sunxi-next gives me all 8 :)
Last edited by DocBoolean on Fri Jul 06, 2018 2:41 pm, edited 1 time in total.
DocBoolean
 
Posts: 7
Joined: Tue Jul 03, 2018 8:12 am

Re: No tty with latest build on CT Plus

Postby summers » Fri Jul 06, 2018 2:22 pm

If you boot from an arch kernel, you will ususally have "/proc/config.gz", that you can copy out and uncompress, and it will give the options that the arch kernel was compiled by. That should be a good place to start from in doing your own home brew kernels.
summers
 
Posts: 926
Joined: Sat Sep 06, 2014 12:56 pm

Re: No tty with latest build on CT Plus

Postby DocBoolean » Fri Jul 06, 2018 2:55 pm

summers:
I already tried that, but compile failed at some module:

Code: Select all
make[1]: *** Keine Regel vorhanden, um das Ziel „firmware/am335x-pm-firmware.elf“,
  benötigt von „firmware/am335x-pm-firmware.elf.gen.o“, zu erstellen.  Schluss.
make: *** [Makefile:1034: firmware] Fehler 2

There seems to be a problem with am335x-pm-firmware. -> can't cross compile with the current kernel config provided by config.gz, sorry.
Last edited by DocBoolean on Fri Jul 06, 2018 4:06 pm, edited 3 times in total.
DocBoolean
 
Posts: 7
Joined: Tue Jul 03, 2018 8:12 am

Re: No tty with latest build on CT Plus

Postby summers » Fri Jul 06, 2018 3:31 pm

You should be able to do
Code: Select all
make oldconfig
then it will use the old config, and just prompt for the new options. The file it finally writes will be good for the main compile.
summers
 
Posts: 926
Joined: Sat Sep 06, 2014 12:56 pm

Re: No tty with latest build on CT Plus

Postby DocBoolean » Wed Jul 11, 2018 4:43 pm

OK,

I experimented a little bit with u-boot versions and found out, that I somehow have to include my sys_config.bin in the loading process.
Sunxi does this by merging u-boot with the sys_config, but this is not working with mainline u-boot files. I dd-ed the sunxi-version, couldn't boot my kernel due to incompatible configs, BUT my hdmi output got activated!

So...now I have to find a way to load my sys_config.bin with mainline u-boot in boot.scr, but even after heavy testing I couldn't find the right way to do that.

Maybe someone can help me with that :)

This is my current boot.cmd:
Code: Select all
ext2load mmc 0 0x44000000 sys_config.bin
ext2load mmc 0 0x46000000 zImage
ext2load mmc 0 0x49000000 sun8i-a83t-cubietruck-plus.dtb
setenv bootargs console=ttyS0,115200 console1=tty0 consoleblank=0 earlyprintk root=/dev/mmcblk0p2 rootwait panic=5 ${extra}
bootz 0x46000000 - 0x49000000
DocBoolean
 
Posts: 7
Joined: Tue Jul 03, 2018 8:12 am


Return to Allwinner

Who is online

Users browsing this forum: No registered users and 2 guests