[Solved] Audio on cubieboard in 4.4 kernel

This forum is for supported devices using an ARMv7 Allwinner SoC.

[Solved] Audio on cubieboard in 4.4 kernel

Postby joximus » Fri Jan 29, 2016 10:45 am

Does audio work in new mainline kernel linux-armv7 4.4.0 on A10 (cubieboard)?
joximus
 
Posts: 9
Joined: Mon Mar 30, 2015 7:22 pm

Postby joximus » Sun Jan 31, 2016 11:06 pm

To answer my own question. Audio is not working. This is output of alsa-info.sh:
Code: Select all
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Sun Jan 31 23:00:08 UTC 2016


!!Linux Distribution
!!------------------

Arch Linux \r (\l) NAME="Arch Linux ARM" ID=archarm ID_LIKE=arch PRETTY_NAME="Arch Linux ARM" HOME_URL="http://archlinuxarm.org/" SUPPORT_URL="https://archlinuxarm.org/forum" BUG_REPORT_URL="https://github.com/archlinuxarm/PKGBUILDs/issues"


!!DMI Information
!!---------------

Manufacturer:     
Product Name:     
Product Version:   
Firmware Version: 


!!Kernel Information
!!------------------

Kernel release:    4.4.0-5-ARCH
Operating System:  GNU/Linux
Architecture:      armv7l
Processor:         unknown
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k4.4.0-5-ARCH
Library version:    1.1.0
Utilities version:  1.1.0


!!Loaded ALSA modules
!!-------------------



!!Sound Servers on this system
!!----------------------------

No sound servers found.


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [sun4icodec     ]: sun4i-codec - sun4i-codec
                      sun4i-codec


!!PCI Soundcards installed in the system
!!--------------------------------------



!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------



!!Loaded sound module options
!!---------------------------


!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116,  2 Jan 31 22:58 /dev/snd/controlC0
crw-rw---- 1 root audio 116,  3 Jan 31 22:58 /dev/snd/pcmC0D0p
crw-rw---- 1 root audio 116,  1 Jan 31 22:58 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Jan 31 22:58 /dev/snd/timer

/dev/snd/by-path:
total 0
drwxr-xr-x 2 root root  60 Jan 31 22:58 .
drwxr-xr-x 3 root root 140 Jan 31 22:58 ..
lrwxrwxrwx 1 root root  12 Jan 31 22:58 platform-1c22c00.codec -> ../controlC0


!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:268: no soundcards found...

ARECORD

arecord: device_list:268: no soundcards found...

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [sun4icodec]

Invalid card number.
Usage: amixer <options> [command]

Available options:
  -h,--help       this help
  -c,--card N     select the card
  -D,--device N   select the device, default 'default'
  -d,--debug      debug mode
  -n,--nocheck    do not perform range checking
  -v,--version    print version of this program
  -q,--quiet      be quiet
  -i,--inactive   show also inactive controls
  -a,--abstract L select abstraction level (none or basic)
  -s,--stdin      Read and execute commands from stdin sequentially
  -R,--raw-volume Use the raw value (default)
  -M,--mapped-volume Use the mapped volume

Available commands:
  scontrols       show all mixer simple controls
  scontents       show contents of all mixer simple controls (default command)
  sset sID P      set contents for one mixer simple control
  sget sID        get contents for one mixer simple control
  controls        show all controls for given card
  contents        show contents of all controls for given card
  cset cID P      set control contents for one control
  cget cID        get control contents for one control
Invalid card number.
Usage: amixer <options> [command]

Available options:
  -h,--help       this help
  -c,--card N     select the card
  -D,--device N   select the device, default 'default'
  -d,--debug      debug mode
  -n,--nocheck    do not perform range checking
  -v,--version    print version of this program
  -q,--quiet      be quiet
  -i,--inactive   show also inactive controls
  -a,--abstract L select abstraction level (none or basic)
  -s,--stdin      Read and execute commands from stdin sequentially
  -R,--raw-volume Use the raw value (default)
  -M,--mapped-volume Use the mapped volume

Available commands:
  scontrols       show all mixer simple controls
  scontents       show contents of all mixer simple controls (default command)
  sset sID P      set contents for one mixer simple control
  sget sID        get contents for one mixer simple control
  controls        show all controls for given card
  contents        show contents of all controls for given card
  cset cID P      set control contents for one control
  cget cID        get control contents for one control


!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--


!!All Loaded Modules
!!------------------

Module
sun4i_codec
snd_soc_core
evdev
snd_pcm_dmaengine
ac97_bus
snd_pcm
snd_timer
sun4i_ts
sun4i_ss
mdio_sun4i
sun4i_emac
spi_sun4i
uio_pdrv_genirq
uio
sch_fq_codel
ip_tables
x_tables


!!ALSA/HDA dmesg
!!--------------

[    3.757454] vcc5v0: disabling
[    3.761080] ALSA device list:
[    3.764085]   No soundcards found.
[    3.769410] EXT4-fs (mmcblk0p1): couldn't mount as ext3 due to feature incompatibilities
Last edited by joximus on Mon Feb 01, 2016 8:29 pm, edited 1 time in total.
joximus
 
Posts: 9
Joined: Mon Mar 30, 2015 7:22 pm

Re: Audio on cubieboard in 4.4 kernel

Postby WarheadsSE » Mon Feb 01, 2016 3:36 pm

Code Tags Please
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm

Re: Audio on cubieboard in 4.4 kernel

Postby joximus » Mon Mar 21, 2016 8:55 am

Just to report that audio is working in new 4.5 linux kernel.
joximus
 
Posts: 9
Joined: Mon Mar 30, 2015 7:22 pm

Re: [Solved] Audio on cubieboard in 4.4 kernel

Postby ho9693 » Fri Jun 03, 2016 7:07 pm

I'm using mainline 4.6.0-3-ARCH kernel with my cubieboard2 (Not dual card),
and audio work.
ho9693
 
Posts: 2
Joined: Sun May 29, 2016 9:48 am

Re: [Solved] Audio on cubieboard in 4.4 kernel

Postby skostyuk » Sun Jul 10, 2016 11:10 am

Audio works for me:

- Cubieboard A10
- Linux alarm 4.6.3-1-ARCH #1 SMP Sat Jul 2 21:22:12 MDT 2016 armv7l GNU/Linux
- Alsamixer settings: http://i.imgur.com/uvCCNkB.png
- active modules: http://pastebin.com/wwwTsSjp
skostyuk
 
Posts: 1
Joined: Fri Jun 19, 2015 8:47 am


Return to Allwinner

Who is online

Users browsing this forum: No registered users and 1 guest