perl-sys-mmap

Make a PKGBUILD? Submit it here for user review and possible placement into the repository.

perl-sys-mmap

Postby Socaltom » Sat Aug 30, 2014 2:20 pm

So I'm trying to get zoneminder to run on my fancy new NAS325. I got the pkg built by moonman a while back and installed it. ( followed all the instructions this time :roll: ) but apparently the perl-sys-mmap isn't compatible with the current version of perl. I tried to build a package from the AUR at Arch, but it won't build for ARM, even when I add arch-arm to the PKGBUILD file.
So I either need perl v5.16.0 or I need help compiling a new sys-mmap base on 5.20? or did I get this wrong?
Thanks
Tom

Code: Select all
Perl API version v5.16.0 of Sys::Mmap does not match v5.20.0 at /usr/lib/perl5/vendor_perl/Sys/Mmap.pm line 302.
Compilation failed in require at /usr/share/perl5/vendor_perl/ZoneMinder/Memory/Mapped.pm line 69.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/ZoneMinder/Memory/Mapped.pm line 69.
Compilation failed in require at /usr/share/perl5/vendor_perl/ZoneMinder/Memory.pm line 120.
Compilation failed in require at /usr/share/perl5/vendor_perl/ZoneMinder.pm line 37.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/ZoneMinder.pm line 37.
Compilation failed in require at /usr/bin/zmpkg.pl line 37.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 37.
Owned by me
Pink Pogo V2, Black Pogo V3, Zyxel NAS 325 v1,
Adminstrator for
Goflex net, Black V3, Black V2
Socaltom
 
Posts: 567
Joined: Thu Apr 07, 2011 2:21 pm
Location: The left side

Re: perl-sys-mmap

Postby moonman » Sat Aug 30, 2014 11:21 pm

There is a newer version: 0.17 so change source and version in pkgbuild. Im thinking that might not be enough and whole zoneminder package needs to be recompiled... maybe not, you will have to try.
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3089
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: perl-sys-mmap [solved]

Postby Socaltom » Sun Aug 31, 2014 1:40 am

when I try to makepkg I get this message
Code: Select all
==> ERROR: perl-sys-mmap is not available for the 'arm' architecture.
    Note that many packages may need a line added to their PKGBUILD
    such as arch=('arm').


If put the arch=('arm') in the PKGBUILD but I still get the message.

Nevermind, I needed to correct the other arch= statement. Its working now
Owned by me
Pink Pogo V2, Black Pogo V3, Zyxel NAS 325 v1,
Adminstrator for
Goflex net, Black V3, Black V2
Socaltom
 
Posts: 567
Joined: Thu Apr 07, 2011 2:21 pm
Location: The left side

Re: perl-sys-mmap

Postby pepedog » Sun Aug 31, 2014 7:38 am

makepkg -A
Would have overcome this
pepedog
Developer
 
Posts: 2431
Joined: Mon Jun 07, 2010 3:30 pm
Location: London UK


Return to User-Submitted Packages

Who is online

Users browsing this forum: No registered users and 1 guest