cubox-i4 kodi no video playback, freeze after a few seconds

This forum is for supported devices using an ARMv7 Freescale SoC.

cubox-i4 kodi no video playback, freeze after a few seconds

Postby rp9 » Mon Dec 05, 2016 8:10 am

Updated to the latest packages.
If I start video playback in kodi, I can hear the audio stream, but kodi doesn't switch to video playback and after ~10 sec kodi freezes.

Anyone else experiencing this?
rp9
 
Posts: 2
Joined: Sat Aug 18, 2012 11:31 am

Re: cubox-i4 kodi no video playback, freeze after a few seco

Postby aplund » Sat Dec 10, 2016 8:51 pm

Yes!!! Gah. I thought it was just my local config. I've been through just about everything and didn't find anything.

I have no idea how to test the vpu on this system. It's a bit of a ... black box.

I did manage to get a mpeg2 stream to play, but it might be software decoded.
aplund
 
Posts: 16
Joined: Tue Feb 04, 2014 5:27 am

Re: cubox-i4 kodi no video playback, freeze after a few seco

Postby Suby » Thu Dec 15, 2016 9:29 pm

This problem is due to the update of imx-vpu to version 5.4.33-1.

If you roll back to 5.4.32-1 the issue should be solved.

It has been reported on the cubox-i forum here( where a fix is also described).

it has been notified on github here.

Please let me me know if there is a better way of notifying the issue as in this forum it is suggested to
report this is in our GitHub issue tracker.
which I wans't able to find (not an expert on github).
Suby
 
Posts: 1
Joined: Thu Dec 15, 2016 9:23 pm

Re: cubox-i4 kodi no video playback, freeze after a few seco

Postby aplund » Sun Dec 18, 2016 8:39 pm

The downgrade also worked for me, but now after a video plays I just get a black screen. Nothing out of the ordinary in the kodi.log file.
aplund
 
Posts: 16
Joined: Tue Feb 04, 2014 5:27 am

Re: cubox-i4 kodi no video playback, freeze after a few seco

Postby moonman » Sat Dec 31, 2016 2:39 am

Do a full system update. Problem has been fixed
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | |[armv5] How to install my.pogoplug.com service | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3089
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada


Return to Freescale

Who is online

Users browsing this forum: No registered users and 1 guest