Cubox-I imx-hdmi-audio problem

This forum is for supported devices using an ARMv7 Freescale SoC.

Cubox-I imx-hdmi-audio problem

Postby cuboxiuser » Tue Feb 07, 2017 11:01 am

Hi,

After an ArchLinux update some time ago, the HDMI driver has some problems on my Cuboxi:
imx-hdmi-audio imx-hdmi-audio: ASoC: can't open platform imx-hdmi-audio: -22
I also made a full system update just 2 days ago (pacman -Syu), but the problem persists.

Extract from the kernel log
Code: Select all
[    0.000000] Linux version 3.14.79-1-ARCH (oleg@alarmOdroidU2) (gcc version 6.2.1 20160830 (GCC) ) #1 SMP Tue Sep 13 01:21:17 MDT 2016
[...]
[    0.000000] Machine model: SolidRun Cubox-i Solo/DualLite
[...]
[    0.000000] Kernel command line: root=/dev/mmcblk0p1 rootwait rw console=tty1 console=ttymxc0,115200 consoleblank=0 video=mxcfb0:dev=hdmi,1280x720M@60,if=RGB24,bpp=32 dmfc=3 ahci_imx.hotplug=1 pci=nomsi loop.max_part=15
[    0.093075] imx6dl-pinctrl 20e0000.iomuxc: initialized IMX pinctrl driver
[    0.251394] imx-ipuv3 2400000.ipu: IPU DMFC ONLY-DP HIGH RESOLUTION: 5B(0~3), 5F(4~7)
[    0.645683] imx-sdma 20ec000.sdma: no iram assigned, using external mem
[    0.646203] imx-sdma 20ec000.sdma: no event needs to be remapped
[    0.646599] imx-sdma 20ec000.sdma: loaded firmware 3.1
[    0.649200] imx-sdma 20ec000.sdma: initialized
[    2.267356] imx2-wdt 20bc000.wdog: IMX2+ Watchdog Timer enabled. timeout=60s (nowayout=0)
[    2.638659] sdhci-esdhc-imx 2194000.usdhc: could not get ultra high speed state, work on normal mode
[    2.977634] imx-spdif sound-spdif.29: snd-soc-dummy-dai <-> 2004000.spdif mapping ok
[    3.019906] imx-audio-hdmi sound-hdmi.30: hdmi-hifi <-> hdmi_audio.3 mapping ok
[    3.212489]   #1: imx-hdmi-soc
[...]
[   15.797375] imx-hdmi-audio imx-hdmi-audio: HDMI Video is not ready!
[   15.797390] imx-hdmi-audio imx-hdmi-audio: ASoC: can't open platform imx-hdmi-audio: -22
[   15.914067] imx-hdmi-audio imx-hdmi-audio: HDMI Video is not ready!
[   15.914087] imx-hdmi-audio imx-hdmi-audio: ASoC: can't open platform imx-hdmi-audio: -22
[   15.915533] imx-hdmi-audio imx-hdmi-audio: HDMI Video is not ready!
[   15.915554] imx-hdmi-audio imx-hdmi-audio: ASoC: can't open platform imx-hdmi-audio: -22
[   18.560419] imx-hdmi-audio imx-hdmi-audio: HDMI Video is not ready!
[   18.560438] imx-hdmi-audio imx-hdmi-audio: ASoC: can't open platform imx-hdmi-audio: -22
[   18.569358] imx-hdmi-audio imx-hdmi-audio: HDMI Video is not ready!
[   18.569378] imx-hdmi-audio imx-hdmi-audio: ASoC: can't open platform imx-hdmi-audio: -22
[   18.570757] imx-hdmi-audio imx-hdmi-audio: HDMI Video is not ready!
[   18.570819] imx-hdmi-audio imx-hdmi-audio: ASoC: can't open platform imx-hdmi-audio: -22


As a result, Kodi can not play videos anymore.

Does anyone have similar problems?
Any ideas?
cuboxiuser
 
Posts: 1
Joined: Tue Feb 07, 2017 10:47 am

Return to Freescale

Who is online

Users browsing this forum: No registered users and 2 guests