Cubox-i - HDMI Stops Responding

This forum is for supported devices using an ARMv7 Freescale SoC.

Cubox-i - HDMI Stops Responding

Postby msalerno » Wed Feb 15, 2017 10:33 pm

Kernel - Linux MyCUBox 3.14.79-1-ARCH #1 SMP Tue Sep 13 01:21:17 MDT 2016 armv7l GNU/Linux
All packages updated

There seems to be an issue where my Cubox-i stops receiving a signal over HDMI after a few minutes. Everything works find and then the screen goes black and the TV reports that there is no signal.

I am able to SSH to the system and confirm that it is still operational.

I'm digging through the logs and dmesg to see if there are any error messages, but so far nothing stands out. I believe it may be an issue with the kernel since I have found other posts about the same problem.
Posts: 20
Joined: Wed Apr 16, 2014 11:13 pm

Re: Cubox-i - HDMI Stops Responding

Postby jjrytko » Sun Feb 19, 2017 8:21 pm

I have the same issue. When running Kodi HDMI is disconnected after about 10 minutes from Kodi startup. I can still control Kodi with remote via CEC, but my TV says that there is no signal and the screen is black. If I restart Kodi HDMI starts working again.

Have you found a solution? I tried downgrading to linux-imx6-3.14.73-1 kernel, but it didn't help.
Posts: 4
Joined: Mon Dec 29, 2014 7:01 pm

Re: Cubox-i - HDMI Stops Responding

Postby Polichronucci » Tue Feb 21, 2017 3:09 am

What happens is that the screen gets switched off due to inactivity. This is the console inactivity, it has nothing to do with video playback. To fix this you need to set consoleblank=0 in the kernel parameters.

The problem is caused by the new UBoot package (uboot-cubox-i 2017.01-01). Before this update the consoleblank=0 was defined in the uEnv.txt, now the uEnv.txt is not used anymore.
Note: uEnv.txt is no longer sourced. Make any customizations within /boot/boot.txt and run ./mkscr within /boot to convert it to the boot.scr file.

I tool all the previous defined kernel parameters from the uEnv.txt (including the consoleblank=0) and appended them to the boot.txt file "setenv bootargs" line. Then:
Code: Select all
cd /boot

Works like a charm.
Posts: 31
Joined: Wed Oct 09, 2013 10:47 am

Re: Cubox-i - HDMI Stops Responding

Postby jjrytko » Wed Feb 22, 2017 9:03 pm

Solved the problem for me, many thanks Polichronucci!
Posts: 4
Joined: Mon Dec 29, 2014 7:01 pm

Return to Freescale

Who is online

Users browsing this forum: No registered users and 1 guest