Hummingboard issue with "uboot-cubox-i 2017.01-1"

This forum is for supported devices using an ARMv7 Freescale SoC.

Hummingboard issue with "uboot-cubox-i 2017.01-1"

Postby lynx » Tue Feb 28, 2017 10:39 pm


I have a Hummingboard (IMX6) device and was running successfully ArchLinux for couple years installed by this guide: ... le/cubox-i

However after last update (mid February 2017) the device failed to reboot, I already lost all my settings and software configuration :( but would like to bring it back to live.

I tried to reinstall ArchLinux from the guide and it works fine, can be rebooted, and new software can be installed. But if I run "pacman -Suy" it brings the latest version of "uboot-cubox-i 2017.01-1". By the next reboot device will not start again, complaining about some files that cannot be found, and it falls into the infinite booting loop.

Does anybody has experienced something like that or am I the only lucky one?

I will appreciate any help with my problem! Any hint or link to a guide on how to install / upgrade the ArchLinux properly or migrate it to latest kernel. The original imx6 kernel is 3.14.x:
Code: Select all
[alarm@alarm ~]$ uname -a
Linux alarm 3.14.79-1-ARCH #1 SMP Tue Sep 13 01:21:17 MDT 2016 armv7l GNU/Linux

but I have seen people already mentioned that they are using latest kernels probably installed from here:

I really like ArchLinux for their minimalistic approach that fits my usage pattern for Hummingboard - small low-power server. However, if I do not find a solution, I'll have to switch to officially supported distros that come with pre-packed desktop environments that I do not need.

Thank you in advance!
Posts: 4
Joined: Wed Sep 19, 2012 9:37 pm

Re: Hummingboard issue with "uboot-cubox-i 2017.01-1"

Postby Polichronucci » Sun Mar 05, 2017 2:00 pm

Posts: 31
Joined: Wed Oct 09, 2013 10:47 am

Re: Hummingboard issue with "uboot-cubox-i 2017.01-1"

Postby Musikolo » Thu Mar 09, 2017 4:13 am

Hi Lynx,

I also had some issues when using the latest uboot version. My Cubox-ipro4 didn't boot up. After a lot of hours, I got to understand what changed:
- First of all, you should have a quick look at a bug I found in the documentation (viewtopic.php?f=45&t=11412)
- With the new uboot, your uEnv.txt file is not longer used/sourced.
- The replacement is the boot.txt file. You can move the arguments you were passing to the kernel to the new boot.txt file.
- After doing any change, you must call ./mksrc from your /boot directory to create a new boot.scr file. This step requires you to have the uboot-tools package installed.
- It's nice if you back up the boot.scr beforehand. You could restore it, in case you mess it up too much the boot.txt file.

If you don't want to use the new uboot and don't want pacman to annoy you all the time, you can do edit your /etc/pacman.conf file and add this:
Code: Select all

You can find out more about this at ... g_upgraded

I hope it helps!

Best regards.
Posts: 2
Joined: Fri Jul 25, 2014 3:56 am

Return to Freescale

Who is online

Users browsing this forum: No registered users and 1 guest