Built in Bluetooth CuBox i: brcm43xx failing to start

This forum is for supported devices using an ARMv7 Freescale SoC.

Built in Bluetooth CuBox i: brcm43xx failing to start

Postby Oleg » Sat Jan 06, 2018 11:07 pm

Hi, I use Arch Linux on CuBox i4x4 and i4pro, both of them have problems to start bluetooth service for built in bluetooth adapter as brcm43xx service fails to start:
Code: Select all
[root@alarm-4x4 oleg]# systemctl -l --no-pager status brcm43xx
* brcm43xx.service - Broadcom 43xx bluetooth HCI
   Loaded: loaded (/usr/lib/systemd/system/brcm43xx.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2018-01-06 16:12:14 CST; 12min ago
  Process: 2818 ExecStart=/usr/bin/hciattach -n /dev/brcm43xx any 3000000 (code=exited, status=203/EXEC)
 Main PID: 2818 (code=exited, status=203/EXEC)

Jan 06 16:12:14 alarm-4x4 systemd[1]: Started Broadcom 43xx bluetooth HCI.
Jan 06 16:12:14 alarm-4x4 systemd[2818]: brcm43xx.service: Failed to execute command: No such file or directory
Jan 06 16:12:14 alarm-4x4 systemd[2818]: brcm43xx.service: Failed at step EXEC spawning /usr/bin/hciattach: No such file or directory
Jan 06 16:12:14 alarm-4x4 systemd[1]: brcm43xx.service: Main process exited, code=exited, status=203/EXEC
Jan 06 16:12:14 alarm-4x4 systemd[1]: brcm43xx.service: Failed with result 'exit-code'.


Looks like this service tries to use /usr/bin/hciattach, it got obsolete with latest bluez, we need to use btattach now.

Would quite appreciate a fix for this issue. Thanks.
Oleg
 
Posts: 30
Joined: Tue Jun 23, 2015 1:28 pm

Return to Freescale

Who is online

Users browsing this forum: No registered users and 2 guests