[UDOO Quad] /dev/ttymxc3 gone after Update

This forum is for supported devices using an ARMv7 Freescale SoC.

[UDOO Quad] /dev/ttymxc3 gone after Update

Postby Cronix » Fri May 04, 2018 7:46 pm

Today i decided to pacman -Syu my udoo quad.
Afterwards /dev/ttymxc3 which is normally used to communicate with the internal arduino chip is not seen anymore.

dmesg also only lists mxc1:
[code
][ 0.000000] Kernel command line: console=ttymxc1,115200 root=PARTUUID=1a2074b4-01 rw rootwait video=
[ 0.000032] clocksource: mxc_timer1: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 637086815595 ns
[ 1.326888] clocksource: Switched to clocksource mxc_timer1
[ 1.770051] 21e8000.serial: ttymxc1 at MMIO 0x21e8000 (irq = 62, base_baud = 5000000) is a IMX
[ 2.644136] console [ttymxc1] enabled
[ 2.812692] ehci-mxc: Freescale On-Chip EHCI Host driver
[/code]

I tried rolling back the kernel to 4.7 which worked fine.
my assumption now is that something after kernel 4.7 broke the ttymxc3 serial detection
Cronix
 
Posts: 1
Joined: Fri May 04, 2018 7:29 pm

Return to Freescale

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests