Cubox 510 Total Memory only 632M

This forum is for supported devices using an ARMv7 Marvell SoC.

Cubox 510 Total Memory only 632M

Postby Iridium747 » Fri Jan 27, 2017 10:23 am

I have a CUBOX (Marvell/Armada) 510 running AL. It's used mainly for NFS and works well.
Hover on boot I see only 632M when the box has 1G. I've tried adjusting uboot but with zero luck.

I've run Simply Linux on it and that shows 832M total ram.

Is there any way to increase the memory closer to 1G as it's only used as a server, never a desktop?
Iridium747
 
Posts: 5
Joined: Fri Jan 27, 2017 10:17 am

Re: Cubox 510 Total Memory only 632M

Postby Falcon1 » Tue Apr 18, 2017 12:05 pm

Hi There,

Resurrecting my old cuboxes here. I'm new to Arch but that one I can anwser.

The rest of that memory is reserved for the GPU.

https://archlinuxarm.org/platforms/armv7/marvell/cubox
vmalloc=384M
Falcon1
 
Posts: 3
Joined: Tue Apr 18, 2017 12:00 pm

Re: Cubox 510 Total Memory only 632M

Postby Iridium747 » Sat Apr 29, 2017 6:14 pm

Thanks for the information, but is there anyway to eliminate the GPU setting, as I only ever use it at as a server and never need any graphics.
Iridium747
 
Posts: 5
Joined: Fri Jan 27, 2017 10:17 am

Re: Cubox 510 Total Memory only 632M

Postby Falcon1 » Fri May 05, 2017 3:06 pm

I guess you could. The kernel should panic if you go too low.
https://www.mythtv.org/wiki/Common_Prob ... _too_small

In the old Solid-Run forums there used to be info on how low you could get, IIRC.

You might need to compile your own kernel to omit GPU drivers that need that memory.
Falcon1
 
Posts: 3
Joined: Tue Apr 18, 2017 12:00 pm


Return to Marvell

Who is online

Users browsing this forum: No registered users and 1 guest