X11 on Odroid XU4

This forum is for supported devices using an ARMv7 Samsung SoC.

X11 on Odroid XU4

Postby moremilopls » Wed Feb 08, 2017 4:28 pm

Hi,

I'm having some difficulty getting xorg-server to run on my XU4.

The ARM developer site (https://developer.arm.com/products/soft ... li-drivers) mentions needing 2 sets of drivers, the kernel and user space drivers. It also says they're linked, so you need a compatible version. The latest version of the userspace drivers is r10p0, and the latest kernel space drivers are r16p0. Are these versions compatible, because it doesn't mention compatibility on the site anywhere I can find. Or am I barking up the wrong tree?

The odroid-xu3-libgl-x11 package in the repos is version r14p0-2, but this version doens't exist on the official site. I noticed that it was compiled just after the release of r16p0 on the mali dev site, so is it typo or are they different? This package provides odroid-xu3-libgl, but I can't find any packages that depend on this, so do I need to install it at all? Is this the user space or kernel space driver?

I could only find 1 package referencing mali and xu3/4 so can I assume that the kernel drivers are baked into my kernel package and the odroid-xu3-libgl-x11 package is the user space driver?

There are a few questions there so thanks in advance for any help.

Luke
moremilopls
 
Posts: 2
Joined: Thu Jan 26, 2017 3:07 am

Re: X11 on Odroid XU4

Postby Blueman55 » Sun Feb 12, 2017 11:39 pm

Running the same board and hitting the same problem. I think I actually got xfce to sortof work even without the following packages although this was a while ago and my memory is fuzzy.

odroid-xu3-libgl-x11
odroid-xu3-libgl-headers
xf86-video-armsoc-odroid

Now I just get a "cant open display" error when trying to run anything such as xclock and the like. Xfce still works though.

Guys in this thread talk about getting a mali driver to run on a xu3 and xu4 (http://forum.odroid.com/viewtopic.php?f=96&t=8334) but aside from playing with it a bit, i havent yet tried the driver myself. And when I was playing with it, I didn't get it to work. The guy that made the custom mali driver mentions later that they now have ones in the official repo so I'm not sure if he's still updating his costom driver or if his guide is still viable. As far as the driver coming in 2 pieces, I've read something similar. I'm leaning towards something being baked into the default kernal considering that I don't think I needed to install a mali driver for xfce to work. But thats just a guess on my part. No idea about compatibility Do you have a particular error?
Blueman55
 
Posts: 1
Joined: Sun Feb 12, 2017 11:12 pm

Re: X11 on Odroid XU4

Postby moremilopls » Mon Feb 13, 2017 4:15 pm

Thanks for replying.

I'm going to switch to the supported distro because it looks like they're making big improvements very soon.

I had a link but I can't find it now, there's a thread on the odroid forums where the admin says they're switching to the 4.9 kernel sometime in feb, and their forums are a lot more active.
moremilopls
 
Posts: 2
Joined: Thu Jan 26, 2017 3:07 am

Re: X11 on Odroid XU4

Postby merlinux » Sun Feb 19, 2017 3:22 am

Not sure what you guys are doing wrong but I'll detail the steps needed to get it to work,
You need the same versions of the mali driver in the kernel and userpsace blobs(odroid-xu3-libgl-x11).
There was a bug a few weeks ago where versions of the kernel and userpsace on ALARM differed but it has been fixed.
You also need a graphic driver which can use the mali hardware (xf86-video-armsoc-odroid). You must start X by service and not with startx! (something like lightdm).
Make sure you enable permission for the hardware with something like
Code: Select all
[merlin@xu4 ~]$ cat /etc/udev/rules.d/50-mali.rules
KERNEL=="mali*",SUBSYSTEM=="misc", MODE="0666", GROUP="video"
KERNEL=="ump",SUBSYSTEM=="ump",MODE="0666",GROUP="video"

Add your user to the video group and it should work.
Im not sure of the state of the default armsoc driver (mdrjr) as I am using a custom pkg based on a different branch with custom patches(similar to what meveric uses on his debian image)... You are free to try the PKGBUILD I am using if you run into problems at that stage. pkgbuild here

EDIT: you probably need this too :)
Code: Select all
[merlin@xu4 ~]$ cat /etc/X11/xorg.conf                   
Section "Device"
   Identifier "Mali-Fbdev"
   Driver   "armsoc"
   Option   "fbdev"           "/dev/fb0"
   Option  "DriverName"      "exynos"
   Option  "Debug" "false"
EndSection

Section "Screen"
   Identifier   "Mali-Screen"
   Device       "Mali-Fbdev"
   DefaultDepth 24
EndSection

Section "DRI"
   Mode 0666
EndSection

merlinux
 
Posts: 6
Joined: Fri Jan 27, 2017 9:16 am
Location: cairns, far north queensland, australia

Re: X11 on Odroid XU4

Postby usr238 » Thu Mar 16, 2017 10:00 pm

The above worked for me. Had to use chromium, alsa and pulse audio. Booting with lightdm? I never would've figured that out.

loaded libcec.

So far runs great. The major problem is that a few libraries that are listed as being in the repo aren't. For example SMplayer is listed but it's missing from the repo and blender wouldn't install but I found a work around by not asking for a version number of the missing python library.

All in all, so far so good.
usr238
 
Posts: 4
Joined: Thu Mar 16, 2017 9:50 pm


Return to Samsung

Who is online

Users browsing this forum: No registered users and 3 guests