ODROID-XU4 fails to boot after update

This forum is for supported devices using an ARMv7 Samsung SoC.

Re: ODROID-XU4 fails to boot after update

Postby usr238 » Thu Apr 13, 2017 8:20 am

4.9.20-3 works well for me and it made my day.

The new kernel got rid of some of the problems I was having, like I had to reboot after playing an mkv file with mpv or else my computer would lock up hard. I don't know if it was overheating, a memory leak or what.

Thanks to everyone who worked on this!
Posts: 4
Joined: Thu Mar 16, 2017 9:50 pm

Re: ODROID-XU4 fails to boot after update

Postby glenno » Thu Apr 13, 2017 11:14 am

How did everyone manage to make theirs boot? Did you have to do a parallel boot and mount the broken image and roll back the kernel?

Im running with an emmc so I figure ill do fresh build on SD card, boot it up that way and then repair the emmc
Posts: 15
Joined: Tue Jan 11, 2011 11:33 am

Re: ODROID-XU4 fails to boot after update

Postby JohnK » Wed Apr 19, 2017 8:22 am

I encountered this on my XU4 as well. It turns out that they changed how the boot.scr works slightly. I noticed this because there was a /boot/boot.scr.pacnew file that didn't exist before.

Most people can probably fix their setup by doing `sudo cp /boot/boot.scr /boot/boot.scr-old && sudo cp /boot/boot.scr.pacnew /boot/boot.scr`

I have a slightly weird setup so I grabbed the latest installation tarball and extracted the boot.txt to merge my custom config into and ran ./mkscr in /boot

I hope this helps someone.

NB ArchLinuxARM maintainers: please print out instructions when you change uBoot config so that people don't fall into this trap!
Posts: 1
Joined: Wed Apr 19, 2017 8:16 am

Re: ODROID-XU4 fails to boot after update

Postby jbodhorn » Mon May 22, 2017 11:23 pm

I've been paranoid about updating my odroid-xu4, I tried a while back and thankfully had an image to restore from. I use my odroid as a mini server/NAS so I haven't wanted to have any downtime. I'm currently waiting for about 3tb to copy from 4 different usb 3 drives to a single new 4tb drive, I guess once it finally finishes copying I'll get a fresh image and finally try to update again.

This isn't the first time I've had to deal with my odroid not booting after an update, because of this I tend to wait a while between each update a I always shutdown and dd a fresh image before each update anymore. This has rarely ever been an issue while running arch x86_64 on my laptops. Does anyone know why updates have been causing the odroids to not boot but not other devices, is this stricktly due to limited devs and limited testing?
Posts: 41
Joined: Wed Dec 16, 2015 2:22 am

Re: ODROID-XU4 fails to boot after update

Postby amiga23 » Sat Aug 12, 2017 7:55 am

Just for info

My XU4 did not boot after upgrading to newer Kernel versions. I did not care about for some months. Today I finally tried to fix it. It did boot fine via SD Card but not via eMMC and also not with eMMC and SD Adapter.

The issue on my XU4 was that the eMMC modules root partition does not have a PARTUUID.
As I did not find a way to create a PARTUUID without destroying all data, I did simply change the boot.txt to use /dev/mmcblk0p1 as root partition.

Now my XU4 works fine again.
Posts: 6
Joined: Fri Sep 02, 2016 6:23 pm

Re: ODROID-XU4 fails to boot after update

Postby aphirst » Wed Sep 06, 2017 10:40 am

@amiga23 Are you able to clarify more closely what you did? I'm experiencing what might be a similar issue which I posted about in my own thread. I don't fully understand what modification would need to be made to boot.txt, as I don't even see which part refers to which root partition to use.

EDIT: As can be seen in my thread, I seem to have resolved my issue on my own, by leaving the device for some time before my subsequent boot attempts.
Posts: 14
Joined: Wed Sep 06, 2017 10:09 am

Re: ODROID-XU4 fails to boot after update

Postby amiga23 » Fri Sep 08, 2017 7:17 pm

@aphirst great that you resolved your issue.

So maybe just for documentation:

The blkid command should show a PARTUUID for the root partition, but did not in my case.
In /boot/boot.txt I have set the root partition to
in the "setenv bootargs" line, instead of using the PARTUUID.

After changing the boot.txt it is necessary to run
and the sd_fusing.sh
./sd_fusing.sh <SD Reader's device file>
Posts: 6
Joined: Fri Sep 02, 2016 6:23 pm


Return to Samsung

Who is online

Users browsing this forum: No registered users and 2 guests