ODROID-XU4 fails to boot after update

This forum is for supported devices using an ARMv7 Samsung SoC.

Re: ODROID-XU4 fails to boot after update

Postby BombusRidiculus » Thu Apr 06, 2017 7:39 pm

At this point it's clear there is a significant percentage of XU3 and XU4 users (myself included) that have tested all the Arch 4.9.x kernels so far (the 4.9.13-xyz series, and the new 4.9.20 revision) and it's getting stuck at "Starting kernel"

On the other hand I've been compiling the Hardkernel 4.9.x kernels for their Ubuntu distribution from the designated Git location and no problems there...
BombusRidiculus
 
Posts: 4
Joined: Wed Aug 24, 2016 10:45 am

Re: ODROID-XU4 fails to boot after update

Postby uweonarm » Fri Apr 07, 2017 1:45 pm

Hello,
If the update-problem on right ? My son is missing it's minecraft server. I wait for fixing the update's.
I have a lot of problems to make my other Odroid C2 for desktop. I search for a manual.
Greetings Uwe
uweonarm
 
Posts: 1
Joined: Fri Apr 07, 2017 1:35 pm

Re: ODROID-XU4 fails to boot after update

Postby usr238 » Fri Apr 07, 2017 4:03 pm

I updated my XU4 with pacman -Syyu and it's working. It won't reboot but I can shutdown and then power it on and that works fine. When I reboot the XU4 shutsdown however once down the fan runs continuously and the XU4 appears locked up hard, I have unplug the power it off and then plug it in again.

I have a fairly new XU4, Rev 1.0 20151201

When updating I got the message "No installed modules, this is probably not what you want." But once it powered up lsmod showed several installed modules. Besides reboot, everything appears to be working.
usr238
 
Posts: 4
Joined: Thu Mar 16, 2017 9:50 pm

Re: ODROID-XU4 fails to boot after update

Postby glenno » Sat Apr 08, 2017 5:00 am

Adding a 'me to' to this thread. Ive been running for about 10months on my current XU4 build. Been away for a month so just ran an upgrade to 4.9.20-2 and I am now at the Starting kernel ... screen.
glenno
 
Posts: 15
Joined: Tue Jan 11, 2011 11:33 am

Re: ODROID-XU4 fails to boot after update

Postby usr238 » Sat Apr 08, 2017 8:52 am

Updated yesterday with Syyu and everything worked except for rebooting.

Started it up just now and it locked up, the fan continuously ran and no video where normally it boots up to login in about 10sec.

Powered it off and powered it on and it booted up.
usr238
 
Posts: 4
Joined: Thu Mar 16, 2017 9:50 pm

Re: ODROID-XU4 fails to boot after update

Postby mich04 » Sat Apr 08, 2017 10:45 pm

Does anyone know where I can get an older image. I don't have backups of any. My little odroid was running just fine I went to try and update and would not boot. I thought maybe I had messed up the proper update procedure. I have been trying all day today to get my system back up and running.

The last time this happened I had used gparted to format the sd card. This time that method is not working I have also tried three different sd cards in addition to using a usb card reader and also trying a regular card adapter. /dev/sdx vs /dev/mmcblk0
mich04
 
Posts: 8
Joined: Sat Dec 12, 2015 2:58 am

Re: ODROID-XU4 fails to boot after update

Postby skrooge » Wed Apr 12, 2017 2:00 am

kernel 4.9.20-3 is now booting on my XU3 on both SDcard and emmc.

everything seems to be working, though graphics are very slow in Xorg.
skrooge
 
Posts: 5
Joined: Wed Jan 22, 2014 11:58 am

Re: ODROID-XU4 fails to boot after update

Postby zskolnik » Wed Apr 12, 2017 7:30 pm

Kernel 4.9.20-3 works here as well, both by upgrading a 3.x kernel or by doing a clean installation on a microSD card.

Some notes for the upgrading from my experience that may cause some issuse (Please note that I boot from microSD, I have no eMMC module. I do not know how the changes below affect an eMMC setup):
-The internal microsd card reader is now accessible at /dev/mmcblk1 instead of /dev/mmcblk0
-The shutdown process takes around 10 seconds to start after the command ("shutdown now") is issued, this affects reboots too.
-The LED controls are no longer found at /sys/device/leds.15/leds, use /sys/class/leds instead

After fixing the configuration files according to these changes in my setup everything seems to be working nicely.
zskolnik
 
Posts: 2
Joined: Tue Apr 04, 2017 7:11 pm

Re: ODROID-XU4 fails to boot after update

Postby BombusRidiculus » Wed Apr 12, 2017 10:41 pm

I can also confirm that 4.9.20-3 is the first 4.9.x-y series kernel that works for me.

One note that may help users that boot their rootfs from an external USB3 harddisk, is that (unlike the 3.10.x kernel booting process that was more permissive) I was forced to insert a rootdelay=20 attribute set in the emmc's /boot/boot.txt , on the setenv bootargs line (and of course, perforn ./mkscr afterwards), otherwise the hdd partition was not ready in time
BombusRidiculus
 
Posts: 4
Joined: Wed Aug 24, 2016 10:45 am

Re: ODROID-XU4 fails to boot after update

Postby mich04 » Thu Apr 13, 2017 4:00 am

I am not sure what happened but now I am able to install again, I didn't change anything, it just works now.
mich04
 
Posts: 8
Joined: Sat Dec 12, 2015 2:58 am

PreviousNext

Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest