How to make Kodi and EGL working on Odroid XU3/XU4

This forum is for supported devices using an ARMv7 Samsung SoC.

How to make Kodi and EGL working on Odroid XU3/XU4

Postby nicolasvila » Tue Apr 18, 2017 9:52 am

Hi.

I have an Odroid XU4 running Debian Jessie and willing to switch to ArchLinuxARM.
I'm trying to get hardware acceleration and Kodi working but I'm a bit lost
Does anybody managed to make the hardware acceleration work?

Here are the packages currently installed on my system:
core/linux-odroid-xu3
core/linux-odroid-xu3-headers
alarm/odroid-xu3-libgl-fb
alarm/odroid-xu3-libgl-headers
alarm/uboot-odroid-xu3

I tried both:
xf86-video-armsoc-alt (from https://github.com/merlinux81/odroid-xu ... ee/testing)
xf86-video-armsoc-odroid (from alarm)
and also tried to replace install odroid-xu3-libgl-x11 instead of alarm/odroid-xu3-libgl-fb but still no luck

My udev configuration: /etc/udev/rules.d/10-odroid.rules
Code: Select all
KERNEL=="mali",SUBSYSTEM=="misc",MODE="0777"
KERNEL=="mali0",SUBSYSTEM=="misc",MODE="0777"
KERNEL=="ump",SUBSYSTEM=="ump",MODE="0777"
KERNEL=="ttySAC0", SYMLINK+="ttyACM99"
KERNEL=="event*", SUBSYSTEM=="input", MODE="0777"
KERNEL=="CEC", MODE="0777"
KERNEL=="amvideo", MODE="0666"
KERNEL=="amstream*", MODE="0666"
KERNEL=="mali",SUBSYSTEM=="misc",MODE="0777"
KERNEL=="mali0",SUBSYSTEM=="misc",MODE="0777"
KERNEL=="ump",SUBSYSTEM=="ump",MODE="0777"
KERNEL=="ttySAC0", SYMLINK+="ttyACM99"
KERNEL=="event*", SUBSYSTEM=="input", MODE="0777"
KERNEL=="CEC", MODE="0777"
KERNEL=="amvideo", MODE="0666"
KERNEL=="amstream*", MODE="0666"


My /etc/X11/xorg.conf:
Code: Select all
Section "Device"
   Identifier "Mali-Fbdev"
   Driver "armsoc"
   Option "fbdev" "/dev/fb0"
   Option "Debug" "false"
   Option "DPMS" "false"
EndSection
Section "Screen"
   Identifier "Default Screen"
   Device "Mali-Fbdev"
   DefaultDepth 24
EndSection
Section "ServerLayout"
   Identifier "Default Layout"
   Option "BlankTime" "0"
   Option "StandbyTime" "0"
   Option "SuspendTime" "0"
   Option "OffTime" "0"
EndSection
Section "DRI"
   Mode 0666
EndSection


Could you please tell me how did you do to make Kodi work on the XU4?
Last thing, when I try to run es2_info, I got
Code: Select all
Error: eglGetDisplay() failed


Thanks for your help
nicolasvila
 
Posts: 2
Joined: Tue Apr 18, 2017 9:46 am

Return to Samsung

Who is online

Users browsing this forum: No registered users and 2 guests