[SOLVED?] [ODROID-XU4] Cannot boot from eMMC, fine from µSD

This forum is for supported devices using an ARMv7 Samsung SoC.

[SOLVED?] [ODROID-XU4] Cannot boot from eMMC, fine from µSD

Postby aphirst » Wed Sep 06, 2017 10:20 am

I followed the installation instructions on the alarm wiki to the letter, intending to use my new ODROID-XU4 with a 16GB eMMC card.

However, booting in µSD mode using the eMMC card (using the eMMC-to-µSD adapter, with the XU4 switch set to "µSD") is unsuccessful (no fan spin-up, I don't have the serial connector so I'm not going to be able to get much extra info). Booting is of course also not possible from the eMMC when plugged directly into the eMMC (with the XU4 switch set to "eMMC"), since clearly the final bootloader stage was not yet completed.

To rule out the possibility of (total) board failure, I also decided to test using a real 64GB µSD card. I again followed the wiki instructions, inserted the µSD, set the switch to µSD, and turned on the power. The device boots perfectly fine (fan spins up, can connect via SSH).

This is where it gets interesting. I had left the eMMC card plugged into the eMMC port on the board, which can be seen with the output of `lsblk`. Pay close attention to the partition sizes, and the previously mentioned card sizes (64GB µSD, 16GB eMMC):

Code: Select all
[alarm@alarm ~]$ lsblk
mmcblk1      179:0    0 59.5G  0 disk
`-mmcblk1p1  179:1    0 59.5G  0 part
mmcblk0      179:16   0 14.7G  0 disk
`-mmcblk0p1  179:17   0 14.7G  0 part /
mmcblk0boot0 179:32   0    4M  1 disk
mmcblk0boot1 179:48   0    4M  1 disk
mmcblk0rpmb  179:64   0    4M  0 disk

It seems that despite "booting" from the µSD, I'm actually loading Arch itself from the eMMC slot. Out of curiosity I tried running the sd_fusing script from this session, giving it the eMMC device /dev/mmcblk0 but this had no effect (booting in "eMMC mode" still fails).

How might I further diagnose this? What further info (short of my purchasing the serial adapter) would be useful for me to provide?

I very much look forward to any input.
Last edited by aphirst on Fri Sep 15, 2017 10:55 am, edited 1 time in total.
Posts: 14
Joined: Wed Sep 06, 2017 10:09 am

Re: [ODROID-XU4] Cannot boot from eMMC, boots fine from µSD

Postby aphirst » Thu Sep 07, 2017 7:11 am

I came back to this a few hours later (last night) and bizarrely, I was in fact able to boot from eMMC (with the µSD removed). It seems my attempt to perform the sd_fusing was actually successful.

I now suspect the problem to be the device being very sensitive regarding its power supply - when switching the wall socket off it is necessary for me to wait up to 30 seconds for the subsequent boot attempt to be successful (taking almost this long for the red LED to fade). Trying too soon just results in the device laying dormant.

Manual (SSH) rebooting of the device has no problem, which makes me suspect the power supply itself (from an odroid reseller in my region, liymo) of, for example, having a capacitor which takes a long time to discharge, and the board being unable to boot properly having never fully disengaged. This is however of course just speculation.

I'm now having some other problems with the device, which I'll defer to a separate thread.
Posts: 14
Joined: Wed Sep 06, 2017 10:09 am

Re: [SOLVED?] [ODROID-XU4] Cannot boot from eMMC, fine from

Postby pogojotz » Fri Nov 03, 2017 1:52 pm

I have made the same discovery with a 16GB SD card and a 64GB eMMC card. I tested this on 3 different ODROID XU4 with 2 different eMMC cards, so hardware failure may be excluded.
This is a nice workaround, but in the end this issue should either be fixed or the workaround presented in the installation instructions. Is there a bug report present on this?
Posts: 4
Joined: Thu Nov 02, 2017 9:36 am

Re: [SOLVED?] [ODROID-XU4] Cannot boot from eMMC, fine from

Postby karog » Fri Nov 03, 2017 6:53 pm

See from 2 years ago, 3rd post in Odroid XU4 eMMC installation problem
Posts: 238
Joined: Thu Jan 05, 2012 7:55 pm

Re: [SOLVED?] [ODROID-XU4] Cannot boot from eMMC, fine from

Postby pogojotz » Mon Nov 06, 2017 3:03 pm

I didn't know this discrepancy between installation instruction and real world was known for 2 years :shock:
This cost me several hours of self blaming and retrying the process over and over. The instruction should really be updated.
Posts: 4
Joined: Thu Nov 02, 2017 9:36 am

Re: [SOLVED?] [ODROID-XU4] Cannot boot from eMMC, fine from

Postby beedaddy » Wed Jan 24, 2018 7:32 am

I, too, vote for updating the installation instructions. I suffered from this problem, too, spending an evening with trial and error. I was close to the solution, but not close enough. ;)
Thanks to this forum, I will try it again and I'm pretty sure that it will work. But, having an updated installation instruction would be fine and would have saved some debugging hours. ;)
Posts: 2
Joined: Wed Jan 24, 2018 7:15 am

Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest