Installing ALARM on Snow (xe303c12-a01us)

This forum is for supported devices using an ARMv7 Samsung SoC.

Installing ALARM on Snow (xe303c12-a01us)

Postby Blowinup » Sat Aug 31, 2019 7:29 pm

Using the following instructions to install ALARM on an SD Card:

I successfully completed all of the steps without any errors or issues and excitedly rebooted. Unfortunately it fails to boot from the SD Card I used. I verified all of the files are there but Control-U only returns a loud beep then a pause followed by two beeps before it boots to CrOS.

I've tried the following to resolve:

In the following post Stahna asserts, "You must use cgpt to repair the partition table on the USB or it won't work"!

I know Stahna was using Kali and not ALARM but it seemed worth a try. So I tried ran cgpt -repair on both /dev/mmcblk1p1 and /dev/mmcblk1p2 . Both returned the following:

WARNING: Primary GPT header is invalid
WARNING: Secondary GPT header is invalid

QUESTION: Is this a problem and, if so, how do I fix it?

Stahna next states, "Then use the cgpt command again to set your boot priority to the USB... I simply set the KERN-A (for SD card boot) priority to 5 and the KERN-B (for USB boot) priority to 10".

Something similar is mentioned here that appears to refer more specifically to ALARM;

I see that there are options for 'boot' and 'priority but I can't find any info on how to use these. I've searched but haven't found anything more than cgpt --help offers which is nothing for than listing the options. I've also tried guessing at the syntax but just keep getting the same list of options so I'm obviously not guessing right.

QUESTION: How do I set boot priority with cgpt? Do I need a customer bootloader?

It's also been suggested that I need to put my BIOS in developer mode using the following:

localhost login: chronos
chronos@localhost $ sudo bash
localhost chronos # chromeos-firmwareupdate --mode=todev

I tried that and get an error indicating 'todev' is an invalid mode.

I've put a lot of work into this and feel like I may be close. Or maybe I'm way off base and need to start over. The Arm page on indicates that only a USB can be used to boot to a non CrOS but there appears to be a lot of people, obviously much smarted than me, who have gotten it to boot from an SD Card.

Next step will be to start over with a USB instead of SD Card but I sure would be grateful if someone would be so kind as to offer some guidance before I start from scratch.

Thanks in advance!
Posts: 1
Joined: Fri Aug 30, 2019 10:54 pm

Re: Installing ALARM on Snow (xe303c12-a01us)

Postby ExTechOp » Thu Oct 10, 2019 7:48 am

I have exactly the same issue, and I tried installing onto USB, so the media type probably is not the problem. Could the current install image somehow be incompatible with this hardware? How would one go about debugging this issue, as the beeps don't convey much information about what's wrong?
Posts: 3
Joined: Tue Oct 08, 2019 12:17 pm

Re: Installing ALARM on Snow (xe303c12-a01us)

Postby ExTechOp » Tue Oct 15, 2019 9:37 am

A quick test of pre-built Kali Linux 2019.3 reveals that it boots without problems (but then has some issues with the graphics card). So, it seems that the boot problem is with Archlinux. Again, anyone have ideas about how to go about debugging this?
Posts: 3
Joined: Tue Oct 08, 2019 12:17 pm

Return to Samsung

Who is online

Users browsing this forum: No registered users and 2 guests