Problem with CEC and ODROID U2 (Exynos 4412)

This forum is for supported devices using an ARMv7 Samsung SoC.

Problem with CEC and ODROID U2 (Exynos 4412)

Postby JSerra » Wed Aug 28, 2013 9:58 am

Hello, Im trying to get CEC work on an ODROID U2 with Arch Linux.

If I run in a terminal:
Code: Select all
# cec-client /dev/CEC

This is the output:
Code: Select all
No device type given. Using 'recording device'
CEC Parser created - libCEC version 2.1.3
opening a connection to the CEC adapter...
DEBUG:   [               3]   unregistering all CEC clients
DEBUG:   [               3]   Broadcast (F): osd name set to 'Broadcast'
ERROR:   [            3507]   error opening serial port '/dev/CEC': Device or resource busy

I installed linux from the image file of Arch Linux Web page: ArchLinuxARM-2013.07-odroid-u2.img

I'm thinking that maybe i've a problem with the libcec dependencies.
These are the dependences for libcec from libcec readme file:
libCEC needs the following dependencies in order to work correctly:
* udev v151 or later
* cdc-acm support compiled into the kernel or available as module
* liblockdev 1.0 or later

If I type #pacman -S udev
warning: systemd-204-3 is up to date -- reinstalling (that means udev is included in that package?)
I have found a packge (lockdev) but no liblockdev

To compile libCEC on Linux, you'll need the following dependencies:
* autoconf 2.13 or later
* automake 1.11 or later
* libtool
* gcc 4.2 or later
* liblockdev 1.0 development headers

(I cant find a liblockde1-dev package as in raspbian repository)

The following dependencies are recommended. Without them, the adapter can not
be auto-detected.
* pkg-config
* udev development headers v151 or later

(I cant find a libudev-dev package as in raspbian repository)

I get the source code for libcec from here:

I'm usisng the Arch Linux Kernel(not the one sugested in And i followed these steps:
Code: Select all
#git clone --branch=exynos
#cd libcec
#./configure --enable-exynos

when configure ends it shows:
Code: Select all
libCEC version 2:1:0 configured

Compilation flags:
  CXXFLAGS :       -g -O2 -fPIC -Wall -Wextra -Wno-missing-field-initializers
  libCEC LDFLAGS : -llockdev -ldl -lpthread  -ludev
  client LDFLAGS : -ldl -lpthread

Configured features:
  Pulse-Eight CEC Adapter :      yes
  Pulse-Eight CEC Adapter detection :   yes
  Raspberry Pi support :      no
  TDA995x support :         no
  Exynos support :         yes

You can now build libCEC by running:

Then I ran make and make install and everything seemed normal, despite the dependecies issue, commented earlier in this post.

I think that this kernel has support for CEC because when i run:
Code: Select all
# dmesg | grep cec
[    0.170000] s5p_hdmi_cec_set_platdata()
[    2.990000] s5p-cec s5p-cec: Probe start
[    2.995000] s5p-cec s5p-cec: s5p_cec_probe: pdata=ed0bce40
[    3.000000] s5p-cec s5p-cec: s5p_cec_mem_probe(): mapped cec_base to f0046000, size 0x1000
[    3.005000] s5p-cec s5p-cec: Requesting irq 146 for s5p-cec
[    3.015000] s5p-cec s5p-cec: probe successful

Tried to change the permisions of /dev/CEC, and also of /var/lock just in case
also check with
Code: Select all
#fuser /dev/CEC
but there is no other procces using it.

Thank you. Best regards.
Posts: 3
Joined: Wed Aug 28, 2013 9:49 am

Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest